aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portlint
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2018-11-19 20:05:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2018-11-19 20:05:38 +0000
commit2a9aad72f41a1ead39b606832c787a17752ec9f2 (patch)
tree3c08ea2cad950af2f4eda243a6a4f288f75bd49d /ports-mgmt/portlint
parent2eabd23240c584353e06c856df3aee2ef3333959 (diff)
downloadports-2a9aad72f41a1ead39b606832c787a17752ec9f2.tar.gz
ports-2a9aad72f41a1ead39b606832c787a17752ec9f2.zip
Remove the warnings around USE_PYTHON and autoplist.
You can use autoplist with a pkg-plist or PLIST_*. Some ports require this apparently. Remove these warnings for now until a more robust duplicate-checking solution can be implemented. Reported by: koobs
Notes
Notes: svn path=/head/; revision=485359
Diffstat (limited to 'ports-mgmt/portlint')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl12
2 files changed, 3 insertions, 11 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 504eba6fbb15..d64218a1d7e6 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.18.6
+PORTVERSION= 2.18.7
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 6af24f451a88..0ef9b0d75248 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.482 2018/10/14 17:47:55 jclarke Exp $
+# $MCom: portlint/portlint.pl,v 1.484 2018/11/19 20:03:35 jclarke Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 18;
-my $micro = 6;
+my $micro = 7;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -1503,16 +1503,8 @@ sub checkmakefile {
my $python_plist = 0;
if ($makevar{USE_PYTHON} && $makevar{USE_PYTHON} =~ /\bautoplist\b/) {
$python_plist = 1;
- if (-f 'pkg-plist') {
- &perror("WARN", $file, -1, "If you are using python and using autoplist ".
- "you may remove the pkg-plist file.");
- }
}
if ($whole =~ /\nPLIST_FILES.?=/ || $whole =~ /\nPLIST_DIRS.?=/) {
- if ($python_plist) {
- &perror("WARN", $file, -1, "If you are using python and using autoplist you may ".
- "remove the definition of PLIST_FILE.");
- }
if (-f 'pkg-plist') {
my $lineno = &linenumber($`);
&perror("WARN", $file, $lineno, "You may remove pkg-plist ".