aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portlint
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2016-11-11 02:13:40 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2016-11-11 02:13:40 +0000
commit7ff2ece9967bd593ca345a5860426aa002c12fb8 (patch)
treee3e048b60b5e5c14533ea3279f41fa969df2854f /ports-mgmt/portlint
parent73769ba3cad9ea1303dbe7fdda75d6b64edaa76f (diff)
downloadports-7ff2ece9967bd593ca345a5860426aa002c12fb8.tar.gz
ports-7ff2ece9967bd593ca345a5860426aa002c12fb8.zip
Notes
Diffstat (limited to 'ports-mgmt/portlint')
-rw-r--r--ports-mgmt/portlint/Makefile1
-rw-r--r--ports-mgmt/portlint/src/portlint.pl6
2 files changed, 4 insertions, 3 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 008571337ab9..542810a717fe 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -3,6 +3,7 @@
PORTNAME= portlint
PORTVERSION= 2.17.5
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 97c4bce59844..f48c996d09df 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.396 2016/11/09 00:33:57 jclarke Exp $
+# $MCom: portlint/portlint.pl,v 1.397 2016/11/11 02:12:15 jclarke Exp $
#
use strict;
@@ -395,10 +395,10 @@ sub checkdistinfo {
}
if (/^TIMESTAMP\s+=\s+(\d+)$/) {
my $now = time;
- if ($_ > $now) {
+ if ($1 > $now) {
&perror("FATAL", $file, $., "TIMESTAMP is in the future");
} else {
- if ($now - $_ > 2592000) {
+ if ($now - $1 > (30 * 60 * 60 * 24)) {
&perror("WARN", $file, $., "TIMESTAMP is over 30 days old");
}
}