aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/ports-tools
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2017-01-30 21:07:01 +0000
committerPawel Pekala <pawel@FreeBSD.org>2017-01-30 21:07:01 +0000
commit57724e7d875390ca7f2cc9ccdcfcb7d148a44d18 (patch)
treed1f41ea56eaf58afb023a96566abd3badb5a3490 /ports-mgmt/ports-tools
parent4f77e25036f9564f009aed8eae92bf364a6ebfd1 (diff)
downloadports-57724e7d875390ca7f2cc9ccdcfcb7d148a44d18.tar.gz
ports-57724e7d875390ca7f2cc9ccdcfcb7d148a44d18.zip
Add collection of my ports tree related scripts
mkpatch ------- Makes patch from (all or pattern matched) modified files in WRKSRC directory. pcheck ------ Check for various errors that portlint don't catch: * misspellings in description files * files with no final new lines * leading articles in COMMENT, tabs in WWW lines pclean ------ Keeps your ports svn repo tidy, removes work directories, leftover files and reverts any changes made. pcommit ------- Wrapper for svn commit, removes and adds files, sets props, etc. pfind ----- Simple port's search wrapper. Search parameters include build dependency, category, name, maintainer, regexp pattern and slave ports. pkg-deleaf ---------- Leaf package remover with nice dialog interface. plist-sort ---------- Smart plist sorter which understands PLIST_SUB substitutions and options determined conditional files. plist-update ------------ Script utilizing check-plist port's framework target output for updating outdated pkg-plist, understands PLIST_SUB substitutions and sorts final files list. plog ---- Easy way to send poudriere build logs to your FreeBSD account by scp or view them on your computer. reinplace-check --------------- Checks for files with stale REINPLACE_CMD actions or shows diff's of them. tbuilder -------- Poudriere testport wrapper that makes easier to queue multiple builds of: - specific port - ports linking with certain library - ports with certain names - ports with Makefile matching regular expression - slave ports etc. upgrade-base ------------ Helper script for upgrading FreeBSD base. Detects and sets number of make jobs possible. After upgrade rebuilds ports with kernel modules and offers to remove old files using dialog inerface. upgrade-ports ------------- Helper script for updating ports tree and upgrading your ports. Combining information gathered from UPDATING and MOVED files tries to provide upgrade process as problem free as possible. This includes showing new UPDATING entries since last upgrade, ports origin move tracking, simple conflict resolution, removal of obsolete ports and sanity checking afterwards. Before any change is made user is presented with summary of changes intended similiar to pkg upgrade.
Notes
Notes: svn path=/head/; revision=432868
Diffstat (limited to 'ports-mgmt/ports-tools')
-rw-r--r--ports-mgmt/ports-tools/Makefile25
-rw-r--r--ports-mgmt/ports-tools/distinfo3
-rw-r--r--ports-mgmt/ports-tools/pkg-descr3
3 files changed, 31 insertions, 0 deletions
diff --git a/ports-mgmt/ports-tools/Makefile b/ports-mgmt/ports-tools/Makefile
new file mode 100644
index 000000000000..650325b02305
--- /dev/null
+++ b/ports-mgmt/ports-tools/Makefile
@@ -0,0 +1,25 @@
+# Created by: Pawel Pekala <pawel@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ports-tools
+PORTVERSION= 1.0
+CATEGORIES= ports-mgmt
+
+MAINTAINER= pawel@FreeBSD.org
+COMMENT= Collection of ports tree related scripts
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= ppekala
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= bin/mkpatch bin/pcheck bin/pclean bin/pcommit bin/pfind \
+ bin/plist-sort bin/plist-update bin/plog bin/reinplace-check \
+ sbin/pkg-deleaf sbin/tbuilder sbin/upgrade-base \
+ sbin/upgrade-ports
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/ports-tools/distinfo b/ports-mgmt/ports-tools/distinfo
new file mode 100644
index 000000000000..34c3255ec6c9
--- /dev/null
+++ b/ports-mgmt/ports-tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1485809693
+SHA256 (ppekala-ports-tools-1.0_GH0.tar.gz) = 201f8254ae44226ce0a11eee50358b727a9dc16ba684875cbac9f20451fc5ebf
+SIZE (ppekala-ports-tools-1.0_GH0.tar.gz) = 18552
diff --git a/ports-mgmt/ports-tools/pkg-descr b/ports-mgmt/ports-tools/pkg-descr
new file mode 100644
index 000000000000..354647e59b69
--- /dev/null
+++ b/ports-mgmt/ports-tools/pkg-descr
@@ -0,0 +1,3 @@
+Collection of scripts making things easier when working with ports tree.
+
+WWW: https://github.com/ppekala/ports-tools