aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/porttools
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-24 14:56:17 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-24 14:56:17 +0000
commitea6723045bdb66d15822d0d3fcbe21970e4da6dc (patch)
tree5fc12a8e6d12603849cd5011a6077ac5df52c163 /ports-mgmt/porttools
parentdf0d3a1a8dd931c4e8ab317bd7551c161763ad92 (diff)
downloadports-ea6723045bdb66d15822d0d3fcbe21970e4da6dc.tar.gz
ports-ea6723045bdb66d15822d0d3fcbe21970e4da6dc.zip
- Fix commandline arguments handling (again)
Notes
Notes: svn path=/head/; revision=220696
Diffstat (limited to 'ports-mgmt/porttools')
-rw-r--r--ports-mgmt/porttools/Makefile2
-rw-r--r--ports-mgmt/porttools/files/patch-arguments-parsing12
2 files changed, 7 insertions, 7 deletions
diff --git a/ports-mgmt/porttools/Makefile b/ports-mgmt/porttools/Makefile
index 71b6549b679d..771b11d5925f 100644
--- a/ports-mgmt/porttools/Makefile
+++ b/ports-mgmt/porttools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= porttools
PORTVERSION= 0.77
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ports-mgmt
MASTER_SITES= SF
diff --git a/ports-mgmt/porttools/files/patch-arguments-parsing b/ports-mgmt/porttools/files/patch-arguments-parsing
index 63b94d8c4d69..c8a2c416dcf2 100644
--- a/ports-mgmt/porttools/files/patch-arguments-parsing
+++ b/ports-mgmt/porttools/files/patch-arguments-parsing
@@ -7,7 +7,7 @@ diff -ruN cmd_commit.in.orig cmd_commit.in
set -- $ARGS
-for i
-do
-+while [ x"" != x"--" -a x"" != x"" ]
++while [ x"$1" != x"--" -a x"$1" != x"" ]
+do
+ i=$1
case "$i" in
@@ -22,7 +22,7 @@ diff -ruN cmd_diff.in.orig cmd_diff.in
set -- $ARGS
-for i
-do
-+while [ x"" != x"--" -a x"" != x"" ]
++while [ x"$1" != x"--" -a x"$1" != x"" ]
+do
+ i=$1
case "$i" in
@@ -37,7 +37,7 @@ diff -ruN cmd_install.in.orig cmd_install.in
set -- $ARGS
-for i
-do
-+while [ x"" != x"--" -a x"" != x"" ]
++while [ x"$1" != x"--" -a x"$1" != x"" ]
+do
+ i=$1
case "$i" in
@@ -52,7 +52,7 @@ diff -ruN cmd_submit.in.orig cmd_submit.in
set -- $ARGS
-for i
-do
-+while [ x"" != x"--" -a x"" != x"" ]
++while [ x"$1" != x"--" -a x"$1" != x"" ]
+do
+ i=$1
case "$i" in
@@ -67,7 +67,7 @@ diff -ruN cmd_test.in.orig cmd_test.in
set -- $ARGS
-for i
-do
-+while [ x"" != x"--" -a x"" != x"" ]
++while [ x"$1" != x"--" -a x"$1" != x"" ]
+do
+ i=$1
case "$i" in
@@ -82,7 +82,7 @@ diff -ruN cmd_upgrade.in.orig cmd_upgrade.in
set -- $ARGS
-for i
-do
-+while [ x"" != x"--" -a x"" != x"" ]
++while [ x"$1" != x"--" -a x"$1" != x"" ]
+do
+ i=$1
case "$i" in