aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/porttools
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2012-04-28 07:58:13 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2012-04-28 07:58:13 +0000
commitf86a87c735218d54f0d29464ebfaabdc3c284ab5 (patch)
tree0afa36daedab811b078740d905a7bc15015921fe /ports-mgmt/porttools
parent2f5f7c51dbe2bde2ce382778cf62285493ea14f3 (diff)
downloadports-f86a87c735218d54f0d29464ebfaabdc3c284ab5.tar.gz
ports-f86a87c735218d54f0d29464ebfaabdc3c284ab5.zip
- Avoid literal appearances of "$FreeBSD:...$" in patch-util_diff.in.
- While we are here: - Make the affected sed pattern more flexible with regard to the repository path from which the port was checked out. - When handling -d <dir>, if the port's directory does not exist, fix the path used in the first check for an alternative path. - Bump PORTREVISION. PR: ports/166593 Submitted by: Johannes Joemann <joemann@beefree.free.de> (maintainer)
Notes
Notes: svn path=/head/; revision=295643
Diffstat (limited to 'ports-mgmt/porttools')
-rw-r--r--ports-mgmt/porttools/Makefile2
-rw-r--r--ports-mgmt/porttools/files/patch-util_diff.in4
2 files changed, 3 insertions, 3 deletions
diff --git a/ports-mgmt/porttools/Makefile b/ports-mgmt/porttools/Makefile
index 62e68b8fbfd5..5cae00d24a5c 100644
--- a/ports-mgmt/porttools/Makefile
+++ b/ports-mgmt/porttools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= porttools
PORTVERSION= 0.99
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= ports-mgmt
MASTER_SITES= SF
diff --git a/ports-mgmt/porttools/files/patch-util_diff.in b/ports-mgmt/porttools/files/patch-util_diff.in
index e5428cddfc28..c7d07a8f22e3 100644
--- a/ports-mgmt/porttools/files/patch-util_diff.in
+++ b/ports-mgmt/porttools/files/patch-util_diff.in
@@ -90,7 +90,7 @@
else
# Non-CVS modes
+ DIRBASENAME=`basename \`pwd\``
-+ PORTBASENAME_HEADER=`sed -n -E -e '1,/^($|[^#].*$)|\\$FreeBSD: /tmp/pcvs/ports/ports-mgmt/porttools/files/patch-util_diff.in,v 1.5 2012-03-03 13:31:02 crees Exp $FreeBSD:[[:space:]]*ports/([^/]+)/([^/]+)/Makefile.*$%\2%p' Makefile`
++ PORTBASENAME_HEADER=`sed -n -E -e '1,/^($|[^#].*$)|\\$FreeBSD\:/s%^#.*\\$FreeBSD\:[[:space:]]*([^/]+/)*([^/]+)/Makefile.*\\$%\2%p' Makefile`
+ if [ "${DIRBASENAME}" != "${PORTBASENAME_HEADER}" ]
+ then
+ echo "Warning: current directory name differs from Makefile header:"
@@ -116,7 +116,7 @@
+ if [ ! -d ${ORIG_DIR} ]
+ then
+ echo "Original version does not exist at ${ORIG_DIR}"
-+ if [ -d "${DIFF_MODE}/${CATEGORY}/${PORTBASENAME}" ]
++ if [ -d "${DIFF_MODE}/${CATEGORY}/${DIRBASENAME}" ]
+ then
+ PORTBASENAME=${DIRBASENAME}
+ ORIG_DIR="${DIFF_MODE}/${CATEGORY}/${PORTBASENAME}"