aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/poudriere
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2017-05-16 16:15:10 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2017-05-16 16:15:10 +0000
commit6b45af196f651f323f3e80e5458df722dba1450e (patch)
tree5043d1bae7e64a04a8b107a5e96e98c91fcbdde3 /ports-mgmt/poudriere
parentf6c77240e5ebab51c8458393790e1b6b2e46f906 (diff)
downloadports-6b45af196f651f323f3e80e5458df722dba1450e.tar.gz
ports-6b45af196f651f323f3e80e5458df722dba1450e.zip
Fix build of sh on GCC platforms where -std=gnu99 is needed.
Notes
Notes: svn path=/head/; revision=441008
Diffstat (limited to 'ports-mgmt/poudriere')
-rw-r--r--ports-mgmt/poudriere/Makefile1
-rw-r--r--ports-mgmt/poudriere/files/patch-Makefile.am37
2 files changed, 38 insertions, 0 deletions
diff --git a/ports-mgmt/poudriere/Makefile b/ports-mgmt/poudriere/Makefile
index c8dff501258d..152cb39aae44 100644
--- a/ports-mgmt/poudriere/Makefile
+++ b/ports-mgmt/poudriere/Makefile
@@ -2,6 +2,7 @@
PORTNAME= poudriere
DISTVERSION= 3.1.17
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/bdrewery/${PORTNAME}/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
diff --git a/ports-mgmt/poudriere/files/patch-Makefile.am b/ports-mgmt/poudriere/files/patch-Makefile.am
new file mode 100644
index 000000000000..515848ebeae3
--- /dev/null
+++ b/ports-mgmt/poudriere/files/patch-Makefile.am
@@ -0,0 +1,37 @@
+commit 7772e88ac1976ed60f4c233136c9246e3a99016e
+Author: Bryan Drewery <bryan@shatow.net>
+Date: Fri May 12 09:26:06 2017 -0700
+
+ Use C99 to build sh as head does.
+
+ This fixes the build for Sparc64 with GCC 4.2.1.
+
+ Reported by: linimon, jhibbits
+ Fixes #468
+
+diff --git Makefile.am Makefile.am
+index 2e7f8960..7bab2d8d 100644
+--- Makefile.am
++++ Makefile.am
+@@ -146,7 +146,7 @@ rm_SOURCES= src/libexec/poudriere/rm/rm.c
+ timeout_SOURCES= src/libexec/poudriere/timeout/timeout.c
+ timestamp_SOURCES= src/libexec/poudriere/timestamp/timestamp.c
+ tsort_SOURCES= src/libexec/poudriere/tsort/tsort.c
+-sh_CFLAGS= -DSHELL -DNO_HISTORY \
++sh_CFLAGS= -DSHELL -DNO_HISTORY -std=gnu99 \
+ -include $(top_srcdir)/external/sh_compat/compat.h \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/external/sh
+diff --git Makefile.in Makefile.in
+index 1987d11d..d32d502b 100644
+--- Makefile.in
++++ Makefile.in
+@@ -600,7 +600,7 @@ rm_SOURCES = src/libexec/poudriere/rm/rm.c
+ timeout_SOURCES = src/libexec/poudriere/timeout/timeout.c
+ timestamp_SOURCES = src/libexec/poudriere/timestamp/timestamp.c
+ tsort_SOURCES = src/libexec/poudriere/tsort/tsort.c
+-sh_CFLAGS = -DSHELL -DNO_HISTORY -include \
++sh_CFLAGS = -DSHELL -DNO_HISTORY -std=gnu99 -include \
+ $(top_srcdir)/external/sh_compat/compat.h -I$(top_srcdir)/src \
+ -I$(top_srcdir)/external/sh -I$(top_srcdir)/src/poudriere-sh \
+ -I$(top_builddir)/src/poudriere-sh