aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/py-pnu-portstreelint
diff options
context:
space:
mode:
authorHubert Tournier <hubert.tournier@gmail.com>2024-03-20 08:27:33 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2024-03-20 09:41:54 +0000
commitd004acb586229ffd0436c52c6b7f3e3f6dfcd202 (patch)
tree964e3be746947731894bc6b8838ecec26c4f1780 /ports-mgmt/py-pnu-portstreelint
parentdd085323090696599b24bc4b78d151818f777f7f (diff)
downloadports-d004acb586229ffd0436c52c6b7f3e3f6dfcd202.tar.gz
ports-d004acb586229ffd0436c52c6b7f3e3f6dfcd202.zip
ports-mgmt/py-pnu-portstreelint: New port: FreeBSD ports tree lint
- Submitter becomes maintainer The portstreelint utility checks the FreeBSD ports tree Index and some parts of the ports' Makefiles for errors and warnings. By default it will scan the whole port tree, but you can select a subset of the ports by specifying lists of categories, maintainers and ports names. WWW: https://github.com/HubTou/portstreelint PR: 277824
Diffstat (limited to 'ports-mgmt/py-pnu-portstreelint')
-rw-r--r--ports-mgmt/py-pnu-portstreelint/Makefile25
-rw-r--r--ports-mgmt/py-pnu-portstreelint/distinfo3
-rw-r--r--ports-mgmt/py-pnu-portstreelint/pkg-descr12
3 files changed, 40 insertions, 0 deletions
diff --git a/ports-mgmt/py-pnu-portstreelint/Makefile b/ports-mgmt/py-pnu-portstreelint/Makefile
new file mode 100644
index 000000000000..202ea8c3487f
--- /dev/null
+++ b/ports-mgmt/py-pnu-portstreelint/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= pnu-portstreelint
+DISTVERSION= 1.2.0
+CATEGORIES= ports-mgmt security python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= hubert.tournier@gmail.com
+COMMENT= FreeBSD ports tree lint
+WWW= https://github.com/HubTou/portstreelint
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/License
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pnu-libpnu>=1.3.0:devel/py-pnu-libpnu@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pnu-vuxml>=1.2.1:security/py-pnu-vuxml@${PY_FLAVOR}
+
+USES= python shebangfix
+USE_PYTHON= autoplist flavors pep517
+
+SHEBANG_FILES= src/portstreelint/*.py
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/py-pnu-portstreelint/distinfo b/ports-mgmt/py-pnu-portstreelint/distinfo
new file mode 100644
index 000000000000..0cdad9049ec7
--- /dev/null
+++ b/ports-mgmt/py-pnu-portstreelint/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1710899690
+SHA256 (pnu-portstreelint-1.2.0.tar.gz) = 21b76e3f492a6b3077f053ea93aa9613114c84795c3f2fe414869262b270d8fe
+SIZE (pnu-portstreelint-1.2.0.tar.gz) = 21832
diff --git a/ports-mgmt/py-pnu-portstreelint/pkg-descr b/ports-mgmt/py-pnu-portstreelint/pkg-descr
new file mode 100644
index 000000000000..39509966f43e
--- /dev/null
+++ b/ports-mgmt/py-pnu-portstreelint/pkg-descr
@@ -0,0 +1,12 @@
+The portstreelint utility checks the FreeBSD ports tree Index and some
+parts of the ports' Makefiles for errors and warnings.
+
+By default it will scan the whole port tree, but you can select a
+subset of the ports by specifying lists of categories, maintainers and
+ports names.
+
+It is possible to generate a CSV delimited file with the
+per-maintainer findings to a specified filename. This allows for
+automated processing of the results, such as, for example, sending
+warning emails, storing results and displaying only diffs since
+previous run...