aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-07-04 20:08:11 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-07-04 20:08:11 +0000
commit0d888b0e8adc9bb5dbba5dfdde74df7265629d22 (patch)
treee3f636e4e9dc68ad6feb95ff29dba6c1ba3d2143 /ports-mgmt
parent7420515f301fa4dc2feb8e98f9c96afa73808497 (diff)
- Fix pkg-rquery -I to have all expected output.
Obtained from: upstream 29c9c84e0e11c2c182a8d79634344e57bf2575f1 With hat: portmgr Reported by: dteske
Notes
Notes: svn path=/head/; revision=360653
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg/Makefile2
-rw-r--r--ports-mgmt/pkg/files/patch-rquery-I43
2 files changed, 44 insertions, 1 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 54b7c77e49b6..300a18f52367 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pkg
DISTVERSION= 1.2.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= ports-mgmt
MASTER_SITES= \
http://files.etoilebsd.net/${PORTNAME}/ \
diff --git a/ports-mgmt/pkg/files/patch-rquery-I b/ports-mgmt/pkg/files/patch-rquery-I
new file mode 100644
index 000000000000..08a96723e308
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-rquery-I
@@ -0,0 +1,43 @@
+diff --git pkg/rquery.c pkg/rquery.c
+index 7ce40f7..f967a34 100644
+--- pkg/rquery.c
++++ pkg/rquery.c
+@@ -84,13 +84,23 @@ print_index(struct pkg *pkg)
+ #ifndef PORTSDIR
+ #define PORTSDIR "/usr/ports"
+ #endif
+- struct pkg_category *cat = NULL;
+
+- pkg_printf("%n-%v|" PORTSDIR "/%o|%p|%c|" PORTSDIR "/%o/pkg-descr|%m|",
+- pkg, pkg, pkg, pkg, pkg, pkg, pkg);
+- while (pkg_categories(pkg, &cat) == EPKG_OK)
+- pkg_printf("%Cn ", cat);
+- printf("\n");
++ pkg_printf(
++ "%n-%v|" /* PKGNAME */
++ "%S/%o|" /* PORTDIR */
++ "%p|" /* PREFIX */
++ "%c|" /* COMMENT */
++ "%S/%o/pkg-descr|" /* _DESCR */
++ "%m|" /* MAINTAINER */
++ "%C%{%Cn%| %}|" /* CATEGORIES */
++ "|" /* BUILD_DEPENDS */
++ "%d%{%dn-%dv%| %}|" /* RUN_DEPENDS */
++ "%w|" /* WWW */
++ "|" /* EXTRACT_DEPENDS */
++ "|" /* PATCH_DEPENDS */
++ "\n", /* FETCH_DEPENDS */
++ pkg, pkg, PORTSDIR, pkg, pkg, pkg, PORTSDIR, pkg, pkg, pkg, pkg,
++ pkg);
+ }
+
+ int
+@@ -201,7 +211,7 @@ exec_rquery(int argc, char **argv)
+ return (EX_IOERR);
+
+ if (index_output)
+- query_flags = PKG_LOAD_BASIC|PKG_LOAD_CATEGORIES;
++ query_flags = PKG_LOAD_BASIC|PKG_LOAD_CATEGORIES|PKG_LOAD_DEPS;
+
+ if (match == MATCH_ALL || match == MATCH_CONDITION) {
+ const char *condition_sql = NULL;