aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-11-30 12:12:43 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-11-30 12:12:43 +0000
commit3d95e6e13aca2cf20c5978134efdf2d07ad10ddd (patch)
tree143a5bc30de29a9d767e798ef93688190c2bc66c /ports-mgmt
parent28f53418c6456ace40042e76de4352bca0e4c6ff (diff)
downloadports-3d95e6e13aca2cf20c5978134efdf2d07ad10ddd.tar.gz
ports-3d95e6e13aca2cf20c5978134efdf2d07ad10ddd.zip
Add fastest_pkg 0.1.1, script to find the fastest pkg mirror.
Notes
Notes: svn path=/head/; revision=556631
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/fastest_pkg/Makefile23
-rw-r--r--ports-mgmt/fastest_pkg/distinfo3
-rw-r--r--ports-mgmt/fastest_pkg/pkg-descr5
4 files changed, 32 insertions, 0 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index a2d9ad34b977..c3a2ca902c98 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -10,6 +10,7 @@
SUBDIR += dialog4ports
SUBDIR += dialog4ports-static
SUBDIR += distilator
+ SUBDIR += fastest_pkg
SUBDIR += freebsd-bugzilla-cli
SUBDIR += genpatch
SUBDIR += genplist
diff --git a/ports-mgmt/fastest_pkg/Makefile b/ports-mgmt/fastest_pkg/Makefile
new file mode 100644
index 000000000000..fc0dd5a3940b
--- /dev/null
+++ b/ports-mgmt/fastest_pkg/Makefile
@@ -0,0 +1,23 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fastest_pkg
+PORTVERSION= 0.1.1
+DISTVERSIONPREFIX= v
+CATEGORIES= ports-mgmt python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Script to find the fastest pkg mirror
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=0:dns/py-dnspython@${PY_FLAVOR} \
+ curl:ftp/curl
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= ehaupt
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/fastest_pkg/distinfo b/ports-mgmt/fastest_pkg/distinfo
new file mode 100644
index 000000000000..0124ed8faaaa
--- /dev/null
+++ b/ports-mgmt/fastest_pkg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1606665674
+SHA256 (ehaupt-fastest_pkg-v0.1.1_GH0.tar.gz) = 6b665da1d41d18fadf49ddef31258c9e3ad360466c6a2cad4b62e59242b09ca3
+SIZE (ehaupt-fastest_pkg-v0.1.1_GH0.tar.gz) = 2498
diff --git a/ports-mgmt/fastest_pkg/pkg-descr b/ports-mgmt/fastest_pkg/pkg-descr
new file mode 100644
index 000000000000..59c642aae13e
--- /dev/null
+++ b/ports-mgmt/fastest_pkg/pkg-descr
@@ -0,0 +1,5 @@
+By default pkg uses DNS-based load balancing. This method does not necessarily
+choose the fastest mirror. This script can help you to find the fastest pkg
+mirror near you.
+
+WWW: https://github.com/ehaupt/fastest_pkg