aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-11-01 21:51:16 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-11-01 21:51:16 +0000
commiteda87cdd9958c2f97a7864654db6983097ddcd70 (patch)
treee67f7f0f676af517e421f82083df4e0ab72c6b46 /ports-mgmt
parentee2eef93a9babbd5528db6d3ed8f7a28b4abb0be (diff)
downloadports-eda87cdd9958c2f97a7864654db6983097ddcd70.tar.gz
ports-eda87cdd9958c2f97a7864654db6983097ddcd70.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmanager/Makefile2
-rw-r--r--ports-mgmt/portmanager/files/patch-ac74
2 files changed, 75 insertions, 1 deletions
diff --git a/ports-mgmt/portmanager/Makefile b/ports-mgmt/portmanager/Makefile
index b112b5d4e38f..be42a2f5ba7e 100644
--- a/ports-mgmt/portmanager/Makefile
+++ b/ports-mgmt/portmanager/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portmanager
PORTVERSION= 0.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= portmanager
diff --git a/ports-mgmt/portmanager/files/patch-ac b/ports-mgmt/portmanager/files/patch-ac
new file mode 100644
index 000000000000..4212684a7470
--- /dev/null
+++ b/ports-mgmt/portmanager/files/patch-ac
@@ -0,0 +1,74 @@
+diff -ruN ./libPMGR/src/PMGRrDbCreate.c ../../portmanager-0.2.0/libPMGR/src/PMGRrDbCreate.c
+--- ./libPMGR/src/PMGRrDbCreate.c Thu Aug 12 02:19:05 2004
++++ ../../portmanager-0.2.0/libPMGR/src/PMGRrDbCreate.c Thu Oct 28 15:28:20 2004
+@@ -55,6 +55,7 @@
+ char* portDependencyDir = NULL;
+ char* portDir = NULL;
+ char* portName = NULL;
++ int address = 0;
+ int errorCode = 0;
+ int idx = 0;
+ int portDependencyDirLen = 0;
+@@ -140,10 +141,46 @@
+ }
+ fread( portBuffer, 1, size, portStream );
+ portBuffer[size+1] = 0;
+- portName = strstr( portBuffer, "@name " ) + strlen( "@name " );
+- portNameLen = strstr( portName, "\n" ) - portName;
+- portDir = strstr( portBuffer, "@comment ORIGIN:" ) + strlen( "@comment ORIGIN:" );
+- portDirLen = strstr( portDir, "\n" ) - portDir;
++
++ /* sets portName to start address of portname */
++ /* ver 0.2.0_3 added error checking for @name not found int +CONTENTS file */
++ if( (address = (int)strnstr(portBuffer, "@name ", size)) == 0 )
++ {
++ fprintf( stderr, "%s %s error: \"@name\" not found in %s\n", id, ver, pkg.portDirName );
++ fprintf( stderr, "\t\t%s installation is corrupt!\n", pkg.entry->d_name );
++ fprintf( stderr, "\t\trecomend running \"pkg_delete -f %s\" then manually reinstalling this port\n", pkg.entry->d_name );
++ return(1);
++ }
++ portName = (char*)(address + strlen("@name "));
++
++ if( (address = (int)strnstr(portName, "\n", 256)) == 0 )
++ {
++ fprintf( stderr, "%s %s portName error: \"end of line\" not found in %s\n", id, ver, pkg.portDirName );
++ fprintf( stderr, "\t\t%s installation is corrupt!\n", pkg.entry->d_name );
++ fprintf( stderr, "\t\trecomend running \"pkg_delete -f %s\" then manually reinstalling this port\n", pkg.entry->d_name );
++ return(1);
++ }
++ portNameLen = address - (int)portName;
++
++ if( (address = (int)strnstr(portBuffer, "@comment ORIGIN:", size)) == 0 )
++ {
++ fprintf( stderr, "%s %s error: \"@comment ORIGIN:\" not found in %s\n", id, ver, pkg.portDirName );
++ fprintf( stderr, "\t\t%s installation is corrupt!\n", pkg.entry->d_name );
++ fprintf( stderr, "\t\trecomend running \"pkg_delete -f %s\" then manually reinstalling this port\n", pkg.entry->d_name );
++ return(1);
++ }
++ portDir = (char*)(address + strlen("@comment ORIGIN:"));
++
++
++ if( (address = (int)strnstr(portDir, "\n", 256)) == 0 )
++ {
++ fprintf( stderr, "%s %s portDir error: \"end of line\" not found in %s\n", id, ver, pkg.portDirName );
++ fprintf( stderr, "\t\t%s installation is corrupt!\n", pkg.entry->d_name );
++ fprintf( stderr, "\t\trecomend running \"pkg_delete -f %s\" then manually reinstalling this port\n", pkg.entry->d_name );
++ return(1);
++ }
++ portDirLen = address - (int)portDir;
++
+ portName[portNameLen] = 0;
+ portDir[portDirLen] = 0;
+ fprintf( portIStream, "%s%c%s%c\n", portName, NULL, portDir, NULL );
+diff -ruN ./libPMGR/src/libPMGR.h ../../portmanager-0.2.0/libPMGR/src/libPMGR.h
+--- ./libPMGR/src/libPMGR.h Thu Oct 28 15:33:54 2004
++++ ../../portmanager-0.2.0/libPMGR/src/libPMGR.h Thu Oct 28 15:31:41 2004
+@@ -33,7 +33,7 @@
+ #include <pmupgrade.h>
+
+ #ifndef VER
+-static char ver[] = "0.2.0_2";
++static char ver[] = "0.2.0_3";
+ #define VER 1
+ #endif
+