aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2021-06-30 02:45:57 +0000
committerFukang Chen <loader@FreeBSD.org>2021-06-30 05:09:36 +0000
commitf76aa00290b61be36138c3c177250b5ac10f2607 (patch)
tree8abc9e91e5b1f9e6c2c77529f64cc58d857de13c /ports-mgmt
parentd3a50ae15530e720a7fb660123d0e6608531f9ee (diff)
downloadports-f76aa00290b61be36138c3c177250b5ac10f2607.tar.gz
ports-f76aa00290b61be36138c3c177250b5ac10f2607.zip
Mk/bsd.options.desc.mk: Add shared version control OPTIONS & descriptions
- Add CVS description - Add DARCS description - Add GIT description - Add MERCURIAL description - Add PERFORCE description - Rename SVN to SUBVERSION devel/anjuta: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE and OPTIONS_DEFAULT - Change SUBVERSION_DESC to use the default description devel/git: - Rename OPTION P4 to PERFORCE - Rename OPTION SVN to SUBVERSION - Change PERFORCE_DESC to use the default description devel/ocaml-opam: - Rename OPTION HG to MERCURIAL - Sort OPTIONS_DEFINE and OPTIONS_DEFAULT - Change {DARCS,GIT,MERCURIAL}_DESC to use the default description devel/thunar-vcs-plugin: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE - Change GIT_DESC to use the default description devel/viewvc-devel: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE, OPTIONS_DEFAULT and OPTIONS_SINGLE net-mgmt/observium: - Rename OPTION SVN to SUBVERSION net-mgmt/rancid3: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_SINGLE_SCM - Change {CVS,GIT,SUBVERSION}_DESC to use the default description ports-mgmt/portshaker: - Rename OPTION SVN to SUBVERSION - Rename HG to MERCURIAL - Sort OPTIONS_DEFINE - Change {GIT,MERCURIAL}_DESC to use the default description security/hydra: - Rename OPTION SVN to SUBVERSION security/medusa: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE shells/scponly: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE - Typo fix in SVNSERVE_DESC www/trac-devel: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE, OPTIONS_DEFAULT and OPTIONS_MULTI_DATABASE - Change {GIT,SUBVERSION}_DESC to use the default description Reviewed by: koobs, adamw, dvl, garga, hannes_mehnert.org, rm, dbaio, romain Approved by: koobs (ports, mentor) Differential Revision: https://reviews.freebsd.org/D17459 MFH: No (OPTION description updates)
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portest/Makefile2
-rw-r--r--ports-mgmt/portshaker/Makefile14
2 files changed, 7 insertions, 9 deletions
diff --git a/ports-mgmt/portest/Makefile b/ports-mgmt/portest/Makefile
index 02738ce0bb22..07bd9c3a4033 100644
--- a/ports-mgmt/portest/Makefile
+++ b/ports-mgmt/portest/Makefile
@@ -2,6 +2,7 @@
PORTNAME= portest
PORTVERSION= 0.1.9
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MAINTAINER= ultima@FreeBSD.org
@@ -18,7 +19,6 @@ PLIST_FILES= sbin/portest
OPTIONS_DEFINE= GIT PORTLINT PORTTOOLS POUDRIERE
-GIT_DESC= Git support
GIT_RUN_DEPENDS= git:devel/git
PORTLINT_DESC= Portlint support
diff --git a/ports-mgmt/portshaker/Makefile b/ports-mgmt/portshaker/Makefile
index 877d3c1d67ab..013b0bdcff6d 100644
--- a/ports-mgmt/portshaker/Makefile
+++ b/ports-mgmt/portshaker/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= portshaker
PORTVERSION= 1.0.19
DISTVERSIONPREFIX= v
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= ports-mgmt
MAINTAINER?= romain@FreeBSD.org
@@ -18,20 +18,18 @@ GH_ACCOUNT= smortex
GH_PROJECT= portshaker
.if ${PORTNAME} == "portshaker"
-OPTIONS_DEFINE= RSYNC SVN GIT HG
-OPTIONS_DEFAULT= RSYNC SVN
+OPTIONS_DEFINE= GIT MERCURIAL RSYNC SUBVERSION
+OPTIONS_DEFAULT= RSYNC SUBVERSION
RSYNC_DESC= rsync support
-GIT_DESC= git support
-HG_DESC= mercurial support
RSYNC_RUN_DEPENDS= rsync:net/rsync
WITH_SUBVERSION_VER?= 114
.if ${WITH_SUBVERSION_VER} == 114
-SVN_RUN_DEPENDS= svn:devel/subversion
+SUBVERSION_RUN_DEPENDS= svn:devel/subversion
.elif ${WITH_SUBVERSION_VER} == LTS
-SVN_RUN_DEPENDS= svn:devel/subversion-lts
+SUBVERSION_RUN_DEPENDS= svn:devel/subversion-lts
.endif
GIT_RUN_DEPENDS= git:devel/git
-HG_RUN_DEPENDS= ${PY_MERCURIAL}
+MERCURIAL_RUN_DEPENDS= ${PY_MERCURIAL}
.else
OPTIONS_DEFINE= BSDSHARP ENLIGHTENMENT GECKO HASKELL MARCUSCOM TEXLIVE XORG
OPTIONS_DEFAULT= BSDSHARP