aboutsummaryrefslogtreecommitdiff
path: root/print/bibview
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-09-12 08:11:56 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-09-12 08:11:56 +0000
commit1bc1187e0f092788bcd9e50721edce75c27efc92 (patch)
treeb77f6d5f76c4b7536049a0d031ceaa88d0d5408d /print/bibview
parent74d94aba95bd3d883803285661198e8db29a86bf (diff)
downloadports-1bc1187e0f092788bcd9e50721edce75c27efc92.tar.gz
ports-1bc1187e0f092788bcd9e50721edce75c27efc92.zip
Import bibview port. bibview allows to edit bibliographic databases
for use with BibTeX. PR: 4133 Submitted by: "David A. Bader" <dbader@umiacs.umd.edu>
Notes
Notes: svn path=/head/; revision=7874
Diffstat (limited to 'print/bibview')
-rw-r--r--print/bibview/Makefile19
-rw-r--r--print/bibview/distinfo1
-rw-r--r--print/bibview/files/patch-aa11
-rw-r--r--print/bibview/files/patch-ab14
-rw-r--r--print/bibview/files/patch-ac37
-rw-r--r--print/bibview/files/patch-ad18
-rw-r--r--print/bibview/files/patch-ae22
-rw-r--r--print/bibview/files/patch-af22
-rw-r--r--print/bibview/pkg-comment1
-rw-r--r--print/bibview/pkg-descr23
-rw-r--r--print/bibview/pkg-plist4
11 files changed, 172 insertions, 0 deletions
diff --git a/print/bibview/Makefile b/print/bibview/Makefile
new file mode 100644
index 000000000000..25cdf5f67a42
--- /dev/null
+++ b/print/bibview/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: bibview
+# Version required: 1.5
+# Date created: 21 July 1997
+# Whom: dbader@umiacs.umd.edu
+#
+# $Id$
+#
+
+DISTNAME= bibview-2.2
+CATEGORIES= databases print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= biblio/bibtex/utils/bibview-2.0
+
+MAINTAINER= dbader@umiacs.umd.edu
+
+USE_IMAKE= yes
+WRKSRC= ${WRKDIR}/bibview-2.2
+
+.include <bsd.port.mk>
diff --git a/print/bibview/distinfo b/print/bibview/distinfo
new file mode 100644
index 000000000000..4d6cd38179f2
--- /dev/null
+++ b/print/bibview/distinfo
@@ -0,0 +1 @@
+MD5 (bibview-2.2.tar.gz) = dba28a7929f2961e9e93b3b6ad50107e
diff --git a/print/bibview/files/patch-aa b/print/bibview/files/patch-aa
new file mode 100644
index 000000000000..58954c920bf2
--- /dev/null
+++ b/print/bibview/files/patch-aa
@@ -0,0 +1,11 @@
+--- Imakefile.orig Mon Feb 27 14:41:19 1995
++++ Imakefile Thu Sep 11 13:08:27 1997
+@@ -9,7 +9,7 @@
+
+
+ /* nothing needs to be modified below this point */
+-CFLAGS = $(STD_CPP_DEFINES)
++CFLAGS = $(STD_CPP_DEFINES) -I/usr/X11R6/include
+ #ifdef NeXTArchitecture
+
+ SYS_LIBRARIES = XawClientLibs -lm -lsys_s
diff --git a/print/bibview/files/patch-ab b/print/bibview/files/patch-ab
new file mode 100644
index 000000000000..8887fc743dcb
--- /dev/null
+++ b/print/bibview/files/patch-ab
@@ -0,0 +1,14 @@
+--- bibview.c.orig Fri Apr 21 18:49:15 1995
++++ bibview.c Thu Sep 11 13:08:28 1997
+@@ -170,9 +170,9 @@
+ /* fallback resources */
+ static char *fallback_resources[] = {
+ #ifdef GERMAN
+- #include "fb_ger.h"
++#include "fb_ger.h"
+ #else
+- #include "fb_res.h"
++#include "fb_res.h"
+ #endif
+ NULL
+ };
diff --git a/print/bibview/files/patch-ac b/print/bibview/files/patch-ac
new file mode 100644
index 000000000000..45ec9e37942d
--- /dev/null
+++ b/print/bibview/files/patch-ac
@@ -0,0 +1,37 @@
+--- FileNom.c.orig Thu May 4 18:15:11 1995
++++ FileNom.c Thu Sep 11 13:08:28 1997
+@@ -822,20 +822,20 @@
+ Dimension height, internalHeight, rowSpacing;
+ int num, newNum, idx;
+ struct dirent **namelist;
+- #ifndef HAVE_DIR
++#ifndef HAVE_DIR
+ DIR *dirp;
+ struct dirent *direntp;
+ int direntp_size;
+- #else
++#else
+ extern int alphasort();
+- #endif
++#endif
+ char buf[MAXPATHLEN], *bp;
+ String name;
+ struct stat fstats;
+ unsigned int namlen;
+- #ifdef HAVE_DIR
++#ifdef HAVE_DIR
+ num = scandir(CurrentDir(fnw), &namelist, (int(*)())0, alphasort);
+- #else
++#else
+ /* Read the directory `CurrentDir(fnw)'
+ and set the `dirent's in `namelist'. */
+ dirp = opendir( CurrentDir(fnw) );
+@@ -860,7 +860,7 @@
+
+ /* Sort the directory entries in `namelist'. */
+ qsort( namelist, num, sizeof(struct dirent*), direntpcmp );
+- #endif
++#endif
+
+ if (num <= 0)
+ {
diff --git a/print/bibview/files/patch-ad b/print/bibview/files/patch-ad
new file mode 100644
index 000000000000..40ac9569de58
--- /dev/null
+++ b/print/bibview/files/patch-ad
@@ -0,0 +1,18 @@
+--- gui_widg.c.orig Thu Nov 25 14:11:15 1993
++++ gui_widg.c Thu Sep 11 13:08:30 1997
+@@ -330,12 +330,12 @@
+ XtNfromHoriz, warnIcon, NULL);
+ sprintf(textLabel, "msgText%d", abs((int)errcode));
+ if (errcode >= 200){
+- #ifdef GERMAN
++#ifdef GERMAN
+ sprintf(warnLabel, "Karte unvollstaendig: kein %s",
+ glbFldToName(errcode-200));
+- #else
++#else
+ sprintf(warnLabel, "Card incomplete: no %s", glbFldToName(errcode-200));
+- #endif
++#endif
+ warnText = XtVaCreateManagedWidget(textLabel,
+ labelWidgetClass, warnForm,
+ XtNjustify, XtJustifyLeft,
diff --git a/print/bibview/files/patch-ae b/print/bibview/files/patch-ae
new file mode 100644
index 000000000000..514c65f15929
--- /dev/null
+++ b/print/bibview/files/patch-ae
@@ -0,0 +1,22 @@
+--- gui_card.c.orig Mon May 8 18:24:55 1995
++++ gui_card.c Thu Sep 11 13:08:31 1997
+@@ -370,15 +370,15 @@
+ CardWidgetsPtr cwp;
+ Dimension height;
+
+- #ifdef ACTION_PROBLEM
++#ifdef ACTION_PROBLEM
+ if (first_in){
+- #endif
++#endif
+ XtAppAddActions(XtWidgetToApplicationContext(topLevel), actions,
+ XtNumber(actions));
+- #ifdef ACTION_PROBLEM
++#ifdef ACTION_PROBLEM
+ first_in = 0;
+ }
+- #endif
++#endif
+ reqback = options.reqColor;
+ auth_ed_back = options.authedColor;
+
diff --git a/print/bibview/files/patch-af b/print/bibview/files/patch-af
new file mode 100644
index 000000000000..786f077c04f9
--- /dev/null
+++ b/print/bibview/files/patch-af
@@ -0,0 +1,22 @@
+--- ctl_card.c.orig Mon May 8 18:25:53 1995
++++ ctl_card.c Thu Sep 11 13:08:32 1997
+@@ -659,15 +659,15 @@
+ sprintf(aw->shellName, "%s: NEW", glbFldToName(nannote));
+ else
+ sprintf(aw->shellName, "%s: %s", glbFldToName(nannote), cp->cd->mainkey);
+- #ifdef ACTION_PROBLEM
++#ifdef ACTION_PROBLEM
+ if (first_in){
+- #endif
++#endif
+ XtAppAddActions(XtWidgetToApplicationContext(topLevel), annote_actions,
+ XtNumber(annote_actions));
+- #ifdef ACTION_PROBLEM
++#ifdef ACTION_PROBLEM
+ first_in = 0;
+ }
+- #endif
++#endif
+ aw->annoteShell = XtVaCreatePopupShell("AnnoteShell",
+ topLevelShellWidgetClass, topLevel,
+ XtNtitle, aw->shellName,
diff --git a/print/bibview/pkg-comment b/print/bibview/pkg-comment
new file mode 100644
index 000000000000..cfcb7d8b7ea6
--- /dev/null
+++ b/print/bibview/pkg-comment
@@ -0,0 +1 @@
+Graphical interface for manipulating BibTeX bibliography databases
diff --git a/print/bibview/pkg-descr b/print/bibview/pkg-descr
new file mode 100644
index 000000000000..5777ed670071
--- /dev/null
+++ b/print/bibview/pkg-descr
@@ -0,0 +1,23 @@
+
+ BIBVIEW
+ (graphical interface for BibTeX program)
+ by Holger Martin, Peter Urban, Armin Liebl
+ liebla@informatik.tu-muenchen.de
+
+ The program "bibview" is a graphical interface for manipulating
+ BibTeX databases. It supports the user in making new entries,
+ searching for entries and moving entries from one BiB to another.
+ It is possible to work with more than one BiB simultaneously.
+ bibview is implemented with Xt and Athena Widgets.
+ There are six types of windows in bibview:
+ The main window contains menus for customizing bibview and
+ for working with BiBs on the file level.
+ The bibliography window (one for every open BiB) contains commands
+ for manipulating the BiB.
+ The list window (at most one for every open BiB) shows a list of
+ entries. It displays the fields author, title, type and year.
+ The card window (at most one for every entry) helps editing an entry.
+ It contains boxes for each field of the entry (according to the type).
+ The fields can be edited by putting the mouse cursor into the field.
+ Macros in fields and the symbol for concatenation ('#') are marked
+ with a preceding '@'.
diff --git a/print/bibview/pkg-plist b/print/bibview/pkg-plist
new file mode 100644
index 000000000000..b7a125fbc2b8
--- /dev/null
+++ b/print/bibview/pkg-plist
@@ -0,0 +1,4 @@
+bin/bibview
+lib/X11/app-defaults/BibView
+lib/X11/app-defaults/BibView-color
+man/man1/bibview.1.gz