aboutsummaryrefslogtreecommitdiff
path: root/print/catdvi
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2014-07-03 14:36:33 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2014-07-03 14:36:33 +0000
commitc8821edb097b470c21ceb3e2484f115b01f656a3 (patch)
tree332626db26334fd531981b6560d891f01ab7695b /print/catdvi
parent9df6393d9c53a6ba98a3ba54be91e1f44bc52b4c (diff)
downloadports-c8821edb097b470c21ceb3e2484f115b01f656a3.tar.gz
ports-c8821edb097b470c21ceb3e2484f115b01f656a3.zip
. fix build:
----- cc -O2 -pipe -fno-strict-aliasing -I/usr/local/include -DCFG_HAS_GETOPT_LONG -c -o kpathsea.o kpathsea.c kpathsea.c:39:23: error: redefinition of 'kpathsea_version_string' with a different type: 'char *' vs 'const char *' extern char * kpathsea_version_string; ----- . remove the indefinite article from COMMENT; . add LICENSE (GPLv2).
Notes
Notes: svn path=/head/; revision=360377
Diffstat (limited to 'print/catdvi')
-rw-r--r--print/catdvi/Makefile4
-rw-r--r--print/catdvi/files/patch-kpathsea.c11
2 files changed, 14 insertions, 1 deletions
diff --git a/print/catdvi/Makefile b/print/catdvi/Makefile
index 01059878e6dc..7a24b1d085e4 100644
--- a/print/catdvi/Makefile
+++ b/print/catdvi/Makefile
@@ -8,7 +8,9 @@ CATEGORIES= print
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= A DVI to text/plain translator
+COMMENT= DVI to text/plain translator
+
+LICENSE= GPLv2
USE_TEX= latex
USES= gmake
diff --git a/print/catdvi/files/patch-kpathsea.c b/print/catdvi/files/patch-kpathsea.c
new file mode 100644
index 000000000000..b235fb1f6b31
--- /dev/null
+++ b/print/catdvi/files/patch-kpathsea.c
@@ -0,0 +1,11 @@
+--- kpathsea.c.orig 2014-04-08 16:18:57.296160200 +0400
++++ kpathsea.c 2014-04-08 16:19:06.680160318 +0400
+@@ -36,7 +36,7 @@ void copyright_findtfm(void)
+
+ void version_findtfm(void)
+ {
+- extern char * kpathsea_version_string;
++ extern const char * kpathsea_version_string;
+ puts(kpathsea_version_string);
+ }
+