aboutsummaryrefslogtreecommitdiff
path: root/print/cups-bjnp
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2013-08-27 00:35:46 +0000
committerDiane Bruce <db@FreeBSD.org>2013-08-27 00:35:46 +0000
commitf339f50854250c98fe219e1267045c9f571aeecd (patch)
tree1a4261d84c9678eb5088fae759d10823aea6659f /print/cups-bjnp
parent2550f6d8a574f0a4b9f5f158ce74721ff166833a (diff)
downloadports-f339f50854250c98fe219e1267045c9f571aeecd.tar.gz
ports-f339f50854250c98fe219e1267045c9f571aeecd.zip
Update port to latest version.
PR: ports/174129 Submitted by: shurd@sasktel.net (Maintainer)
Notes
Notes: svn path=/head/; revision=325426
Diffstat (limited to 'print/cups-bjnp')
-rw-r--r--print/cups-bjnp/Makefile9
-rw-r--r--print/cups-bjnp/distinfo4
-rw-r--r--print/cups-bjnp/files/patch-bjnp-debug.c72
-rw-r--r--print/cups-bjnp/files/patch-bjnp.h10
-rw-r--r--print/cups-bjnp/files/patch-configure11
5 files changed, 87 insertions, 19 deletions
diff --git a/print/cups-bjnp/Makefile b/print/cups-bjnp/Makefile
index ae80739de7bf..57391cac4e52 100644
--- a/print/cups-bjnp/Makefile
+++ b/print/cups-bjnp/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: cups-bjnp
-# Date created: 15 May 2009
-# Whom: shurd@sasktel.net
-#
# $FreeBSD$
#
PORTNAME= cups-bjnp
-PORTVERSION= 0.5.3
+PORTVERSION= 1.2.1
PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= SF
@@ -14,11 +10,10 @@ MASTER_SITES= SF
MAINTAINER= shurd@sasktel.net
COMMENT= CUPS backend for Canon USB over IP protocol
-LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-client
+LIB_DEPENDS= cups:${PORTSDIR}/print/cups-client
BUILD_DEPENDS= ${LOCALBASE}/libexec/cups/backend:${PORTSDIR}/print/cups-base
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-lcompat"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/print/cups-bjnp/distinfo b/print/cups-bjnp/distinfo
index 5892a5c69703..fe5f24d5ab34 100644
--- a/print/cups-bjnp/distinfo
+++ b/print/cups-bjnp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cups-bjnp-0.5.3.tar.gz) = 9d369d6c561b81d91006675c4ad3c209548dc7aca63b39be3ffe7756b70dce04
-SIZE (cups-bjnp-0.5.3.tar.gz) = 117082
+SHA256 (cups-bjnp-1.2.1.tar.gz) = bda4ff2a9e9f673018374b75b1cf6f67f5aef3025a3a08d2c9ccf15a2bb8573a
+SIZE (cups-bjnp-1.2.1.tar.gz) = 140536
diff --git a/print/cups-bjnp/files/patch-bjnp-debug.c b/print/cups-bjnp/files/patch-bjnp-debug.c
new file mode 100644
index 000000000000..19c8dbd627c1
--- /dev/null
+++ b/print/cups-bjnp/files/patch-bjnp-debug.c
@@ -0,0 +1,72 @@
+--- bjnp-debug.c.orig 2013-01-21 10:43:27.000000000 -0800
++++ bjnp-debug.c 2013-08-14 02:29:30.000000000 -0700
+@@ -19,7 +19,7 @@
+
+ #include <stdio.h>
+ #include <stdarg.h>
+-#include <sys/timeb.h>
++#include <sys/time.h>
+ #include <errno.h>
+ #include "bjnp.h"
+
+@@ -59,7 +59,7 @@
+ static int to_cups = 0;
+ static FILE *debug_file = NULL;
+ static time_t start_sec = 0;
+-static int start_msec;
++static suseconds_t start_usec;
+
+ /*
+ * local functions
+@@ -186,9 +186,9 @@
+ {
+ va_list ap;
+ char printbuf[256];
+- struct timeb timebuf;
++ struct timeval timebuf;
+ int sec;
+- int msec;
++ suseconds_t usec;
+
+ /* print received data into a string */
+ va_start (ap, fmt);
+@@ -204,15 +204,15 @@
+
+ if ((level <= debug_level) && debug_file)
+ {
+- ftime (&timebuf);
+- if ((msec = timebuf.millitm - start_msec) < 0)
++ gettimeofday (&timebuf, NULL);
++ if ((usec = timebuf.tv_usec - start_usec) < 0)
+ {
+- msec += 1000;
+- timebuf.time -= 1;
++ usec += 1000000;
++ timebuf.tv_sec -= 1;
+ }
+- sec = timebuf.time - start_sec;
++ sec = timebuf.tv_sec - start_sec;
+
+- fprintf (debug_file, "%8s: %03d.%03d %s", level2str (level), sec, msec,
++ fprintf (debug_file, "%8s: %03d.%06ld %s", level2str (level), sec, usec,
+ printbuf);
+ }
+ }
+@@ -224,13 +224,13 @@
+ * set debug level to level (string)
+ */
+
+- struct timeb timebuf;
++ struct timeval timebuf;
+ char loglevel[16];
+ char *separator;
+
+- ftime (&timebuf);
+- start_sec = timebuf.time;
+- start_msec = timebuf.millitm;
++ gettimeofday (&timebuf, NULL);
++ start_sec = timebuf.tv_sec;
++ start_usec = timebuf.tv_usec;
+
+ /*
+ * Split string into loglevel and optional cupslog string
diff --git a/print/cups-bjnp/files/patch-bjnp.h b/print/cups-bjnp/files/patch-bjnp.h
deleted file mode 100644
index 945aec712267..000000000000
--- a/print/cups-bjnp/files/patch-bjnp.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- bjnp.h.orig 2009-03-14 22:47:19.000000000 +0100
-+++ bjnp.h 2011-10-14 18:36:08.000000000 +0200
-@@ -34,6 +34,7 @@
- */
-
- # include <stdlib.h>
-+# include <stdio.h>
- # include <errno.h>
- # include <signal.h>
- # include <stdint.h>
diff --git a/print/cups-bjnp/files/patch-configure b/print/cups-bjnp/files/patch-configure
new file mode 100644
index 000000000000..3a28174e2581
--- /dev/null
+++ b/print/cups-bjnp/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2013-08-14 02:30:58.000000000 -0700
++++ configure 2013-08-14 02:30:31.000000000 -0700
+@@ -3946,7 +3946,7 @@
+ IFS=$ac_save_IFS
+
+
+-for ac_func in ftime \
++for ac_func in gettimeofday \
+ getaddrinfo \
+ getnameinfo \
+ gethostname \