aboutsummaryrefslogtreecommitdiff
path: root/print/detex
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-03-25 10:53:11 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-03-25 10:53:11 +0000
commit6b05df3643318b978bcfd927040697a87fb3bf31 (patch)
treef63d6bea44b850f6c06dfaf9424a63300d9b6a53 /print/detex
parent9a565ac877125cc3eab2223fa1d2fcce2f61b9d0 (diff)
downloadports-6b05df3643318b978bcfd927040697a87fb3bf31.tar.gz
ports-6b05df3643318b978bcfd927040697a87fb3bf31.zip
detex takes as input a TeX source file and strips the TeX commands.
The result is output to stdout. This is useful if you need a pure ASCII version of a TeX/LaTeX file.
Notes
Notes: svn path=/head/; revision=6012
Diffstat (limited to 'print/detex')
-rw-r--r--print/detex/Makefile26
-rw-r--r--print/detex/distinfo1
-rw-r--r--print/detex/files/patch-01122
-rw-r--r--print/detex/pkg-comment1
-rw-r--r--print/detex/pkg-descr3
-rw-r--r--print/detex/pkg-plist2
6 files changed, 155 insertions, 0 deletions
diff --git a/print/detex/Makefile b/print/detex/Makefile
new file mode 100644
index 000000000000..12649f7c2f85
--- /dev/null
+++ b/print/detex/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: detex
+# Version required: 2.6
+# Date created: Mon Feb 17, 1997
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= detex-2.6
+CATEGORIES= print
+MASTER_SITES= ftp://ftp.cs.purdue.edu/pub/trinkle/
+EXTRACT_SUFX= .tar
+
+MAINTAINER= obrien@FreeBSD.org
+
+EXTRACT_BEFORE_ARGS= -C ${WRKDIR} -xf
+NO_WRKSUBDIR= yes
+MAN1= detex.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/detex ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1}l ${PREFIX}/man/man1/${MAN1}
+
+
+.include <bsd.port.mk>
diff --git a/print/detex/distinfo b/print/detex/distinfo
new file mode 100644
index 000000000000..bc869305560b
--- /dev/null
+++ b/print/detex/distinfo
@@ -0,0 +1 @@
+MD5 (detex-2.6.tar) = 410ce52761054c6af7059cb3d9f98e5b
diff --git a/print/detex/files/patch-01 b/print/detex/files/patch-01
new file mode 100644
index 000000000000..74180e14f29e
--- /dev/null
+++ b/print/detex/files/patch-01
@@ -0,0 +1,122 @@
+--- detex.l.orig Thu Aug 12 08:54:46 1993
++++ detex.l Mon Feb 17 23:01:15 1997
+@@ -76,7 +76,7 @@
+
+ <Normal>"\\begin"{S}"{"{S}"document"{S}"}" {fLatex = !fForcetex; IGNORE;}
+
+-<Normal>"\\begin" /* environment start */ {LaBEGIN LaBegin; IGNORE;}
++<Normal>"\\begin" {/* environment start */ LaBEGIN LaBegin; IGNORE;}
+
+ <LaBegin>{S}"{"{S}"verbatim"{S}"}" { if (BeginEnv("verbatim"))
+ BEGIN LaEnv;
+@@ -85,8 +85,8 @@
+ IGNORE;
+ }
+
+-<LaVerbatim>"\\end"{S}"{"{S}"verbatim"{S}"}" /* verbatim mode */
+- {BEGIN Normal; IGNORE;}
++<LaVerbatim>"\\end"{S}"{"{S}"verbatim"{S}"}" {/* verbatim mode */
++ BEGIN Normal; IGNORE;}
+ <LaVerbatim>. ECHO;
+
+ <LaBegin>{W} { if (BeginEnv(yytext))
+@@ -98,11 +98,11 @@
+ <LaBegin>"\n" NEWLINE;
+ <LaBegin>. ;
+
+-<LaEnv>"\\end" /* absorb some environments */ {LaBEGIN LaEnd; IGNORE;}
++<LaEnv>"\\end" {/* absorb some environments */ LaBEGIN LaEnd; IGNORE;}
+ <LaEnv>"\n" NEWLINE;
+ <LaEnv>. ;
+
+-<LaEnd>{W} /* end environment */ { if (EndEnv(yytext))
++<LaEnd>{W} {/* end environment */ if (EndEnv(yytext))
+ BEGIN Normal;
+ IGNORE;
+ }
+@@ -110,8 +110,8 @@
+ <LaEnd>"\n" NEWLINE;
+ <LaEnd>. ;
+
+-<Normal>"\\bibitem" /* ignore args */ {LaBEGIN LaMacro2; IGNORE;}
+-<Normal>"\\bibliography" /* of these \cs */ {LaBEGIN LaMacro; IGNORE;}
++<Normal>"\\bibitem" {/* ignore args */ LaBEGIN LaMacro2; IGNORE;}
++<Normal>"\\bibliography" {/* of these \cs */ LaBEGIN LaMacro; IGNORE;}
+ <Normal>"\\bibstyle" {LaBEGIN LaMacro; IGNORE;}
+ <Normal>"\\cite" {CITEBEGIN LaMacro2; IGNORE;}
+ <Normal>"\\documentstyle" {LaBEGIN LaMacro; IGNORE;}
+@@ -122,8 +122,8 @@
+ <Normal>"\\pagestyle" {LaBEGIN LaMacro; IGNORE;}
+ <Normal>"\\ref" {CITEBEGIN LaMacro; IGNORE;}
+ <Normal>"\\setcounter" {LaBEGIN LaMacro; IGNORE;}
+-<Normal>"\\verb" /* ignore \verb<char>...<char> */
+- { if (fLatex) {
++<Normal>"\\verb" {/* ignore \verb<char>...<char> */
++ if (fLatex) {
+ char verbchar, c;
+ verbchar = input();
+ while ((c = input()) != verbchar)
+@@ -143,33 +143,33 @@
+ <LaMacro2>"\n" NEWLINE;
+ <LaMacro2>. ;
+
+-<Normal>"\\def" /* ignore def begin */ {BEGIN Define; IGNORE;}
++<Normal>"\\def" {/* ignore def begin */ BEGIN Define; IGNORE;}
+ <Define>"{" BEGIN Normal;
+ <Define>"\n" NEWLINE;
+ <Define>. ;
+
+-<Normal>"\\(" /* formula mode */ {LaBEGIN LaFormula; IGNORE;}
++<Normal>"\\(" {/* formula mode */ LaBEGIN LaFormula; IGNORE;}
+ <LaFormula>"\\)" BEGIN Normal;
+ <LaFormula>"\n" NEWLINE;
+ <LaFormula>. ;
+
+-<Normal>"\\[" /* display mode */ {LaBEGIN LaDisplay; IGNORE;}
++<Normal>"\\[" {/* display mode */ LaBEGIN LaDisplay; IGNORE;}
+ <LaDisplay>"\\]" BEGIN Normal;
+ <LaDisplay>"\n" NEWLINE;
+ <LaDisplay>. ;
+
+-<Normal>"$$" /* display mode */ {BEGIN Display; IGNORE;}
++<Normal>"$$" {/* display mode */ BEGIN Display; IGNORE;}
+ <Display>"$$" BEGIN Normal;
+ <Display>"\n" NEWLINE;
+ <Display>. ;
+
+-<Normal>"$" /* math mode */ {BEGIN Math; IGNORE;}
++<Normal>"$" {/* math mode */ BEGIN Math; IGNORE;}
+ <Math>"$" BEGIN Normal;
+ <Math>"\n" NEWLINE;
+ <Math>"\\$" ;
+ <Math>. ;
+
+-<Normal>"\\include" /* process files */ {LaBEGIN LaInclude; IGNORE;}
++<Normal>"\\include" {/* process files */ LaBEGIN LaInclude; IGNORE;}
+ <LaInclude>[^{ \t\n}]+ { IncludeFile(yytext);
+ BEGIN Normal;
+ }
+@@ -192,11 +192,11 @@
+ <Input>"\n" NEWLINE;
+ <Input>. ;
+
+-<Normal>\\(aa|AA|ae|AE|oe|OE|ss)[ \t]*[ \t\n}] /* handle ligatures */
+- {(void)printf("%.2s", yytext+1);}
++<Normal>\\(aa|AA|ae|AE|oe|OE|ss)[ \t]*[ \t\n}] {/* handle ligatures */
++ (void)printf("%.2s", yytext+1);}
+ <Normal>\\[OoijLl][ \t]*[ \t\n}] {(void)printf("%.1s", yytext+1);}
+
+-<Normal>\\[a-zA-Z@]+ /* ignore other \cs */ {BEGIN Control; IGNORE;}
++<Normal>\\[a-zA-Z@]+ {/* ignore other \cs */ BEGIN Control; IGNORE;}
+ <Normal>"\\ " SPACE;
+ <Normal>\\. IGNORE;
+ <Control>\\[a-zA-Z@]+ IGNORE;
+@@ -205,7 +205,7 @@
+ <Control>[ \t]*[{]* {BEGIN Normal; IGNORE;}
+ <Control>. {yyless(0);BEGIN Normal;}
+
+-<Normal>[{}\\|] /* special characters */ IGNORE;
++<Normal>[{}\\|] {/* special characters */ IGNORE;}
+ <Normal>[!?]"`" IGNORE;
+ <Normal>~ SPACE;
+
diff --git a/print/detex/pkg-comment b/print/detex/pkg-comment
new file mode 100644
index 000000000000..e89fd3e66dda
--- /dev/null
+++ b/print/detex/pkg-comment
@@ -0,0 +1 @@
+Strips TeX/LaTeX codes from a file
diff --git a/print/detex/pkg-descr b/print/detex/pkg-descr
new file mode 100644
index 000000000000..87702137f9d2
--- /dev/null
+++ b/print/detex/pkg-descr
@@ -0,0 +1,3 @@
+detex takes as input a TeX source file and strips the TeX commands.
+The result is output to stdout. This is useful if you need a pure ASCII
+version of a TeX/LaTeX file.
diff --git a/print/detex/pkg-plist b/print/detex/pkg-plist
new file mode 100644
index 000000000000..aaa2d1a95513
--- /dev/null
+++ b/print/detex/pkg-plist
@@ -0,0 +1,2 @@
+bin/detex
+man/man1/detex.1.gz