aboutsummaryrefslogtreecommitdiff
path: root/print/dot2tex
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-07-01 06:56:29 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-07-01 06:56:29 +0000
commit5e9bccc6ed5f31c2df5437fc518d3c969a6fbcf8 (patch)
treeaa1160579ee8d216d758710413d1f9c2c7252d10 /print/dot2tex
parentbea4f8a142ae79bd8709d52e10462a3031a4a2b8 (diff)
downloadports-5e9bccc6ed5f31c2df5437fc518d3c969a6fbcf8.tar.gz
ports-5e9bccc6ed5f31c2df5437fc518d3c969a6fbcf8.zip
print/dot2tex: Fix incorrect Python version spec
dot2tex supports Python 2 and 3. This change removes the unecessary version spec restriction to 2.7. While I'm here: - Add PKGNAMEPREFIX (unique package names per flavor) - Enable USE_PYTHON=concurrent, each package flavor installs scripts in common locations - Add TEST_DEPENDS/test target - Add python to CATEGORIES - Pet portlint (Make file sort/group order) PR: 237984 Approved by: portmgr (maintainer timeout: 1 month) MFH: 2019Q2 (blanket(s): ports (& Python) compliance)
Notes
Notes: svn path=/head/; revision=505544
Diffstat (limited to 'print/dot2tex')
-rw-r--r--print/dot2tex/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/print/dot2tex/Makefile b/print/dot2tex/Makefile
index 2eee0bea0235..9aec55e20db9 100644
--- a/print/dot2tex/Makefile
+++ b/print/dot2tex/Makefile
@@ -3,7 +3,9 @@
PORTNAME= dot2tex
PORTVERSION= 2.9.0
-CATEGORIES= print
+PORTREVISION= 1
+CATEGORIES= print python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= tota@FreeBSD.org
COMMENT= Graphviz to LaTeX converter
@@ -13,11 +15,21 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>=1.4.8:devel/py-pyparsing@${PY_FLAVOR} \
dot:graphics/graphviz
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
-NO_ARCH= yes
-USES= python:2.7
-USE_PYTHON= distutils autoplist
+USES= python
USE_GITHUB= yes
+USE_PYTHON= distutils autoplist concurrent
+
+# Enable this before running test target
+# bsd.tex.mk doesnt support :test (only) depends
+#USE_TEX= latex
+
GH_ACCOUNT= kjellmf
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m nose
+
.include <bsd.port.mk>