aboutsummaryrefslogtreecommitdiff
path: root/print/dvipdfmx
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2009-06-24 08:08:23 +0000
committerHiroki Sato <hrs@FreeBSD.org>2009-06-24 08:08:23 +0000
commit1999a1ac11a9d00e83cf41271e888dcc9d6aaf84 (patch)
treed9d80756aeb4336d6ec30f452027b5a2e79227b0 /print/dvipdfmx
parent0f2aedc509d3056b00e6d5caaa512786a84bf104 (diff)
Update to 20090522. Changes include:
- Added dvipdfm compatibility mode. This mode is triggered if dvipdfmx is called as "dvipdfm", and likewise extractbb as "ebb". (The latter mode was already present.) - Improved PDF version handling. A "Version" entry in the document catalog is now honored. Moreover, dvipdfmx accepts to write PDF 1.7, and extractbb doesn't complain about PDF versions any more. Encryption keys too long for PDF 1.3 now lead to an error instead of a silent change of PDF version. - Bug fix: \special{pdf:bann} ... \special{pdf:eann} (e.g., \hyperlink) cause a problem when it was surrounded by the pair \special{pdf:bcontent} ... \special{\special{pdf:econtent}. - Removed binary mode option "-b". In ebb, just ignore it. - xbb: Changed output-to-stdout option to "-O". - Fixed two problems with removal of PDF destinations: Non-link annotations produced a warning, and broken links were not detected if no valid destination existed. Removing unused destinations is now default behaviour and can be prevented by using the flag "-C 0x10". Since the feature is still new, this flag is set in dvipdfmx.cfg. Approved by: maintainer timeout (1 month)
Notes
Notes: svn path=/head/; revision=236574
Diffstat (limited to 'print/dvipdfmx')
-rw-r--r--print/dvipdfmx/Makefile3
-rw-r--r--print/dvipdfmx/distinfo6
-rw-r--r--print/dvipdfmx/files/patch-src-dvipdfmx.c38
3 files changed, 16 insertions, 31 deletions
diff --git a/print/dvipdfmx/Makefile b/print/dvipdfmx/Makefile
index 296bd3c8bf31..b03c71cac187 100644
--- a/print/dvipdfmx/Makefile
+++ b/print/dvipdfmx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dvipdfmx
-PORTVERSION= 20080607
-PORTREVISION= 1
+PORTVERSION= 20090522
CATEGORIES= print
MASTER_SITES= http://project.ktug.or.kr/dvipdfmx/snapshot/latest/ \
http://project.ktug.or.kr/dvipdfmx/snapshot/archive/
diff --git a/print/dvipdfmx/distinfo b/print/dvipdfmx/distinfo
index 79a218a37ff3..be85da46aab5 100644
--- a/print/dvipdfmx/distinfo
+++ b/print/dvipdfmx/distinfo
@@ -1,3 +1,3 @@
-MD5 (dvipdfmx/dvipdfmx-20080607.tar.gz) = df7e8584e8de5351b733468ea2ee782e
-SHA256 (dvipdfmx/dvipdfmx-20080607.tar.gz) = 76d91278491a263dfcb93349a2511c91930675f914fd9521135a49e893b79b98
-SIZE (dvipdfmx/dvipdfmx-20080607.tar.gz) = 549165
+MD5 (dvipdfmx/dvipdfmx-20090522.tar.gz) = 32e74f231fd0ce1d9e6ce2ffb0967e37
+SHA256 (dvipdfmx/dvipdfmx-20090522.tar.gz) = dcf8bc500c02e41974630df8bf8327d898196560fe6c1dc14ac5a3fd2824d6cc
+SIZE (dvipdfmx/dvipdfmx-20090522.tar.gz) = 592781
diff --git a/print/dvipdfmx/files/patch-src-dvipdfmx.c b/print/dvipdfmx/files/patch-src-dvipdfmx.c
index 47b52b77bada..27d9a97986f9 100644
--- a/print/dvipdfmx/files/patch-src-dvipdfmx.c
+++ b/print/dvipdfmx/files/patch-src-dvipdfmx.c
@@ -1,26 +1,12 @@
---- src/dvipdfmx.c.orig 2008-05-29 19:40:29.000000000 +0900
-+++ src/dvipdfmx.c 2008-06-11 00:50:55.000000000 +0900
-@@ -30,6 +30,7 @@
- #include <string.h>
- #include <limits.h>
- #include <ctype.h>
-+#include <libgen.h>
-
- #include "system.h"
- #include "mem.h"
-@@ -773,10 +774,13 @@
- main (int argc, char *argv[])
- {
- double dvi2pts;
-+ char *bn = basename(argv[0]);
-
-- if (strcmp(argv[0], "ebb") == 0)
-+ if (strcmp(bn, "ebb") == 0)
- return extractbb(argc, argv, EBB_OUTPUT);
-- else if (strcmp(argv[0], "xbb") == 0 || strcmp(argv[0], "extractbb") == 0)
-+ else if (strcmp(bn, "ebb-dvipdfmx") == 0)
-+ return extractbb(argc, argv, EBB_OUTPUT);
-+ else if (strcmp(bn, "xbb") == 0 || strcmp(bn, "extractbb") == 0)
- return extractbb(argc, argv, XBB_OUTPUT);
-
- mem_debug_init();
+--- src/dvipdfmx.c.orig 2009-05-11 11:15:25.000000000 +0900
++++ src/dvipdfmx.c 2009-06-12 10:26:27.000000000 +0900
+@@ -806,6 +806,9 @@
+ if (!(strcmp(base, "dvipdfm") && strcmp(base, "ebb")))
+ compat_mode = 1;
+
++ if (strcmp(base, "ebb-dvipdfmx") == 0)
++ return extractbb(argc, argv);
++
+ if (!(strcmp(base, "extractbb") && strcmp(base, "xbb") &&
+ strcmp(base, "ebb")))
+ return extractbb(argc, argv);