aboutsummaryrefslogtreecommitdiff
path: root/print/epson-inkjet-printer-201601w
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2019-07-10 14:40:02 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2019-07-10 14:40:02 +0000
commit7003875294fc8b811ffe452c376f66a855494f60 (patch)
tree9754e52797ffd2ab1caf7b83b3fa360ba5db8a85 /print/epson-inkjet-printer-201601w
parentb3ec6fb0fe1868f49bc3ae82909a818a4d043678 (diff)
downloadports-7003875294fc8b811ffe452c376f66a855494f60.tar.gz
ports-7003875294fc8b811ffe452c376f66a855494f60.zip
On amd64 adding DEFAULT_VERSIONS+=linux=c6 to /etc/make.conf made Linux
infrastructure ports (linux_base-c6 and linux-c6*) install i386 CentOS 6 packages. Using c6_64 instead of c6 made them install mixed amd64/i386 CentOS 6 packages and allowed Linux application ports to install amd64 binaries when available. The i386-only configuration was only useful for users of x11/nvidia-driver* which didn't provide Linux amd64 emulation until recently. With x11/nvidia-driver* now supporting Linux amd64 there's no longer a need for i386-only Linux on amd64. Let DEFAULT_VERSIONS+=linux=c6 make Linux infrastructure ports install mixed amd64/i386 CentOS 6 packages, like c6_64 before, and remove support for c6_64 as a value. Replace LINUX_ARCH with ARCH everywhere because they are always the same now.
Notes
Notes: svn path=/head/; revision=506352
Diffstat (limited to 'print/epson-inkjet-printer-201601w')
-rw-r--r--print/epson-inkjet-printer-201601w/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/print/epson-inkjet-printer-201601w/Makefile b/print/epson-inkjet-printer-201601w/Makefile
index 2ee6aa38cef6..c4ef71a8c575 100644
--- a/print/epson-inkjet-printer-201601w/Makefile
+++ b/print/epson-inkjet-printer-201601w/Makefile
@@ -29,11 +29,11 @@ PLIST_SUB= LINUXBASE=${LINUXBASE} \
USES= linux
USE_LINUX= cups-libs jpeg
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${LINUX_ARCH} == i386
+.if ${ARCH} == i386
PLIST_SUB+= LIBDIR=lib
-.elif ${LINUX_ARCH} == x86_64
+.elif ${ARCH} == amd64
PLIST_SUB+= LIBDIR=lib64
.endif
@@ -50,4 +50,4 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/cups/model/
${LN} -sf ${LINUXBASE}/opt/${PORTNAME}/ppds/Epson ${STAGEDIR}${PREFIX}/share/cups/model/Epson-201601w
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>