aboutsummaryrefslogtreecommitdiff
path: root/print/foomatic-filters
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2020-08-24 11:39:17 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2020-08-24 11:39:17 +0000
commit72f8b649105ea596b366d4d45f52dc524ea76e0a (patch)
tree1d141ebb5ce388e6aa2dbfa7461297bd8e69ea92 /print/foomatic-filters
parent3f226e3afbf0cbfd2663dbbdb21efc241281f117 (diff)
downloadports-72f8b649105ea596b366d4d45f52dc524ea76e0a.tar.gz
ports-72f8b649105ea596b366d4d45f52dc524ea76e0a.zip
print/foomatic-filters: No-op formatting changes
- accept portfmt/portclippy suggestions - remove REINPLACE_CMD that was not modifying any files
Notes
Notes: svn path=/head/; revision=546068
Diffstat (limited to 'print/foomatic-filters')
-rw-r--r--print/foomatic-filters/Makefile32
1 files changed, 15 insertions, 17 deletions
diff --git a/print/foomatic-filters/Makefile b/print/foomatic-filters/Makefile
index 8894a4732cb7..090991d890ab 100644
--- a/print/foomatic-filters/Makefile
+++ b/print/foomatic-filters/Makefile
@@ -13,14 +13,12 @@ COMMENT= Foomatic wrapper scripts
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-CONFLICTS= cups-filters-[0-9]*
-
USES= autoreconf ghostscript perl5 pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_A2PS=${LOCALBASE}/bin/a2ps \
ac_cv_path_CUPS=${LOCALBASE}/libexec/cups \
- ac_cv_path_CUPS_FILTERS=${LOCALBASE}/libexec/cups/filter \
ac_cv_path_CUPS_BACKENDS=${LOCALBASE}/libexec/cups/backend \
+ ac_cv_path_CUPS_FILTERS=${LOCALBASE}/libexec/cups/filter \
ac_cv_path_ENSCRIPT=${LOCALBASE}/bin/enscript \
ac_cv_path_MPAGE=${LOCALBASE}/bin/mpage \
ac_cv_path_PERL=${LOCALBASE}/bin/perl \
@@ -32,30 +30,30 @@ CONFIGURE_ENV= ac_cv_path_A2PS=${LOCALBASE}/bin/a2ps \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= A2PS DBUS CUPS_IMAGE MPAGE
-OPTIONS_RADIO= ENSCRIPT
-OPTIONS_RADIO_ENSCRIPT= ENSCRIPT_A4 ENSCRIPT_LETTER ENSCRIPT_LETTERDJ
-OPTIONS_DEFAULT= A2PS CUPS_IMAGE DBUS ENSCRIPT_A4 MPAGE
-CUPS_IMAGE_DESC= Install cups image utilities
-A2PS_DESC= Install a2ps convertor
-ENSCRIPT_A4_DESC= Install enscript convertor (A4)
-ENSCRIPT_LETTER_DESC= Install enscript convertor (letter)
-ENSCRIPT_LETTERDJ_DESC= Install enscript convertor (letterdj)
-MPAGE_DESC= Print multiple pages per sheet of paper
+CONFLICTS= cups-filters-[0-9]*
+
+OPTIONS_DEFINE= A2PS CUPS_IMAGE DBUS MPAGE
+OPTIONS_DEFAULT= A2PS CUPS_IMAGE DBUS ENSCRIPT_A4 MPAGE
+OPTIONS_RADIO= ENSCRIPT
+OPTIONS_RADIO_ENSCRIPT= ENSCRIPT_A4 ENSCRIPT_LETTER ENSCRIPT_LETTERDJ
+
+A2PS_DESC= Install a2ps convertor
+CUPS_IMAGE_DESC= Install cups image utilities
+ENSCRIPT_A4_DESC= Install enscript convertor (A4)
+ENSCRIPT_LETTERDJ_DESC= Install enscript convertor (letterdj)
+ENSCRIPT_LETTER_DESC= Install enscript convertor (letter)
+MPAGE_DESC= Print multiple pages per sheet of paper
A2PS_RUN_DEPENDS= a2ps:print/a2ps
CUPS_IMAGE_LIB_DEPENDS= libcupsimage.so:print/cups
-DBUS_CONFIGURE_ENABLE= dbus
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
+DBUS_CONFIGURE_ENABLE= dbus
ENSCRIPT_A4_RUN_DEPENDS= enscript:print/enscript-a4
ENSCRIPT_LETTERDJ_RUN_DEPENDS= enscript:print/enscript-letterdj
ENSCRIPT_LETTER_RUN_DEPENDS= enscript:print/enscript-letter
MPAGE_RUN_DEPENDS= mpage:print/mpage
post-patch:
- @${REINPLACE_CMD} -e 's|/bin/bash|${SH}|g' ${WRKSRC}/foomaticrip.c
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/foomaticrip.c
@${REINPLACE_CMD} -e 's|ln -sf $$(BINDIR)|ln -sf ../../../bin|g' \
-e '/filter.conf/ s|if.*||' \
${WRKSRC}/Makefile.am