aboutsummaryrefslogtreecommitdiff
path: root/print/fpdf
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-08 16:08:52 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-04-08 16:08:52 +0000
commit781eccbe54ee08f604dcfbd36d0358f2e007cd06 (patch)
treecc38295bab4e41592069ddc9166b0e386410a330 /print/fpdf
parent3da197a13f3ad29afd322b2598d69b044235afa6 (diff)
downloadports-781eccbe54ee08f604dcfbd36d0358f2e007cd06.tar.gz
ports-781eccbe54ee08f604dcfbd36d0358f2e007cd06.zip
Don"t try to convert every type of files.
PR: 95453 Submitted by: Dmitry Marakasov <amdmi3 (at) mail.ru>
Notes
Notes: svn path=/head/; revision=159133
Diffstat (limited to 'print/fpdf')
-rw-r--r--print/fpdf/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/print/fpdf/Makefile b/print/fpdf/Makefile
index a1220dadaa5b..61e52a58aac5 100644
--- a/print/fpdf/Makefile
+++ b/print/fpdf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fpdf
PORTVERSION= 1.53
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print www
MASTER_SITES= http://www.fpdf.org/fr/
DISTNAME= ${PORTNAME}${PORTVERSION:S|.||}
@@ -18,7 +18,6 @@ COMMENT= A free PHP class to generate PDF files with pure PHP
USE_PHP= zlib
-USE_DOS2UNIX= yes
FETCH_CMD= /usr/bin/fetch -ARr -o ${DISTDIR}/${DISTFILES}
NO_BUILD= yes
@@ -28,6 +27,7 @@ SUB_FILES= pkg-message
SUB_LIST= FPDF_DIR=${FPDF_DIR}
PLIST_SUB= FPDF_DIR=${FPDF_DIR}
+EXT2CNV= afm css htm php txt
DOCS= FAQ.htm doc/* fpdf.css histo.htm install.txt tutoriel
do-fetch:
@@ -37,6 +37,11 @@ do-fetch:
fi
pre-patch:
+ @${ECHO_MSG} "===> Converting DOS text files to UNIX text files"
+.for ext in ${EXT2CNV}
+ @${FIND} ${WRKSRC} -type f -name "*.${ext}" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -i '' -e 's/ $$//'
+.endfor
@${FIND} ${WRKSRC} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
do-install: