aboutsummaryrefslogtreecommitdiff
path: root/print/freetype2/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-11-13 17:06:48 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-11-13 17:06:48 +0000
commit272ffecbc2b081da338c2bd5ddfe9223ee9d0c84 (patch)
tree03d0cc5a22429cb3589f965a52ecb76a015caf41 /print/freetype2/Makefile
parent687aa4b304299b010b4162849b6e599eb4672d48 (diff)
downloadports-272ffecbc2b081da338c2bd5ddfe9223ee9d0c84.tar.gz
ports-272ffecbc2b081da338c2bd5ddfe9223ee9d0c84.zip
Notes
Diffstat (limited to 'print/freetype2/Makefile')
-rw-r--r--print/freetype2/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index 8968f09e1b8e..b5f365641b85 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -5,8 +5,8 @@
# $FreeBSD$
#
-PORTNAME= freetype
-PORTVERSION= 1.3.1
+PORTNAME= freetype2
+PORTVERSION= 2.0
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://sunsite.cnlab-switch.ch/ftp/mirror/freetype/freetype1/ \
@@ -21,15 +21,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jseger@FreeBSD.org
+USE_BZIP2= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-nls --enable-static --enable-shared
+CONFIGURE_WRKSRC= ${WRKSRC}/builds/unix
+LIBTOOLFILES= ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-# Older versions of freetype installed include files in ${PREFIX}/include
-# this is a compatibility hack for now
-
-post-install:
- ${LN} -fs ${PREFIX}/include/freetype/*.h ${PREFIX}/include
+post-configure:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} setup)
.include <bsd.port.mk>