aboutsummaryrefslogtreecommitdiff
path: root/print/freetype2
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2018-04-02 19:38:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2018-04-02 19:38:39 +0000
commit5793655762a99c85caa97db610d2b690f81cebea (patch)
tree381d1403e1da9456db1c12573616c8f27e2c8767 /print/freetype2
parent558907ff0e68c4f86cd87a298874169c1831b47b (diff)
downloadports-5793655762a99c85caa97db610d2b690f81cebea.tar.gz
ports-5793655762a99c85caa97db610d2b690f81cebea.zip
Incorporate a patch from uptream
Remove the LCD filtering option, now freetype2 offers by default a LCD optimized output, no need to keep the old LCD filtering option (keeping it off may confuse users) and let freetype2 use the new "Harmony LCD rendering" Thanks jbeich for pointing me at the PR I missed. PR: 225072 Submitted by: lightside <lightside@gmx.com>
Notes
Notes: svn path=/head/; revision=466253
Diffstat (limited to 'print/freetype2')
-rw-r--r--print/freetype2/Makefile10
-rw-r--r--print/freetype2/files/correct-flex-features.patch54
2 files changed, 59 insertions, 5 deletions
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index d8f2f256f220..dc45b50ce36e 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= freetype2
PORTVERSION= 2.9
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= http://savannah.nongnu.org/download/freetype/ \
SF/freetype/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/}/ \
@@ -36,18 +37,20 @@ PORTDOCS= reference CHANGES formats.txt LICENSE.TXT raster.txt
CPE_PRODUCT= freetype
CPE_VENDOR= freetype
-OPTIONS_DEFINE= DEBUG DOCS LCD_FILTERING LONG_PCF_NAMES PNG \
+OPTIONS_DEFINE= DEBUG DOCS LONG_PCF_NAMES PNG \
TABLE_VALIDATION
OPTIONS_GROUP= SUBPIXEL_HINTING
OPTIONS_GROUP_SUBPIXEL_HINTING= V38 V40
OPTIONS_RADIO= SIZE_METRICS_CHOICE
OPTIONS_RADIO_SIZE_METRICS_CHOICE= FIX_SIZE_METRICS TT_SIZE_METRICS
-OPTIONS_DEFAULT= LCD_FILTERING V40
+OPTIONS_DEFAULT= V40
PNG_DESC= Png compressed OpenType embedded bitmaps support
PNG_LIB_DEPENDS= libpng.so:graphics/png
PNG_CONFIGURE_WITH= png
+EXTRA_PATCHES= ${FILESDIR}/correct-flex-features.patch:-p1
+
TABLE_VALIDATION_DESC= TrueType GX/AAT and OpenType table validation
SIZE_METRICS_CHOICE_DESC= Size metrics for TrueType fonts
@@ -55,9 +58,6 @@ FIX_SIZE_METRICS_DESC= Fix metrics on size request for scalable fonts (alternati
FIX_SIZE_METRICS_EXTRA_PATCHES= ${FILESDIR}/extra-patch-fix_size_metrics.diff
TT_SIZE_METRICS_DESC= TrueType-like size metrics for 'light' auto-hinting
-LCD_FILTERING_DESC?= Sub-pixel rendering (patented)
-LCD_FILTERING_CFLAGS= -DFT_CONFIG_OPTION_SUBPIXEL_RENDERING
-
LONG_PCF_NAMES_DESC= Enable long PCF family names
SUBPIXEL_HINTING_DESC= Sub-pixel hinting support
diff --git a/print/freetype2/files/correct-flex-features.patch b/print/freetype2/files/correct-flex-features.patch
new file mode 100644
index 000000000000..7896545f4cc7
--- /dev/null
+++ b/print/freetype2/files/correct-flex-features.patch
@@ -0,0 +1,54 @@
+From cc2f3cdecff5a351e7e8961b9f2e389ab740231a Mon Sep 17 00:00:00 2001
+From: Ewald Hew <ewaldhew@gmail.com>
+Date: Wed, 10 Jan 2018 13:24:56 +0800
+Subject: [psaux] Correctly handle Flex features (#52846).
+
+* src/psaux/psintrp.c (cf2_interpT2CharString) <cf2_cmdVMOVETO,
+cf2_cmdHMOVETO>: Do not move if doing Flex.
+---
+ ChangeLog | 7 +++++++
+ src/psaux/psintrp.c | 6 ++++--
+ 2 files changed, 11 insertions(+), 2 deletions(-)
+
+diff --git a/ChangeLog b/ChangeLog
+index 1343401..96359ee 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,10 @@
++2018-01-10 Ewald Hew <ewaldhew@gmail.com>
++
++ [psaux] Correctly handle Flex features (#52846).
++
++ * src/psaux/psintrp.c (cf2_interpT2CharString) <cf2_cmdVMOVETO,
++ cf2_cmdHMOVETO>: Do not move if doing Flex.
++
+ 2018-01-09 Alexei Podtelezhnikov <apodtele@gmail.com>
+
+ * builds/windows/vc2010/freetype.sln: Synchronize with the project.
+diff --git a/src/psaux/psintrp.c b/src/psaux/psintrp.c
+index 5c0ee78..da5a8da 100644
+--- a/src/psaux/psintrp.c
++++ b/src/psaux/psintrp.c
+@@ -852,7 +852,8 @@
+
+ curY = ADD_INT32( curY, cf2_stack_popFixed( opStack ) );
+
+- cf2_glyphpath_moveTo( &glyphPath, curX, curY );
++ if ( !decoder->flex_state )
++ cf2_glyphpath_moveTo( &glyphPath, curX, curY );
+
+ break;
+
+@@ -2674,7 +2675,8 @@
+
+ curX = ADD_INT32( curX, cf2_stack_popFixed( opStack ) );
+
+- cf2_glyphpath_moveTo( &glyphPath, curX, curY );
++ if ( !decoder->flex_state )
++ cf2_glyphpath_moveTo( &glyphPath, curX, curY );
+
+ break;
+
+--
+cgit v1.0-41-gc330
+