aboutsummaryrefslogtreecommitdiff
path: root/print/freetype
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-08-21 11:02:37 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-08-21 11:02:37 +0000
commitad1f05ade415f2b939f40efef3d5a644855245af (patch)
tree0e190b76bc1ba54f9186f76f8cfe4b0b2dafdc93 /print/freetype
parent57a3e704b38590181a7c921e6fe39110c60ee9ab (diff)
Notes
Diffstat (limited to 'print/freetype')
-rw-r--r--print/freetype/Makefile1
-rw-r--r--print/freetype/files/patch-lib::arch::unix::Makefile.in54
2 files changed, 49 insertions, 6 deletions
diff --git a/print/freetype/Makefile b/print/freetype/Makefile
index ffc1f63ab958..9015a26e6ba7 100644
--- a/print/freetype/Makefile
+++ b/print/freetype/Makefile
@@ -20,7 +20,6 @@ MASTER_SITE_SUBDIR= freetype1
MAINTAINER= ports@FreeBSD.org
COMMENT= A free and portable TrueType font rendering engine
-USE_GMAKE= yes
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-nls --enable-static --enable-shared
diff --git a/print/freetype/files/patch-lib::arch::unix::Makefile.in b/print/freetype/files/patch-lib::arch::unix::Makefile.in
index e5519bd3eff2..a97729fb0760 100644
--- a/print/freetype/files/patch-lib::arch::unix::Makefile.in
+++ b/print/freetype/files/patch-lib::arch::unix::Makefile.in
@@ -1,8 +1,25 @@
-
-$FreeBSD$
-
---- lib/arch/unix/Makefile.in 2002/03/14 07:15:48 1.1
-+++ lib/arch/unix/Makefile.in 2002/03/14 07:16:24
+--- lib/arch/unix/Makefile.in.orig Sat Jul 31 08:48:17 1999
++++ lib/arch/unix/Makefile.in Sat Aug 21 12:55:07 2004
+@@ -2,8 +2,8 @@
+ #
+ # lib/arch/unix/Makefile.in
+
+-ARCH = arch/unix
+-FT_MAKEFILE = $(ARCH)/Makefile
++FTARCH = arch/unix
++FT_MAKEFILE = $(FTARCH)/Makefile
+
+ RM = @RM@
+ RMF = @RM@ -f
+@@ -83,7 +83,7 @@
+ $(srcdir)/$(FILESRC) \
+ $(srcdir)/$(MEMSRC) \
+ $(srcdir)/$(MUTEXSRC)
+-SRC_S = $(srcdir)/$(ARCH)/freetype.c
++SRC_S = $(srcdir)/$(FTARCH)/freetype.c
+
+ # all header files
+ HEADERS = $(srcdir)/freetype.h \
@@ -200,10 +200,10 @@
-version-info $(version_info) $(FT_LIBS)
@@ -16,3 +33,30 @@ $FreeBSD$
done
uninstall:
+@@ -218,15 +218,15 @@
+ -$(RMF) file.c memory.c mutex.c
+ -$(RMF) libttf.la
+ -$(RMF) *.orig *~ core *.core
+- -$(RMF) $(ARCH)/Makefile
++ -$(RMF) $(FTARCH)/Makefile
+ -$(RMF) .libs/*
+ -$(RMDIR) .libs
+
+ depend: do_link
+ (echo '/^#.* PUT NO STUFF BELOW/,$$d' ; echo w ; echo q) | \
+- ed - $(ARCH)/Makefile
++ ed - $(FTARCH)/Makefile
+ echo '# Dependencies generated by make depend: PUT NO STUFF BELOW' \
+- >> $(ARCH)/Makefile
++ >> $(FTARCH)/Makefile
+ for file in $(SRC_S) $(SRC_M) $(EXTSRC) ; do \
+ $(CPP) $(CPPFLAGS) $(INCLUDES) $$file | \
+ sed -n -e 's|^# [1-9][0-9]* "\([^/].*\.h\)".*|\1|p' \
+@@ -239,6 +239,6 @@
+ else if ($$1 != last) \
+ { print line ; line = last = $$1 } \
+ line = line " " $$2 } \
+- END { print line }' >> $(ARCH)/Makefile
++ END { print line }' >> $(FTARCH)/Makefile
+
+ # Dependencies generated by make depend: PUT NO STUFF BELOW