aboutsummaryrefslogtreecommitdiff
path: root/print/gsfonts/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-03 02:49:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-03 02:49:53 +0000
commit47fa642433aa4d5becf6748ef5fbce2bf843b131 (patch)
tree06f14e2c23413551f07af7f2223a6017eecace50 /print/gsfonts/Makefile
parent1fbf6e36072f1161941052ebe67eab109440705d (diff)
- Stage support
Notes
Notes: svn path=/head/; revision=342377
Diffstat (limited to 'print/gsfonts/Makefile')
-rw-r--r--print/gsfonts/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/print/gsfonts/Makefile b/print/gsfonts/Makefile
index add7bc718dd2..3c15a283e8fd 100644
--- a/print/gsfonts/Makefile
+++ b/print/gsfonts/Makefile
@@ -16,10 +16,10 @@ COMMENT= Standard Fonts for Ghostscript
NO_WRKSUBDIR= yes
NO_BUILD= yes
-PLIST_SUB= FONTSDIR="${FONTSDIR:S|${PREFIX}/||}"
+PLIST_SUB= FONTSDIR="${FONTSDIR:S|${STAGEDIR}${PREFIX}/||}"
OPTIONS_DEFINE= DOCS
-FONTSDIR= ${PREFIX}/share/ghostscript/fonts
+FONTSDIR= ${STAGEDIR}${PREFIX}/share/ghostscript/fonts
CJKFONTS?= std.ja_JP/Ryumin-Light \
std.ja_JP/GothicBBB-Medium \
std.ja_JP/Ryumin-Light.gs7 \
@@ -28,7 +28,6 @@ CJKFONTS?= std.ja_JP/Ryumin-Light \
std.zh_CN/STSong-Light \
std.zh_CN/MSung-Light
-NO_STAGE= yes
do-install:
${MKDIR} ${FONTSDIR}
cd ${WRKSRC}/fonts && \
@@ -43,12 +42,10 @@ do-install:
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= ChangeLog README README.tweaks TODO
post-install:
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/fonts && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/fonts && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>