aboutsummaryrefslogtreecommitdiff
path: root/print/hyperlatex
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-07-06 15:44:33 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-07-06 15:44:33 +0000
commit39e13ec7d5ac992b1aa1a5028d64b3ca12ad2111 (patch)
tree6b3372f805f7c99802f7639f2a7b819aaeec0ba5 /print/hyperlatex
parentb81ae5b934dc7dac8dd1d5e843b71378c9a29d84 (diff)
downloadports-39e13ec7d5ac992b1aa1a5028d64b3ca12ad2111.tar.gz
ports-39e13ec7d5ac992b1aa1a5028d64b3ca12ad2111.zip
Add staging support
Notes
Notes: svn path=/head/; revision=360928
Diffstat (limited to 'print/hyperlatex')
-rw-r--r--print/hyperlatex/Makefile17
-rw-r--r--print/hyperlatex/pkg-plist3
2 files changed, 9 insertions, 11 deletions
diff --git a/print/hyperlatex/Makefile b/print/hyperlatex/Makefile
index df8f8748f653..9cee2be720e3 100644
--- a/print/hyperlatex/Makefile
+++ b/print/hyperlatex/Makefile
@@ -18,7 +18,6 @@ USE_EMACS= yes
LATEX_DIR= ${PREFIX}/share/texmf/tex/latex/hyperlatex
HYPERLATEX_DIR= ${PREFIX}/share/hyperlatex
-NO_STAGE= yes
do-configure:
@(cd ${WRKSRC} && \
${REINPLACE_CMD} -e 's|http://www.cs.uu.nl/\\~{}otfried/img/||' hlx/siteinit.hlx && \
@@ -29,13 +28,15 @@ do-build:
cd ${WRKSRC}/hlx; emacs -batch -q -no-site-file -l hyperlatex.el -f hyperlatex-compile
do-install:
- ${MKDIR} ${HYPERLATEX_DIR}
- ${MKDIR} ${LATEX_DIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/hyperlatex ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/ps2image ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/normalize-eps.awk ${PREFIX}/bin/normalize-eps
- ${INSTALL_DATA} ${WRKSRC}/etc/hyperlatex.sty ${LATEX_DIR}
+ @${MKDIR} ${STAGEDIR}${HYPERLATEX_DIR}
+ @${MKDIR} ${STAGEDIR}${LATEX_DIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/hyperlatex ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/ps2image ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/normalize-eps.awk \
+ ${STAGEDIR}${PREFIX}/bin/normalize-eps
+ ${INSTALL_DATA} ${WRKSRC}/etc/hyperlatex.sty ${STAGEDIR}${LATEX_DIR}
cd ${WRKSRC}/hlx; for f in *.el *.elc *.hlx *.xbm *.awk ; do \
- if [ -f $$f ]; then ${INSTALL_DATA} $$f ${HYPERLATEX_DIR}; fi; done
+ if [ -f $$f ]; then ${INSTALL_DATA} $$f \
+ ${STAGEDIR}${HYPERLATEX_DIR}; fi; done
.include <bsd.port.mk>
diff --git a/print/hyperlatex/pkg-plist b/print/hyperlatex/pkg-plist
index 967c04b79d4e..086cdb1201fa 100644
--- a/print/hyperlatex/pkg-plist
+++ b/print/hyperlatex/pkg-plist
@@ -28,7 +28,4 @@ share/hyperlatex/siteinit.hlx
share/hyperlatex/tabularx.hlx
share/texmf/tex/latex/hyperlatex/hyperlatex.sty
@dirrmtry share/texmf/tex/latex/hyperlatex
-@dirrmtry share/texmf/tex/latex
-@dirrmtry share/texmf/tex
-@dirrmtry share/texmf
@dirrmtry share/hyperlatex