aboutsummaryrefslogtreecommitdiff
path: root/print/kde_poster
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-12-24 17:34:49 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-12-24 17:34:49 +0000
commite8b1b89949966eac7f2cf823f59f0419879c31fb (patch)
treeace1afe91828577d11d99a5715aef8be24988a5c /print/kde_poster
parentf8cfface7c543dd240e218eeeadb50e47394f69b (diff)
downloadports-e8b1b89949966eac7f2cf823f59f0419879c31fb.tar.gz
ports-e8b1b89949966eac7f2cf823f59f0419879c31fb.zip
- Fix the build when only clang is present
- Respect CFLAGS (bump PORTREVISION for consistency) - Set LICENSE - Support staging - Do not silence the calls made in the do-install target - Stop needlessly setting PKGNAMESUFFIX
Notes
Notes: svn path=/head/; revision=337377
Diffstat (limited to 'print/kde_poster')
-rw-r--r--print/kde_poster/Makefile13
-rw-r--r--print/kde_poster/files/patch-Makefile13
2 files changed, 19 insertions, 7 deletions
diff --git a/print/kde_poster/Makefile b/print/kde_poster/Makefile
index 91cad060db59..135cb5d94d37 100644
--- a/print/kde_poster/Makefile
+++ b/print/kde_poster/Makefile
@@ -3,28 +3,27 @@
PORTNAME= kde_poster
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= print kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= printing
-PKGNAMESUFFIX?= # empty
DISTNAME= poster
MAINTAINER= ports@FreeBSD.org
COMMENT= KDE version of the poster utility
+LICENSE= GPL2
+
USE_BZIP2= yes
-USE_GMAKE= yes
ALL_TARGET= poster
WRKSRC= ${WRKDIR}/${DISTNAME}-20060221
CONFLICTS?= poster-[0-9]*
-MAN1= poster.1
-PLIST_FILES= bin/poster
+PLIST_FILES= bin/poster man/man1/poster.1.gz
-NO_STAGE= yes
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin
- @${INSTALL_DATA} ${WRKSRC}/${DISTNAME}.1 ${PREFIX}/man/man1/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/${DISTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/print/kde_poster/files/patch-Makefile b/print/kde_poster/files/patch-Makefile
new file mode 100644
index 000000000000..f1dbdf7fd5a4
--- /dev/null
+++ b/print/kde_poster/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2002-08-29 19:15:37.000000000 +0300
++++ Makefile 2013-12-24 19:18:30.000000000 +0200
+@@ -1,8 +1,8 @@
+-CFLAGS = -g -Wall
++#CFLAGS = -g -Wall
+ #CFLAGS = -O2 -Wall
+
+ poster: poster.c
+- gcc $(CFLAGS) -o poster poster.c -lm
++ $(CC) $(CFLAGS) -o poster poster.c -lm
+
+ # HPUX: cc -O -Aa -D_POSIX_SOURCE -o poster poster.c -lm
+ # Note that this program might trigger a stupid bug in the HPUX C library,