aboutsummaryrefslogtreecommitdiff
path: root/print/latex-beamer
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2007-01-04 21:48:19 +0000
committerHiroki Sato <hrs@FreeBSD.org>2007-01-04 21:48:19 +0000
commit810c4f5f9ddbca92ea9e0ea0bbe4fc5b433cc29f (patch)
tree3125a241b9dd4b90ad08f504f8d676aef64eb890 /print/latex-beamer
parent599a1b5a3f1f7a040bce5c8b4b614b6f34741402 (diff)
downloadports-810c4f5f9ddbca92ea9e0ea0bbe4fc5b433cc29f.tar.gz
ports-810c4f5f9ddbca92ea9e0ea0bbe4fc5b433cc29f.zip
Resurrect print/latex-pgf and print/latex-beamer and update
them to 1.01 and 3.06 respectively. Changes since latex-beamer 3.01 (included in teTeX) include: - Fixed bug in drawing of buttons. - Version for use with pgf version 1.00. - Added color theme wolverine and presentation theme AnnArbor, submitted by Madhusudan Singh <madhusudan.singh@gmail.com>. - Added two screen options. - Added subsubsections (evil!). - Added \begin{frame}{Title}{Subtitle} syntax. - Switched to pgf version 0.95 - \setbeamercovered is now scoped. - Fixed location of navigation symbols on plain frames. - Fixed wrong frame number in conjunction with fragile option. - Fixed compatibility definitions like \beamertemplateballtoc. - Fixed compatibility definitions for \beamersetleftmargin. - Fixed wobbling height of frametitle in default theme. - Fixed problem with serif theme and "onlymath" option. - Fixed problem with >127 characters and fragile option. - Fixed problem with activation of Chinese characters - Fixed problem with spaces in semiverbatim.
Notes
Notes: svn path=/head/; revision=181434
Diffstat (limited to 'print/latex-beamer')
-rw-r--r--print/latex-beamer/Makefile68
-rw-r--r--print/latex-beamer/distinfo3
-rw-r--r--print/latex-beamer/pkg-descr6
3 files changed, 77 insertions, 0 deletions
diff --git a/print/latex-beamer/Makefile b/print/latex-beamer/Makefile
new file mode 100644
index 000000000000..8178a0090cbe
--- /dev/null
+++ b/print/latex-beamer/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: latex-beamer
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-beamer
+PORTVERSION= 3.06
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX class to create a beamer presentation
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX-base \
+ ${TEXMFDIR_LSR}:${PORTSDIR}/print/tex-texmflocal
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
+ ${LOCALBASE}/${TEXMFDIR}/tex/latex/pgf/basiclayer/pgf.sty:${PORTSDIR}/print/latex-pgf \
+ ${TEXMFDIR_LSR}:${PORTSDIR}/print/tex-texmflocal
+
+NO_BUILD= YES
+PLIST= ${WRKDIR}/pkg-plist
+
+TEXMFDIR= share/texmf
+TEXMFDIR_LSR= ${LOCALBASE}/${TEXMFDIR}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+CLASSDIR= ${TEXMFDIR}/tex/latex/${PORTNAME:S/^latex-//}
+
+CLASS_SUBDIRS= base emulation emacs examples extensions lyx themes
+DOC_SUBDIRS= AUTHORS ChangeLog FILES INSTALL README TODO \
+ doc solutions
+
+pre-install:
+ ${RM} -f ${PLIST}
+ ${TOUCH} ${PLIST}
+ cd ${WRKSRC} && ( \
+ ${FIND} ${CLASS_SUBDIRS} -type f | \
+ ${SED} -e "s%^%${CLASSDIR:S,^${PREFIX}/,,}/%"; \
+ ${FIND} ${CLASS_SUBDIRS} -type d | \
+ ${SORT} -r | ${SED} -e "s,^,@dirrm ${CLASSDIR:S,^${PREFIX}/,,}/,"; \
+ ) >> ${PLIST}
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ( \
+ ${FIND} ${DOC_SUBDIRS} -type f | \
+ ${SED} -e "s%^%${DOCSDIR:S,^${PREFIX}/,,}/%"; \
+ ${FIND} ${DOC_SUBDIRS} -type d | \
+ ${SORT} -r | ${SED} -e "s%^%@dirrm ${DOCSDIR:S,^${PREFIX}/,,}/%"; \
+ ${ECHO_CMD} "@dirrm ${DOCSDIR:S,^${PREFIX}/,,}"; \
+ ) >> ${PLIST}
+.endif
+ ${ECHO_CMD} "@unexec ${MKTEXLSR} ${PREFIX}/${TEXMFDIR}" >> ${PLIST}
+ ${ECHO_CMD} "@exec ${MKTEXLSR} ${PREFIX}/${TEXMFDIR}" >> ${PLIST}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ( cd ${WRKSRC} && ${TAR} cf - ${CLASS_SUBDIRS} ) | \
+ ( cd ${PREFIX}/${CLASSDIR} && ${TAR} xf - )
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ( cd ${WRKSRC} && ${TAR} cf - ${DOC_SUBDIRS} ) | \
+ ( cd ${DOCSDIR} && ${TAR} xf - )
+.endif
+
+post-install:
+ ${MKTEXLSR} ${PREFIX}/${TEXMFDIR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-beamer/distinfo b/print/latex-beamer/distinfo
new file mode 100644
index 000000000000..5535ee27eddd
--- /dev/null
+++ b/print/latex-beamer/distinfo
@@ -0,0 +1,3 @@
+MD5 (latex-beamer-3.06.tar.gz) = ab7eeb972d75e758117460aabdddb1e6
+SHA256 (latex-beamer-3.06.tar.gz) = eff7bff87f8adbbea3fb83f3e2edc485e0f99dac6276f62d537a88e1931a63d2
+SIZE (latex-beamer-3.06.tar.gz) = 2638744
diff --git a/print/latex-beamer/pkg-descr b/print/latex-beamer/pkg-descr
new file mode 100644
index 000000000000..83a85eb10d33
--- /dev/null
+++ b/print/latex-beamer/pkg-descr
@@ -0,0 +1,6 @@
+The beamer class is a LaTeX class that allows you to create a beamer
+presentation. It can also be used to create slides. It behaves similarly
+to other packages like Prosper, but has the advantage that it works
+together directly with pdflatex, but also with dvips.
+
+WWW: http://latex-beamer.sourceforge.net/