aboutsummaryrefslogtreecommitdiff
path: root/print/latex2rtf
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2003-10-28 20:22:07 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2003-10-28 20:22:07 +0000
commit08373e8d8f2bc12a054ca77b9923a58f28a73a29 (patch)
tree9575509330eed3a87a5a25062c99a1cb885bfcdb /print/latex2rtf
parent7cf01ed39b995fe79240609f294c2d62b312fb6c (diff)
downloadports-08373e8d8f2bc12a054ca77b9923a58f28a73a29.tar.gz
ports-08373e8d8f2bc12a054ca77b9923a58f28a73a29.zip
Notes
Diffstat (limited to 'print/latex2rtf')
-rw-r--r--print/latex2rtf/Makefile4
-rw-r--r--print/latex2rtf/distinfo2
-rw-r--r--print/latex2rtf/files/patch-aa50
-rw-r--r--print/latex2rtf/pkg-plist1
4 files changed, 33 insertions, 24 deletions
diff --git a/print/latex2rtf/Makefile b/print/latex2rtf/Makefile
index c58f7abb247d..8962ba486003 100644
--- a/print/latex2rtf/Makefile
+++ b/print/latex2rtf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= latex2rtf
-PORTVERSION= 1.9.13
+PORTVERSION= 1.9.14
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
${MASTER_SITE_TEX_CTAN}
@@ -15,6 +15,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME} support/latex2rtf
MAINTAINER= joerg@FreeBSD.org
COMMENT= Translator from LaTeX to RTF
-MAN1= latex2rtf.1
+MAN1= latex2rtf.1 latex2png.1
.include <bsd.port.mk>
diff --git a/print/latex2rtf/distinfo b/print/latex2rtf/distinfo
index 78cea4b16c96..b1468510023a 100644
--- a/print/latex2rtf/distinfo
+++ b/print/latex2rtf/distinfo
@@ -1 +1 @@
-MD5 (latex2rtf-1.9.13.tar.gz) = dedff9b8b17e222384b26c4bb94996d0
+MD5 (latex2rtf-1.9.14.tar.gz) = f590067942f15eb9b829afae6cab8a68
diff --git a/print/latex2rtf/files/patch-aa b/print/latex2rtf/files/patch-aa
index b159a0cbdf0d..e1f23e157b37 100644
--- a/print/latex2rtf/files/patch-aa
+++ b/print/latex2rtf/files/patch-aa
@@ -1,50 +1,58 @@
---- Makefile.orig Thu May 16 02:33:02 2002
-+++ Makefile Thu May 16 02:38:50 2002
-@@ -1,10 +1,9 @@
- # $Id: Makefile,v 1.50 2002/04/03 15:44:18 prahl Exp $
+--- Makefile.orig Thu Nov 28 19:36:14 2002
++++ Makefile Tue Oct 28 21:13:49 2003
+@@ -1,9 +1,8 @@
+ # $Id: Makefile,v 1.76 2002/11/28 18:36:14 prahl Exp $
-CC=gcc
MKDIR=mkdir -p
- LIBS=
-CFLAGS:=-DUNIX
+CFLAGS+=-DUNIX
- #CFLAGS:=-DMSDOS
- #CFLAGS:=-DMACINTOSH
+ #CFLAGS:=-DMSDOS #Windows/DOS
+ #CFLAGS:=-DMACINTOSH #MacOS 8/9
+ #CFLAGS:=-DOS2 #OS/2
+@@ -18,7 +17,7 @@
+ #CFLAGS:=$(CFLAGS) -Zwin32
+
+ #Base directory - adapt as needed
+-PREFIX=$(PREFIX_DRIVE)/usr/local
++#PREFIX=$(PREFIX_DRIVE)/usr/local
-@@ -12,10 +11,8 @@
- #CFLAGS:=$(CFLAGS) -DHAS_NO_GETOPT
+ #Name of executable binary --- beware of 8.3 restriction under DOS
+ BINARY_NAME=latex2rtf$(EXE_SUFFIX)
+@@ -32,7 +31,7 @@
- #Comment out if you don't want compiler warnings
--CFLAGS:=$(CFLAGS) -g -Wall -ansi -pedantic
+ # Nothing to change below this line
- #Base directory
--PREFIX=/usr/local
+-CFLAGS:=$(CFLAGS) -g -Wall -fsigned-char
++CFLAGS+=-fsigned-char
- # Location of binary, man, info, and support files
- BIN_INSTALL=$(PREFIX)/bin
-@@ -123,13 +120,13 @@
+ LIBS=
+ #LIBS=-lMallocDebug -force_flat_namespace
+@@ -144,14 +143,14 @@
$(MKDIR) $(BIN_INSTALL)
$(MKDIR) $(MAN_INSTALL)
$(MKDIR) $(CFG_INSTALL)
-- cp latex2rtf $(BIN_INSTALL)
+- cp $(BINARY_NAME) $(BIN_INSTALL)
- cp scripts/latex2png $(BIN_INSTALL)
- cp doc/latex2rtf.1 $(MAN_INSTALL)
+- cp doc/latex2png.1 $(MAN_INSTALL)
- cp $(CFGS) $(CFG_INSTALL)
- cp doc/latex2rtf.html $(SUPPORT_INSTALL)
- cp doc/latex2rtf.pdf $(SUPPORT_INSTALL)
- cp doc/latex2rtf.txt $(SUPPORT_INSTALL)
-+ ${BSD_INSTALL_PROGRAM} latex2rtf $(BIN_INSTALL)
++ ${BSD_INSTALL_PROGRAM} $(BINARY_NAME) $(BIN_INSTALL)
+ ${BSD_INSTALL_SCRIPT} scripts/latex2png $(BIN_INSTALL)
+ ${BSD_INSTALL_MAN} doc/latex2rtf.1 $(MAN_INSTALL)
++ ${BSD_INSTALL_MAN} doc/latex2png.1 $(MAN_INSTALL)
+ ${BSD_INSTALL_DATA} $(CFGS) $(CFG_INSTALL)
+ ${BSD_INSTALL_DATA} doc/latex2rtf.html $(SUPPORT_INSTALL)
+ ${BSD_INSTALL_DATA} doc/latex2rtf.pdf $(SUPPORT_INSTALL)
+ ${BSD_INSTALL_DATA} doc/latex2rtf.txt $(SUPPORT_INSTALL)
@echo "******************************************************************"
- @echo "*** latex2rtf successfully installed"
- @echo "***"
-@@ -145,7 +142,7 @@
+ @echo "*** latex2rtf successfully installed as \"$(BINARY_NAME)\""
+ @echo "*** in directory \"$(BIN_INSTALL)\""
+@@ -169,7 +168,7 @@
install-info: doc/latex2rtf.info
$(MKDIR) $(INFO_INSTALL)
diff --git a/print/latex2rtf/pkg-plist b/print/latex2rtf/pkg-plist
index 383aaf8b1167..df789f2cc9ed 100644
--- a/print/latex2rtf/pkg-plist
+++ b/print/latex2rtf/pkg-plist
@@ -31,6 +31,7 @@ share/latex2rtf/cfg/nynorsk.cfg
share/latex2rtf/cfg/polish.cfg
share/latex2rtf/cfg/portuges.cfg
share/latex2rtf/cfg/romanian.cfg
+share/latex2rtf/cfg/russian.cfg
share/latex2rtf/cfg/samin.cfg
share/latex2rtf/cfg/scottish.cfg
share/latex2rtf/cfg/serbian.cfg