aboutsummaryrefslogtreecommitdiff
path: root/print/latex2rtf
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-07-25 01:15:35 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-07-25 01:15:35 +0000
commitaaed1951fee0ca7ec3150984c852371278625171 (patch)
tree54a5ed24cc7a07e1c50fed1c81e264cc36881f46 /print/latex2rtf
parent190a536386a8593585f86bca5ef78df17766ceee (diff)
downloadports-aaed1951fee0ca7ec3150984c852371278625171.tar.gz
ports-aaed1951fee0ca7ec3150984c852371278625171.zip
- Update from 2.0.0 to 2.3.8
- Add stage support - Take maintainership
Notes
Notes: svn path=/head/; revision=362862
Diffstat (limited to 'print/latex2rtf')
-rw-r--r--print/latex2rtf/Makefile22
-rw-r--r--print/latex2rtf/distinfo4
-rw-r--r--print/latex2rtf/files/patch-Makefile100
-rw-r--r--print/latex2rtf/files/patch-doc_latex2rtf.info13
-rw-r--r--print/latex2rtf/pkg-plist103
5 files changed, 95 insertions, 147 deletions
diff --git a/print/latex2rtf/Makefile b/print/latex2rtf/Makefile
index 0ca64b0e8419..107efdf25d71 100644
--- a/print/latex2rtf/Makefile
+++ b/print/latex2rtf/Makefile
@@ -2,26 +2,24 @@
# $FreeBSD$
PORTNAME= latex2rtf
-PORTVERSION= 2.0.0
+PORTVERSION= 2.3.8
CATEGORIES= print
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-unix/${PORTVERSION} \
${MASTER_SITE_TEX_CTAN}
-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danilo@FreeBSD.org
COMMENT= Translator from LaTeX to RTF
-MAN1= latex2rtf.1 latex2png.1
-INFO= latex2rtf
+USES= shebangfix
+SHEBANG_FILES= ${WRKSRC}/scripts/latex2png
-USES= perl5
-USE_PERL5= build
+OPTIONS_DEFINE= LATEX2PNG
+LATEX2PNG_DESC= Install latex2png utility
+OPTIONS_SUB= yes
-INSTALL_TARGET= install install-info
+LATEX2PNG_RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
-NO_STAGE= yes
-pre-patch:
- @${CP} ${WRKSRC}/doc/latex2rtf.info ${WRKSRC}/doc/latex2rtf.info.bak
- @${TR} -d '\r\b\0' < ${WRKSRC}/doc/latex2rtf.info.bak > ${WRKSRC}/doc/latex2rtf.info
+MAKE_ARGS+= MANDIR=${PREFIX}/man/man1 CFGDIR=${DATADIR}/cfg \
+ BINDIR=${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/print/latex2rtf/distinfo b/print/latex2rtf/distinfo
index 988fce66d3b3..c8e3c3efc0d6 100644
--- a/print/latex2rtf/distinfo
+++ b/print/latex2rtf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (latex2rtf-2.0.0.tar.gz) = 79f72b7a1619315eb4a7d4f8bc0c2914cf8d6f48ddb0f0afaad921b5072033f5
-SIZE (latex2rtf-2.0.0.tar.gz) = 1196001
+SHA256 (latex2rtf-2.3.8.tar.gz) = 5484530de16e96ce76aedf969c464656a5f8834e748849d9009049e26f8c4143
+SIZE (latex2rtf-2.3.8.tar.gz) = 1579721
diff --git a/print/latex2rtf/files/patch-Makefile b/print/latex2rtf/files/patch-Makefile
index 8c365670783d..b0fe1f6c769c 100644
--- a/print/latex2rtf/files/patch-Makefile
+++ b/print/latex2rtf/files/patch-Makefile
@@ -1,71 +1,33 @@
---- Makefile.orig 2009-12-11 22:10:59.000000000 +0100
-+++ Makefile 2010-02-11 15:08:00.000000000 +0100
-@@ -1,5 +1,5 @@
--CC?=gcc
--TAR?=gnutar
--RM?=rm
-+#CC?=gcc
-+#TAR?=gnutar
-+#RM?=rm
- MKDIR=mkdir -p
- PKGMANDIR?=man
-@@ -6,5 +6,6 @@
-
--CFLAGS:=$(CFLAGS) -DUNIX
-+CFLAGS+=-DUNIX
-+#CFLAGS:=$(CFLAGS) -DUNIX
- #CFLAGS:=$(CFLAGS) -DUNIX -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic
- #CFLAGS:=$(CFLAGS) -DMSDOS -DNOSTDERR #Windows/DOS
- #CFLAGS:=$(CFLAGS) -DMAC_CLASSIC #MacOS 8/9
-@@ -20,7 +21,7 @@
- #CFLAGS:=$(CFLAGS) -Zwin32
-
- #Base directory - adapt as needed
--PREFIX?=$(PREFIX_DRIVE)/usr/local
-+#PREFIX?=$(PREFIX_DRIVE)/usr/local
-
- #Name of executable binary --- beware of 8.3 restriction under DOS
- BINARY_NAME=latex2rtf$(EXE_SUFFIX)
-@@ -34,7 +35,7 @@
-
- # Nothing to change below this line
-
--CFLAGS:=$(CFLAGS) -g -Wall -fsigned-char
-+CFLAGS+= -fsigned-char
-
- LIBS= -lm
-
-@@ -195,14 +196,14 @@
- $(MKDIR) $(BIN_INSTALL)
- $(MKDIR) $(MAN_INSTALL)
- $(MKDIR) $(CFG_INSTALL)
-- cp $(BINARY_NAME) $(BIN_INSTALL)
-- cp scripts/latex2png $(BIN_INSTALL)
-- cp doc/latex2rtf.1 $(MAN_INSTALL)
-- cp doc/latex2png.1 $(MAN_INSTALL)
-- cp $(CFGS) $(CFG_INSTALL)
-- cp doc/latex2rtf.html $(SUPPORT_INSTALL)
-- cp doc/latex2rtf.pdf $(SUPPORT_INSTALL)
-- cp doc/latex2rtf.txt $(SUPPORT_INSTALL)
-+ ${BSD_INSTALL_PROGRAM} $(BINARY_NAME) $(BIN_INSTALL)
-+ ${BSD_INSTALL_SCRIPT} scripts/latex2png $(BIN_INSTALL)
-+ ${BSD_INSTALL_MAN} doc/latex2rtf.1 $(MAN_INSTALL)
-+ ${BSD_INSTALL_MAN} doc/latex2png.1 $(MAN_INSTALL)
-+ ${BSD_INSTALL_DATA} $(CFGS) $(CFG_INSTALL)
-+ ${BSD_INSTALL_DATA} doc/latex2rtf.html $(SUPPORT_INSTALL)
-+ ${BSD_INSTALL_DATA} doc/latex2rtf.pdf $(SUPPORT_INSTALL)
-+ ${BSD_INSTALL_DATA} doc/latex2rtf.txt $(SUPPORT_INSTALL)
+--- ./Makefile.orig 2013-11-12 06:44:44.000000000 -0200
++++ ./Makefile 2014-07-24 21:27:45.000000000 -0300
+@@ -151,10 +151,10 @@
+ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) $(LIBS) -o $(BINARY_NAME)
+
+ cfg.o: Makefile cfg.c
+- $(CC) $(CFLAGS) -DCFGDIR=\"$(DESTDIR)$(CFGDIR)\" -c cfg.c -o cfg.o
++ $(CC) $(CFLAGS) -DCFGDIR=\"$(CFGDIR)\" -c cfg.c -o cfg.o
+
+ main.o: Makefile main.c
+- $(CC) $(CFLAGS) -DCFGDIR=\"$(DESTDIR)$(CFGDIR)\" -c main.c -o main.o
++ $(CC) $(CFLAGS) -DCFGDIR=\"$(CFGDIR)\" -c main.c -o main.o
+
+ check test: latex2rtf
+ cd test && $(MAKE) clean
+@@ -209,7 +209,6 @@
+ cd doc && $(MAKE) -k
+
+ install: latex2rtf doc/latex2rtf.1 $(CFGS) scripts/latex2png
+- cd doc && $(MAKE)
+ $(MKDIR) $(DESTDIR)$(BINDIR)
+ $(MKDIR) $(DESTDIR)$(MANDIR)
+ $(MKDIR) $(DESTDIR)$(CFGDIR)
+@@ -217,9 +216,6 @@
+ cp -p doc/latex2rtf.1 $(DESTDIR)$(MANDIR)
+ cp -p doc/latex2png.1 $(DESTDIR)$(MANDIR)
+ cp -p $(CFGS) $(DESTDIR)$(CFGDIR)
+- cp -p doc/latex2rtf.html $(DESTDIR)$(SUPPORTDIR)
+- cp -p doc/latex2rtf.pdf $(DESTDIR)$(SUPPORTDIR)
+- cp -p doc/latex2rtf.txt $(DESTDIR)$(SUPPORTDIR)
+ cp -p $(BINARY_NAME) $(DESTDIR)$(BINDIR)
@echo "******************************************************************"
@echo "*** latex2rtf successfully installed as \"$(BINARY_NAME)\""
- @echo "*** in directory \"$(BIN_INSTALL)\""
-@@ -220,8 +221,8 @@
-
- install-info: doc/latex2rtf.info
- $(MKDIR) $(INFO_INSTALL)
-- cp doc/latex2rtf.info $(INFO_INSTALL)
-- install-info --info-dir=$(INFO_INSTALL) doc/latex2rtf.info
-+ ${BSD_INSTALL_DATA} doc/latex2rtf.info $(INFO_INSTALL)
-+ install-info --info-dir=$(INFO_INSTALL) $(INFO_INSTALL)/latex2rtf.info
-
- realclean: checkdir clean
- $(RM) -f makefile.depend $(L2R_VERSION).tar.gz
diff --git a/print/latex2rtf/files/patch-doc_latex2rtf.info b/print/latex2rtf/files/patch-doc_latex2rtf.info
deleted file mode 100644
index 32aa7807aa1b..000000000000
--- a/print/latex2rtf/files/patch-doc_latex2rtf.info
+++ /dev/null
@@ -1,13 +0,0 @@
---- doc/latex2rtf.info~ 2010-02-11 14:19:11.000000000 +0100
-+++ doc/latex2rtf.info 2010-02-11 15:03:38.000000000 +0100
-@@ -2,7 +2,9 @@
- latex2rtf.texi.
-
- INFO-DIR-SECTION Document Preparation
--
-+START-INFO-DIR-ENTRY
-+* latex2rtf: (latex2rtf). Translate LaTeX documents to RTF.
-+END-INFO-DIR-ENTRY
-
- 
- File: latex2rtf.info, Node: Top, Next: Introduction, Prev: (dir), Up: (dir)
diff --git a/print/latex2rtf/pkg-plist b/print/latex2rtf/pkg-plist
index 3c6b889e4fca..0ca6850604cd 100644
--- a/print/latex2rtf/pkg-plist
+++ b/print/latex2rtf/pkg-plist
@@ -1,52 +1,53 @@
-bin/latex2png
+%%LATEX2PNG%%bin/latex2png
bin/latex2rtf
-share/latex2rtf/cfg/afrikaans.cfg
-share/latex2rtf/cfg/bahasa.cfg
-share/latex2rtf/cfg/basque.cfg
-share/latex2rtf/cfg/brazil.cfg
-share/latex2rtf/cfg/breton.cfg
-share/latex2rtf/cfg/catalan.cfg
-share/latex2rtf/cfg/croatian.cfg
-share/latex2rtf/cfg/czech.cfg
-share/latex2rtf/cfg/danish.cfg
-share/latex2rtf/cfg/direct.cfg
-share/latex2rtf/cfg/dutch.cfg
-share/latex2rtf/cfg/english.cfg
-share/latex2rtf/cfg/esperanto.cfg
-share/latex2rtf/cfg/estonian.cfg
-share/latex2rtf/cfg/finnish.cfg
-share/latex2rtf/cfg/fonts.cfg
-share/latex2rtf/cfg/french.cfg
-share/latex2rtf/cfg/galician.cfg
-share/latex2rtf/cfg/german.cfg
-share/latex2rtf/cfg/icelandic.cfg
-share/latex2rtf/cfg/ignore.cfg
-share/latex2rtf/cfg/inc_test.tex
-share/latex2rtf/cfg/irish.cfg
-share/latex2rtf/cfg/italian.cfg
-share/latex2rtf/cfg/latin.cfg
-share/latex2rtf/cfg/lsorbian.cfg
-share/latex2rtf/cfg/magyar.cfg
-share/latex2rtf/cfg/norsk.cfg
-share/latex2rtf/cfg/nynorsk.cfg
-share/latex2rtf/cfg/polish.cfg
-share/latex2rtf/cfg/portuges.cfg
-share/latex2rtf/cfg/romanian.cfg
-share/latex2rtf/cfg/russian.cfg
-share/latex2rtf/cfg/samin.cfg
-share/latex2rtf/cfg/scottish.cfg
-share/latex2rtf/cfg/serbian.cfg
-share/latex2rtf/cfg/slovak.cfg
-share/latex2rtf/cfg/slovene.cfg
-share/latex2rtf/cfg/spanish.cfg
-share/latex2rtf/cfg/style.cfg
-share/latex2rtf/cfg/swedish.cfg
-share/latex2rtf/cfg/turkish.cfg
-share/latex2rtf/cfg/ukrainian.cfg
-share/latex2rtf/cfg/usorbian.cfg
-share/latex2rtf/cfg/welsh.cfg
-share/latex2rtf/latex2rtf.html
-share/latex2rtf/latex2rtf.pdf
-share/latex2rtf/latex2rtf.txt
-@dirrm share/latex2rtf/cfg
-@dirrm share/latex2rtf
+%%LATEX2PNG%%man/man1/latex2png.1.gz
+man/man1/latex2rtf.1.gz
+%%DATADIR%%/cfg/afrikaans.cfg
+%%DATADIR%%/cfg/bahasa.cfg
+%%DATADIR%%/cfg/basque.cfg
+%%DATADIR%%/cfg/brazil.cfg
+%%DATADIR%%/cfg/breton.cfg
+%%DATADIR%%/cfg/british.cfg
+%%DATADIR%%/cfg/catalan.cfg
+%%DATADIR%%/cfg/croatian.cfg
+%%DATADIR%%/cfg/czech.cfg
+%%DATADIR%%/cfg/danish.cfg
+%%DATADIR%%/cfg/direct.cfg
+%%DATADIR%%/cfg/dutch.cfg
+%%DATADIR%%/cfg/english.cfg
+%%DATADIR%%/cfg/esperanto.cfg
+%%DATADIR%%/cfg/estonian.cfg
+%%DATADIR%%/cfg/finnish.cfg
+%%DATADIR%%/cfg/fonts.cfg
+%%DATADIR%%/cfg/french.cfg
+%%DATADIR%%/cfg/frenchb.cfg
+%%DATADIR%%/cfg/galician.cfg
+%%DATADIR%%/cfg/german.cfg
+%%DATADIR%%/cfg/greek.cfg
+%%DATADIR%%/cfg/icelandic.cfg
+%%DATADIR%%/cfg/ignore.cfg
+%%DATADIR%%/cfg/irish.cfg
+%%DATADIR%%/cfg/italian.cfg
+%%DATADIR%%/cfg/latin.cfg
+%%DATADIR%%/cfg/lsorbian.cfg
+%%DATADIR%%/cfg/magyar.cfg
+%%DATADIR%%/cfg/norsk.cfg
+%%DATADIR%%/cfg/nynorsk.cfg
+%%DATADIR%%/cfg/polish.cfg
+%%DATADIR%%/cfg/portuges.cfg
+%%DATADIR%%/cfg/romanian.cfg
+%%DATADIR%%/cfg/russian.cfg
+%%DATADIR%%/cfg/samin.cfg
+%%DATADIR%%/cfg/scottish.cfg
+%%DATADIR%%/cfg/serbian.cfg
+%%DATADIR%%/cfg/slovak.cfg
+%%DATADIR%%/cfg/slovene.cfg
+%%DATADIR%%/cfg/spanish.cfg
+%%DATADIR%%/cfg/style.cfg
+%%DATADIR%%/cfg/swedish.cfg
+%%DATADIR%%/cfg/turkish.cfg
+%%DATADIR%%/cfg/ukrainian.cfg
+%%DATADIR%%/cfg/usorbian.cfg
+%%DATADIR%%/cfg/welsh.cfg
+@dirrmtry %%DATADIR%%/cfg
+@dirrmtry %%DATADIR%%