aboutsummaryrefslogtreecommitdiff
path: root/print/libharu
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-14 15:09:30 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-14 15:09:30 +0000
commit4f800583b99d81a17d3b6e32212a7a8d25d8c1af (patch)
tree9d43e456f721cdf005271c60bfe5c0dca77fc749 /print/libharu
parentb965e1be9af4fa81233a511519083eb99d6552af (diff)
downloadports-4f800583b99d81a17d3b6e32212a7a8d25d8c1af.tar.gz
ports-4f800583b99d81a17d3b6e32212a7a8d25d8c1af.zip
- Update to 2.3.0
PR: 184052 Submitted by: gahr Approved by: maintainer (timeout)
Notes
Notes: svn path=/head/; revision=344246
Diffstat (limited to 'print/libharu')
-rw-r--r--print/libharu/Makefile34
-rw-r--r--print/libharu/distinfo4
-rw-r--r--print/libharu/files/patch-demo_CMakeLists.txt21
-rw-r--r--print/libharu/files/patch-hpdf_image_png.c10
-rw-r--r--print/libharu/pkg-plist7
5 files changed, 48 insertions, 28 deletions
diff --git a/print/libharu/Makefile b/print/libharu/Makefile
index 4567d2e95cf0..56d45da4c4c5 100644
--- a/print/libharu/Makefile
+++ b/print/libharu/Makefile
@@ -2,28 +2,38 @@
# $FreeBSD$
PORTNAME= libharu
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.3.0
CATEGORIES= print
-MASTER_SITES= http://libharu.org/files/
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= Haru Free PDF Library
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+
+OPTIONS_DEFINE= EXAMPLES
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-png=${LOCALBASE}
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
USE_LDCONFIG= yes
+USES+= cmake:outsource
+CMAKE_ARGS+= -DDEVPAK:BOOL=ON
+
+USE_GITHUB= yes
+GH_ACCOUNT= libharu
+GH_TAGNAME= RELEASE_2_3_0
+GH_COMMIT= 4ae1d5f
SOVERSION= 2
-PLIST_SUB+= PORTVERSION=${PORTVERSION} \
- SOVERSION=${SOVERSION}
+PLIST_SUB+= SOVERSION=${SOVERSION}
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+CMAKE_ARGS+= -DLIBHPDF_EXAMPLES:BOOL=ON \
+ -DEXAMPLESDIR:STRING=share/examples/${PORTNAME}
+.endif
-NO_STAGE= yes
post-install:
- ${LN} -s ${PREFIX}/lib/libhpdf-${PORTVERSION}.so \
- ${PREFIX}/lib/libhpdf.so.${SOVERSION}
+ ${LN} -s ${PREFIX}/lib/libhpdf.so \
+ ${STAGEDIR}${PREFIX}/lib/libhpdf.so.${SOVERSION}
.include <bsd.port.mk>
diff --git a/print/libharu/distinfo b/print/libharu/distinfo
index cbba05c99d4e..829344c0e6b3 100644
--- a/print/libharu/distinfo
+++ b/print/libharu/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libharu-2.2.1.tar.gz) = 45fd57044042c0e290ad0f11fc19eeb31b50c4b9edadf9d89dd5a7d9ae4865a7
-SIZE (libharu-2.2.1.tar.gz) = 967530
+SHA256 (libharu-2.3.0.tar.gz) = 05d21b32baaa2780b2eae45c7958684239b64560063de229714a8729911ca87e
+SIZE (libharu-2.3.0.tar.gz) = 1396376
diff --git a/print/libharu/files/patch-demo_CMakeLists.txt b/print/libharu/files/patch-demo_CMakeLists.txt
new file mode 100644
index 000000000000..012ebc791b10
--- /dev/null
+++ b/print/libharu/files/patch-demo_CMakeLists.txt
@@ -0,0 +1,21 @@
+--- demo/CMakeLists.txt.orig 2013-11-18 14:51:59.000000000 +0100
++++ demo/CMakeLists.txt 2013-11-18 14:52:21.000000000 +0100
+@@ -86,15 +86,15 @@
+ # =======================================================================
+ install(
+ TARGETS ${demos_NAMES} ${demos_with_grid_NAMES} grid_sheet
+- DESTINATION demo
++ DESTINATION ${EXAMPLESDIR}
+ )
+ foreach(demo ${demos_NAMES} ${demos_with_grid_NAMES} grid_sheet)
+- install(FILES ${demo}.c DESTINATION demo)
++ install(FILES ${demo}.c DESTINATION ${EXAMPLESDIR})
+ endforeach(demo)
+
+ # install demo files
+ install(
+ DIRECTORY images mbtext pngsuite rawimage ttfont type1
+- DESTINATION demo
++ DESTINATION ${EXAMPLESDIR}
+ )
+ endif(LIBHPDF_EXAMPLES)
diff --git a/print/libharu/files/patch-hpdf_image_png.c b/print/libharu/files/patch-hpdf_image_png.c
deleted file mode 100644
index 57f59185f63d..000000000000
--- a/print/libharu/files/patch-hpdf_image_png.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/hpdf_image_png.c.orig 2010-02-08 10:27:51.000000000 +0100
-+++ src/hpdf_image_png.c 2012-05-06 06:53:50.000000000 +0200
-@@ -21,6 +21,7 @@
-
- #ifndef LIBHPDF_HAVE_NOPNGLIB
- #include <png.h>
-+#include <pngpriv.h>
-
- static void
- PngErrorFunc (png_structp png_ptr,
diff --git a/print/libharu/pkg-plist b/print/libharu/pkg-plist
index 6845e3af68b7..32bdcef683fc 100644
--- a/print/libharu/pkg-plist
+++ b/print/libharu/pkg-plist
@@ -1,4 +1,5 @@
include/hpdf.h
+include/hpdf_3dmeasure.h
include/hpdf_annotation.h
include/hpdf_catalog.h
include/hpdf_conf.h
@@ -10,6 +11,7 @@ include/hpdf_encoder.h
include/hpdf_encrypt.h
include/hpdf_encryptdict.h
include/hpdf_error.h
+include/hpdf_exdata.h
include/hpdf_ext_gstate.h
include/hpdf_font.h
include/hpdf_fontdef.h
@@ -18,7 +20,6 @@ include/hpdf_image.h
include/hpdf_info.h
include/hpdf_list.h
include/hpdf_mmgr.h
-include/hpdf_namedict.h
include/hpdf_objects.h
include/hpdf_outline.h
include/hpdf_page_label.h
@@ -29,8 +30,6 @@ include/hpdf_types.h
include/hpdf_u3d.h
include/hpdf_utils.h
include/hpdf_version.h
-lib/libhpdf-%%PORTVERSION%%.so
-lib/libhpdf.a
-lib/libhpdf.la
+lib/libhpdfs.a
lib/libhpdf.so
lib/libhpdf.so.%%SOVERSION%%