aboutsummaryrefslogtreecommitdiff
path: root/print/libharu
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2007-06-15 15:18:00 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2007-06-15 15:18:00 +0000
commitd1e9fe8720453dd72f3bc65648d89193cbb7993a (patch)
treeefb14425cffb3afe4cecc8115a40d4945e9eebad /print/libharu
parentccd266efda15f4f6aeaf74582a02e2627f24fea4 (diff)
downloadports-d1e9fe8720453dd72f3bc65648d89193cbb7993a.tar.gz
ports-d1e9fe8720453dd72f3bc65648d89193cbb7993a.zip
add libharu 2.0.8
Haru Free PDF Library
Notes
Notes: svn path=/head/; revision=193589
Diffstat (limited to 'print/libharu')
-rw-r--r--print/libharu/Makefile43
-rw-r--r--print/libharu/distinfo3
-rw-r--r--print/libharu/files/patch-configure11
-rw-r--r--print/libharu/pkg-descr15
4 files changed, 72 insertions, 0 deletions
diff --git a/print/libharu/Makefile b/print/libharu/Makefile
new file mode 100644
index 000000000000..b615a6bf4028
--- /dev/null
+++ b/print/libharu/Makefile
@@ -0,0 +1,43 @@
+# ex:ts=8
+# Ports collection makefile for: libharu
+# Date created: Jun 15, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libharu
+PORTVERSION= 2.0.8
+CATEGORIES= print
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Haru Free PDF Library
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_PNG= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --shared \
+ --prefix=${PREFIX} \
+ --cflags="${CFLAGS}"
+CFLAGS+= -I${LOCALBASE}/include
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/hpdf.h \
+ include/hpdf_consts.h \
+ include/hpdf_types.h \
+ lib/libhpdf.so \
+ lib/libhpdf.so.1 \
+ lib/libhpdf.so.1.0.0
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/libharu/distinfo b/print/libharu/distinfo
new file mode 100644
index 000000000000..df5c6ea6498c
--- /dev/null
+++ b/print/libharu/distinfo
@@ -0,0 +1,3 @@
+MD5 (libharu_2_0_8.tgz) = 4b9714fd89b4134b0b9c93f857add327
+SHA256 (libharu_2_0_8.tgz) = 825a18796868fecef150339a731bab7ba3ce393acba41834a7384da93a5eb7e1
+SIZE (libharu_2_0_8.tgz) = 1572158
diff --git a/print/libharu/files/patch-configure b/print/libharu/files/patch-configure
new file mode 100644
index 000000000000..c795b694f1c4
--- /dev/null
+++ b/print/libharu/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jun 15 22:47:35 2007
++++ configure Fri Jun 15 22:48:13 2007
+@@ -24,7 +24,7 @@
+ CFLAGS_EXE='-o '
+ CFLAGS_USER=
+
+-LDFLAGS='-L.'
++LDFLAGS='-L. -L${PREFIX}/lib'
+ LDFLAGS_DEMO='-L.'
+ LDFLAGS_ADD=''
+
diff --git a/print/libharu/pkg-descr b/print/libharu/pkg-descr
new file mode 100644
index 000000000000..dbe9627e448b
--- /dev/null
+++ b/print/libharu/pkg-descr
@@ -0,0 +1,15 @@
+HARU is a free, cross platform, open-sourced software library for generating
+PDF. It supports the following features.
+ 1. Generating PDF files with lines, text, images.
+ 2. Outline, text annotation, link annotation.
+ 3. Compressing document with deflate-decode.
+ 4. Embedding PNG, Jpeg images.
+ 5. Embedding Type1 font and TrueType font.
+ 6. Creating encrypted PDF files.
+ 7. Using various character set (ISO8859-1~16, MSCP1250~8, KOI-8R).
+ 8. Supporting CJK fonts and encodings.
+
+You can add the feature of PDF creation by using HARU without understanding
+complicated internal structure of PDF.
+
+WWW: http://libharu.sourceforge.net/