aboutsummaryrefslogtreecommitdiff
path: root/print/libmspub01/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-10-06 19:30:09 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-10-06 19:30:09 +0000
commitea204d50b567c959d98f08a16b36be03ebaa4e85 (patch)
tree72b6213ee35c0e9de59dda82cb4000c929e3bd2f /print/libmspub01/Makefile
parent62c2d21fa3b5f1dc4361260a3a5d303cc30c4ab5 (diff)
downloadports-ea204d50b567c959d98f08a16b36be03ebaa4e85.tar.gz
ports-ea204d50b567c959d98f08a16b36be03ebaa4e85.zip
Notes
Diffstat (limited to 'print/libmspub01/Makefile')
-rw-r--r--print/libmspub01/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/print/libmspub01/Makefile b/print/libmspub01/Makefile
new file mode 100644
index 000000000000..a76de788bf92
--- /dev/null
+++ b/print/libmspub01/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= libmspub
+PORTVERSION= 0.1.0
+CATEGORIES= print graphics devel
+MASTER_SITES= http://dev-www.libreoffice.org/src/
+PKGNAMESUFFIX= 01
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Library and tools for parsing Microsoft Publisher file format
+
+LICENSE= LGPL21 MPL GPLv2
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/ptr_container/ptr_map.hpp:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libicui18n.so:${PORTSDIR}/devel/icu \
+ librevenge-0.0.so:${PORTSDIR}/textproc/librevenge
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= libtool pathfix pkgconfig tar:xz
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ARGS= --disable-werror --without-docs
+CONFIGURE_ENV= ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-lz"
+CPPFLAGS+= -I${LOCALBASE}/include
+
+.include <bsd.port.mk>