aboutsummaryrefslogtreecommitdiff
path: root/print/libotf
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2021-01-01 16:33:21 +0000
committerKurt Jaeger <pi@FreeBSD.org>2021-01-01 16:33:21 +0000
commita991d863b02fa44a05b3f2c63491b2128d2d1c57 (patch)
tree3dd03e2cb3c851694450db842dccb6dff8276c35 /print/libotf
parent9e0b3d088cb51586cedabed9aa1fd25559c0b11a (diff)
downloadports-a991d863b02fa44a05b3f2c63491b2128d2d1c57.tar.gz
ports-a991d863b02fa44a05b3f2c63491b2128d2d1c57.zip
print/libotf: Don't use freetype-config
- freetype-config is deprecated and shouldn't be used to detect freetype(2) Import patch from Archlinux to fix this issue PR: 252112 Submitted by: daniel.engberg.lists@pyret.net Approved by: nikola.lecic@anthesphoria.net (maintainer)
Notes
Notes: svn path=/head/; revision=559849
Diffstat (limited to 'print/libotf')
-rw-r--r--print/libotf/Makefile2
-rw-r--r--print/libotf/files/patch-configure.ac33
2 files changed, 34 insertions, 1 deletions
diff --git a/print/libotf/Makefile b/print/libotf/Makefile
index 8d67cd5572d4..60443a518ffa 100644
--- a/print/libotf/Makefile
+++ b/print/libotf/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfreetype.so:print/freetype2
-USES= pathfix pkgconfig libtool:keepla xorg
+USES= autoreconf pathfix pkgconfig libtool:keepla xorg
GNU_CONFIGURE= yes
USE_XORG= ice sm x11 xaw xt xmu
INSTALL_TARGET= install-strip
diff --git a/print/libotf/files/patch-configure.ac b/print/libotf/files/patch-configure.ac
new file mode 100644
index 000000000000..776e05ae6e7f
--- /dev/null
+++ b/print/libotf/files/patch-configure.ac
@@ -0,0 +1,33 @@
+--- configure.ac.orig 2018-01-23 23:01:37 UTC
++++ configure.ac
+@@ -48,23 +48,24 @@ AM_CONDITIONAL([X11_UNAVAILABLE], [test x$no_x = xyes]
+ AC_FUNC_ALLOCA
+ AC_FUNC_MALLOC
+
++PKG_PROG_PKG_CONFIG
++
+ # Check for Freetype2 usability.
+-AC_CHECK_PROG(HAVE_FREETYPE_CONFIG, freetype-config, yes)
+-if test "x$HAVE_FREETYPE_CONFIG" = "xyes"; then
+- FREETYPE_INC=`freetype-config --cflags`
++PKG_CHECK_MODULES(FREETYPE, freetype2, [
++ FREETYPE_INC="$FREETYPE_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $FREETYPE_INC"
+ AC_CHECK_HEADER(ft2build.h, HAVE_FREETYPE=yes,
+ HAVE_FREETYPE=no CPPFLAGS=$save_CPPFLAGS)
+ if test "x$HAVE_FREETYPE" = "xyes" ; then
+- FREETYPE_LD_FLAGS=`freetype-config --libs`;
++ FREETYPE_LD_FLAGS="$FREETYPE_LIBS"
+ LIBS="$LIBS $FREETYPE_LD_FLAGS"
+ AC_CHECK_LIB(freetype, FT_Init_FreeType, HAVE_FREETYPE=yes,
+ HAVE_FREETYPE=no)
+ fi
+-fi
++])
+
+ if test "x$HAVE_FREETYPE" != "xyes" ; then
+- echo "Freetype library wan't found in your system!"
++ echo "Freetype library not found in your system!"
+ exit 1
+ fi
+ AC_SUBST(FREETYPE_INC)