aboutsummaryrefslogtreecommitdiff
path: root/print/libraqm
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2019-05-13 20:19:20 +0000
committerKoop Mast <kwm@FreeBSD.org>2019-05-13 20:19:20 +0000
commit52922516e1c7e5ba6601f15bfcc4f3f28d0fd3ae (patch)
treebf2d437692feb62ce4cbd88062378bda02946e2c /print/libraqm
parent9bd042d0c71fb0baeb55701dce5828eacb284164 (diff)
downloadports-52922516e1c7e5ba6601f15bfcc4f3f28d0fd3ae.tar.gz
ports-52922516e1c7e5ba6601f15bfcc4f3f28d0fd3ae.zip
Add libraqm, which is a small library that encapsulates the logic for
complex text layout and provide a convenient API.
Notes
Notes: svn path=/head/; revision=501596
Diffstat (limited to 'print/libraqm')
-rw-r--r--print/libraqm/Makefile24
-rw-r--r--print/libraqm/distinfo3
-rw-r--r--print/libraqm/pkg-descr8
-rw-r--r--print/libraqm/pkg-plist21
4 files changed, 56 insertions, 0 deletions
diff --git a/print/libraqm/Makefile b/print/libraqm/Makefile
new file mode 100644
index 000000000000..9d0c4470f5fa
--- /dev/null
+++ b/print/libraqm/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= libraqm
+PORTVERSION= 0.6.0
+CATEGORIES= print
+MASTER_SITES= https://github.com/HOST-Oman/libraqm/releases/download/v${PORTVERSION}/
+DISTNAME= raqm-${PORTVERSION}
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Library that encapsulates complex text layout logic
+
+LICENSE= MIT
+
+LIB_DEPENDS= libfribidi.so:converters/fribidi \
+ libharfbuzz.so:print/harfbuzz \
+ libfreetype.so:print/freetype2
+
+USES= gmake libtool pkgconfig
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/print/libraqm/distinfo b/print/libraqm/distinfo
new file mode 100644
index 000000000000..bb41094a91ed
--- /dev/null
+++ b/print/libraqm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1557777780
+SHA256 (raqm-0.6.0.tar.gz) = 37ccb06bcedd2e1340137086841ca8929fd728627bd1d707daba448d5c7b111a
+SIZE (raqm-0.6.0.tar.gz) = 678695
diff --git a/print/libraqm/pkg-descr b/print/libraqm/pkg-descr
new file mode 100644
index 000000000000..86aeb705fe06
--- /dev/null
+++ b/print/libraqm/pkg-descr
@@ -0,0 +1,8 @@
+Raqm is a small library that encapsulates the logic for complex text layout
+and provide a convenient API.
+
+It currently provides bidirectional text support (using FriBiDi), shaping
+(using HarfBuzz), and proper script itemization. As a result, Raqm can
+support most writing systems covered by Unicode.
+
+WWW: https://github.com/HOST-Oman/libraqm
diff --git a/print/libraqm/pkg-plist b/print/libraqm/pkg-plist
new file mode 100644
index 000000000000..53619f120ce4
--- /dev/null
+++ b/print/libraqm/pkg-plist
@@ -0,0 +1,21 @@
+include/raqm.h
+lib/libraqm.a
+lib/libraqm.so
+lib/libraqm.so.0
+lib/libraqm.so.0.600.0
+libdata/pkgconfig/raqm.pc
+share/gtk-doc/html/raqm/annotation-glossary.html
+share/gtk-doc/html/raqm/api-index-full.html
+share/gtk-doc/html/raqm/ch01.html
+share/gtk-doc/html/raqm/home.png
+share/gtk-doc/html/raqm/index.html
+share/gtk-doc/html/raqm/left-insensitive.png
+share/gtk-doc/html/raqm/left.png
+share/gtk-doc/html/raqm/object-tree.html
+share/gtk-doc/html/raqm/raqm-Raqm.html
+share/gtk-doc/html/raqm/raqm.devhelp2
+share/gtk-doc/html/raqm/right-insensitive.png
+share/gtk-doc/html/raqm/right.png
+share/gtk-doc/html/raqm/style.css
+share/gtk-doc/html/raqm/up-insensitive.png
+share/gtk-doc/html/raqm/up.png