aboutsummaryrefslogtreecommitdiff
path: root/print/lilypond-devel
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-21 10:25:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-21 10:25:58 +0000
commitf63195069865113c0279fe9b33372add8cba9684 (patch)
tree6c962dc25356b700179b8ae5401877c2e9efb015 /print/lilypond-devel
parent2b1323d4c928ccb0b12cd868356aeddbd94fd2e2 (diff)
downloadports-f63195069865113c0279fe9b33372add8cba9684.tar.gz
ports-f63195069865113c0279fe9b33372add8cba9684.zip
- Builds fine on 9.x
- Mark BROKEN on FreeBSD 10.1, 10.2 Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=429056
Diffstat (limited to 'print/lilypond-devel')
-rw-r--r--print/lilypond-devel/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index dd964b1d6bcb..6d50070bf196 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -32,8 +32,6 @@ LIB_DEPENDS= libltdl.so:devel/libltdl \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-BROKEN_FreeBSD_9= does not build on FreeBSD < 10.x
-
INFO= internals \
lilypond-changes \
lilypond-contributor \
@@ -73,6 +71,12 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000 && ${OSVERSION} < 1003000
+BROKEN= does not build on < 10.3 (undefined reference to `__cxa_throw_bad_array_new_length')
+.endif
+
post-patch:
${FIND} ${WRKSRC} -name "*.cc" | ${XARGS} \
${REINPLACE_CMD} -e 's|isinf[ ]*(|::isinf(|g' -e 's|isnan|::isnan|g'
@@ -87,4 +91,4 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lilypond/${PORTVERSION}/python/midi.so
(cd ${STAGEDIR}/${DATADIR} && ${LN} -fs ${PORTVERSION} current)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>