aboutsummaryrefslogtreecommitdiff
path: root/print/lilypond
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-08-28 13:36:39 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-08-28 13:36:39 +0000
commitdbf905182a070e624c07360f92059e8081be535f (patch)
tree8fc7d0acef33fd2005aeb7fe92bde6b24d560d3e /print/lilypond
parent57cbbeaaba3ed199a892f3818cac4975d2426b44 (diff)
downloadports-dbf905182a070e624c07360f92059e8081be535f.tar.gz
ports-dbf905182a070e624c07360f92059e8081be535f.zip
Notes
Diffstat (limited to 'print/lilypond')
-rw-r--r--print/lilypond/Makefile63
-rw-r--r--print/lilypond/distinfo4
-rw-r--r--print/lilypond/files/patch-Documentation_GNUmakefile14
-rw-r--r--print/lilypond/pkg-plist30
4 files changed, 79 insertions, 32 deletions
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index 2b8d6f7891d9..39b6ca16f241 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -8,49 +8,61 @@
#
PORTNAME= lilypond
-PORTVERSION= 2.14.2
-PORTREVISION= 2
+PORTVERSION= 2.16.0
CATEGORIES= print audio
-MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v2.14/
+MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v${PORTVERSION:R}/
MAINTAINER= gahr@FreeBSD.org
COMMENT= The GNU music typesetter
-BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX \
- mftrace:${PORTSDIR}/print/mftrace \
- rarian-sk-config:${PORTSDIR}/textproc/rarian \
- texi2html:${PORTSDIR}/textproc/texi2html \
+BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
pdftexi2dvi:${PORTSDIR}/print/texinfo \
- zip:${PORTSDIR}/archivers/zip \
- gsed:${PORTSDIR}/textproc/gsed \
+ t1ascii:${PORTSDIR}/print/t1utils \
+ bash:${PORTSDIR}/shells/bash \
+ fontforge:${PORTSDIR}/print/fontforge \
${LOCALBASE}/share/ghostscript/fonts/c059033l.pfb:${PORTSDIR}/print/gsfonts
-LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile \
- gmp.10:${PORTSDIR}/math/gmp
-RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
+
+LIB_DEPENDS= guile:${PORTSDIR}/lang/guile \
+ gmp:${PORTSDIR}/math/gmp \
+ freetype:${PORTSDIR}/print/freetype2
+
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
mftrace:${PORTSDIR}/print/mftrace \
+ gs:${PORTSDIR}/print/ghostscript9 \
${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans-Bold.ttf:${PORTSDIR}/x11-fonts/dejavu
MAN1= lilymidi.1 lilypond-book.1 lilypond-invoke-editor.1 \
lilypond.1 lilysong.1 convert-ly.1 abc2ly.1 etf2ly.1 \
midi2ly.1 musicxml2ly.1
-INFO= lilypond-changes lilypond-contributor lilypond-essay \
- lilypond-extending lilypond-internals lilypond-learning \
- lilypond-notation lilypond-usage lilypond-web \
- music-glossary
-USE_AUTOTOOLS= autoconf
+INFO= lilypond-notation \
+ lilypond-usage \
+ lilypond-internals \
+ lilypond-learning \
+ lilypond-changes \
+ lilypond-contributor \
+ lilypond-essay \
+ lilypond-extending \
+ lilypond-snippets \
+ lilypond-web \
+ music-glossary \
+ internals
+
USE_BISON= build
USE_GETTEXT= yes
USE_GMAKE= yes
USE_PYTHON= yes
+USE_PERL5_BUILD=yes
USE_GNOME= pango
+
MAKEFILE= GNUmakefile
GNU_MAKEFILE= yes
MAKE_JOBS_UNSAFE= yes
+
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-ncsb-dir=${LOCALBASE}/share/ghostscript/fonts
-CONFIGURE_ENV+= MAKEINFO="${LOCALBASE}/bin/makeinfo" \
- FLEX=${FLEX} \
- YACC=${YACC}
+CONFIGURE_ENV+= ac_cv_prog_MAKEINFO="${LOCALBASE}/bin/makeinfo" \
+ FLEX=${FLEX} YACC=${YACC}
ALL_TARGET= all
@@ -67,20 +79,13 @@ PLIST_SUB+= NLS=""
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|makeinfo|${LOCALBASE}/bin/makeinfo|; s|find -maxdepth|find . -maxdepth|g' \
- ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|<FlexLexer.h>|"/usr/include/FlexLexer.h"|' \
${WRKSRC}/lily/include/includable-lexer.hh
.if defined(WITHOUT_NLS)
- ${REINPLACE_CMD} -e '17,21d' ${WRKSRC}/po/GNUmakefile
-.endif
-
-pre-su-install:
-.if exists(${PREFIX}/info/dir)
- ${REINPLACE_CMD} -i '' -e '/LilyPond/d' ${PREFIX}/info/dir
+ ${REINPLACE_CMD} -e '/^PO_FILES/s|= |= #|' ${WRKSRC}/${MAKEFILE}
.endif
post-install:
- @${LN} -s ${DATADIR}/${PORTVERSION} ${DATADIR}/current
+ @${LN} -fs ${DATADIR}/${PORTVERSION} ${DATADIR}/current
.include <bsd.port.post.mk>
diff --git a/print/lilypond/distinfo b/print/lilypond/distinfo
index d89636fab264..0279e097ee92 100644
--- a/print/lilypond/distinfo
+++ b/print/lilypond/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lilypond-2.14.2.tar.gz) = 243a6b3845722a37083d73ed681e69ffde0b3b9c6158af20db3c0926dd982696
-SIZE (lilypond-2.14.2.tar.gz) = 15224418
+SHA256 (lilypond-2.16.0.tar.gz) = ecd5b7a2da668c94de7757e366f34bdd5d49b89e9b40ce859174dd2a7edb163d
+SIZE (lilypond-2.16.0.tar.gz) = 15994773
diff --git a/print/lilypond/files/patch-Documentation_GNUmakefile b/print/lilypond/files/patch-Documentation_GNUmakefile
new file mode 100644
index 000000000000..87759fd94f9d
--- /dev/null
+++ b/print/lilypond/files/patch-Documentation_GNUmakefile
@@ -0,0 +1,14 @@
+--- Documentation/GNUmakefile.orig 2012-08-28 14:06:34.000000000 +0200
++++ Documentation/GNUmakefile 2012-08-28 14:06:18.000000000 +0200
+@@ -77,9 +77,9 @@
+ MAIN_INFO_DOC = lilypond-web
+ INFO_DOCS = lilypond-usage lilypond-changes lilypond-contributor lilypond-internals \
+ lilypond-essay lilypond-learning lilypond-notation music-glossary \
+- lilypond-web lilypond-extending
++ lilypond-web lilypond-extending lilypond-snippets internals
+ ifeq ($(out),www)
+-INFO_DOCS += lilypond-snippets
++INFO_DOCS +=
+ endif
+ INFO_FILES = $(INFO_DOCS:%=$(outdir)/%.info)
+
diff --git a/print/lilypond/pkg-plist b/print/lilypond/pkg-plist
index 51f0fb03c68d..d5d8ab00a611 100644
--- a/print/lilypond/pkg-plist
+++ b/print/lilypond/pkg-plist
@@ -49,11 +49,19 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-clefs.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-dots.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-dynamics.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags11.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags13.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags14.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags16.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags18.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags20.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags23.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags26.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-macros.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-noteheads-generic.mf
-%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-noteheads-test-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-noteheads.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-noteheads11.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-noteheads13.mf
@@ -75,6 +83,7 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-test20.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-test23.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-test26.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-ties.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-timesignatures.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-trills.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta11.mf
@@ -92,7 +101,16 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-flags.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-macros.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads11.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads13.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads14.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads16.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads18.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads20.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads23.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads26.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-rests.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-scripts.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-timesignatures.mf
@@ -130,6 +148,7 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/ly/catalan.ly
%%DATADIR%%/%%PORTVERSION%%/ly/chord-modifiers-init.ly
%%DATADIR%%/%%PORTVERSION%%/ly/chord-repetition-init.ly
+%%DATADIR%%/%%PORTVERSION%%/ly/context-mods-init.ly
%%DATADIR%%/%%PORTVERSION%%/ly/declarations-init.ly
%%DATADIR%%/%%PORTVERSION%%/ly/deutsch.ly
%%DATADIR%%/%%PORTVERSION%%/ly/drumpitch-init.ly
@@ -137,6 +156,7 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/ly/english.ly
%%DATADIR%%/%%PORTVERSION%%/ly/engraver-init.ly
%%DATADIR%%/%%PORTVERSION%%/ly/espanol.ly
+%%DATADIR%%/%%PORTVERSION%%/ly/event-listener.ly
%%DATADIR%%/%%PORTVERSION%%/ly/festival.ly
%%DATADIR%%/%%PORTVERSION%%/ly/generate-documentation.ly
%%DATADIR%%/%%PORTVERSION%%/ly/generate-interface-doc-init.ly
@@ -162,11 +182,13 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/ly/predefined-ukulele-fretboards.ly
%%DATADIR%%/%%PORTVERSION%%/ly/property-init.ly
%%DATADIR%%/%%PORTVERSION%%/ly/scale-definitions-init.ly
+%%DATADIR%%/%%PORTVERSION%%/ly/scheme-sandbox.ly
%%DATADIR%%/%%PORTVERSION%%/ly/script-init.ly
%%DATADIR%%/%%PORTVERSION%%/ly/spanners-init.ly
%%DATADIR%%/%%PORTVERSION%%/ly/string-tunings-init.ly
%%DATADIR%%/%%PORTVERSION%%/ly/suomi.ly
%%DATADIR%%/%%PORTVERSION%%/ly/svenska.ly
+%%DATADIR%%/%%PORTVERSION%%/ly/text-replacements.ly
%%DATADIR%%/%%PORTVERSION%%/ly/titling-init.ly
%%DATADIR%%/%%PORTVERSION%%/ly/toc-init.ly
%%DATADIR%%/%%PORTVERSION%%/ly/vlaams.ly
@@ -203,6 +225,7 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/scm/auto-beam.scm
%%DATADIR%%/%%PORTVERSION%%/scm/autochange.scm
%%DATADIR%%/%%PORTVERSION%%/scm/backend-library.scm
+%%DATADIR%%/%%PORTVERSION%%/scm/bar-line.scm
%%DATADIR%%/%%PORTVERSION%%/scm/bezier-tools.scm
%%DATADIR%%/%%PORTVERSION%%/scm/c++.scm
%%DATADIR%%/%%PORTVERSION%%/scm/chord-entry.scm
@@ -227,6 +250,7 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/scm/display-lily.scm
%%DATADIR%%/%%PORTVERSION%%/scm/display-woodwind-diagrams.scm
%%DATADIR%%/%%PORTVERSION%%/scm/document-backend.scm
+%%DATADIR%%/%%PORTVERSION%%/scm/document-context-mods.scm
%%DATADIR%%/%%PORTVERSION%%/scm/document-functions.scm
%%DATADIR%%/%%PORTVERSION%%/scm/document-identifiers.scm
%%DATADIR%%/%%PORTVERSION%%/scm/document-markup.scm
@@ -256,6 +280,7 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/scm/lily-sort.scm
%%DATADIR%%/%%PORTVERSION%%/scm/lily.scm
%%DATADIR%%/%%PORTVERSION%%/scm/ly-syntax-constructors.scm
+%%DATADIR%%/%%PORTVERSION%%/scm/markup-macros.scm
%%DATADIR%%/%%PORTVERSION%%/scm/markup.scm
%%DATADIR%%/%%PORTVERSION%%/scm/memory-trace.scm
%%DATADIR%%/%%PORTVERSION%%/scm/midi.scm
@@ -274,12 +299,14 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/scm/predefined-fretboards.scm
%%DATADIR%%/%%PORTVERSION%%/scm/ps-to-png.scm
%%DATADIR%%/%%PORTVERSION%%/scm/safe-lily.scm
+%%DATADIR%%/%%PORTVERSION%%/scm/safe-utility-defs.scm
%%DATADIR%%/%%PORTVERSION%%/scm/script.scm
%%DATADIR%%/%%PORTVERSION%%/scm/song-util.scm
%%DATADIR%%/%%PORTVERSION%%/scm/song.scm
%%DATADIR%%/%%PORTVERSION%%/scm/standalone.scm
%%DATADIR%%/%%PORTVERSION%%/scm/stencil.scm
%%DATADIR%%/%%PORTVERSION%%/scm/tablature.scm
+%%DATADIR%%/%%PORTVERSION%%/scm/text.scm
%%DATADIR%%/%%PORTVERSION%%/scm/time-signature-settings.scm
%%DATADIR%%/%%PORTVERSION%%/scm/titling.scm
%%DATADIR%%/%%PORTVERSION%%/scm/to-xml.scm
@@ -305,6 +332,7 @@ share/emacs/site-lisp/lilypond-words.el
%%NLS%%share/locale/da/LC_MESSAGES/lilypond.mo
%%NLS%%share/locale/de/LC_MESSAGES/lilypond.mo
%%NLS%%share/locale/el/LC_MESSAGES/lilypond.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/lilypond.mo
%%NLS%%share/locale/es/LC_MESSAGES/lilypond.mo
%%NLS%%share/locale/fi/LC_MESSAGES/lilypond.mo
%%NLS%%share/locale/fr/LC_MESSAGES/lilypond.mo