aboutsummaryrefslogtreecommitdiff
path: root/print/lout
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>1998-02-21 21:19:40 +0000
committerBill Fenner <fenner@FreeBSD.org>1998-02-21 21:19:40 +0000
commit9abd386284e0847b46f1fc7aea10e9a1013cd7e2 (patch)
tree695bc446708dcbf3b0d8163802bff26ced60888e /print/lout
parent8ee3feb13e19c368c1f3a713fc360e16f243a1f9 (diff)
downloadports-9abd386284e0847b46f1fc7aea10e9a1013cd7e2.tar.gz
ports-9abd386284e0847b46f1fc7aea10e9a1013cd7e2.zip
Upgrade to 3.11
Notes
Notes: svn path=/head/; revision=9872
Diffstat (limited to 'print/lout')
-rw-r--r--print/lout/Makefile10
-rw-r--r--print/lout/distinfo2
-rw-r--r--print/lout/files/patch-0143
-rw-r--r--print/lout/pkg-plist9
4 files changed, 36 insertions, 28 deletions
diff --git a/print/lout/Makefile b/print/lout/Makefile
index c21823597032..83256c200841 100644
--- a/print/lout/Makefile
+++ b/print/lout/Makefile
@@ -1,17 +1,17 @@
# New ports collection makefile for: lout
-# Version required: 3.10
+# Version required: 3.11
# Date created: 10/22/96
# Whom: oly@world.std.com
#
-# $Id: Makefile,v 1.2 1996/11/09 01:17:15 asami Exp $
+# $Id: Makefile,v 1.3 1997/09/05 15:47:07 max Exp $
#
-DISTNAME= lout.3.10
-PKGNAME= lout-3.10
+DISTNAME= lout.3.11
+PKGNAME= lout-3.11
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_TEX_CTAN} \
ftp://ftp.cs.usyd.edu.au/jeff/lout/
-MASTER_SITE_SUBDIR= support/lout/lout
+MASTER_SITE_SUBDIR= support/lout
MAINTAINER= oly@world.std.com
diff --git a/print/lout/distinfo b/print/lout/distinfo
index d31d343f05f4..6c261c860ca4 100644
--- a/print/lout/distinfo
+++ b/print/lout/distinfo
@@ -1 +1 @@
-MD5 (lout.3.10.tar.gz) = a9669b6138e462938277be1147a74b6b
+MD5 (lout.3.11.tar.gz) = 3fc6bcac17d07ef04ea33d705df9e79e
diff --git a/print/lout/files/patch-01 b/print/lout/files/patch-01
index 63c6e419be0b..8aa878972a19 100644
--- a/print/lout/files/patch-01
+++ b/print/lout/files/patch-01
@@ -1,22 +1,21 @@
---- makefile.orig Sat Nov 30 20:33:10 1996
-+++ makefile Sat Sep 6 00:13:42 1997
-@@ -216,10 +216,11 @@
- USESTAT = 1
- SAFEDFT = 0
+--- makefile.orig Sun Nov 16 20:01:34 1997
++++ makefile Sat Feb 21 11:40:17 1998
+@@ -241,10 +241,10 @@
--BINDIR = /external/users/jhk/bin
--LIBDIR = /external/users/jhk/lout.lib
--DOCDIR = /external/users/jhk/lout.doc
--MANDIR = /external/users/jhk/lout.man
-+PREFIX?= /usr/local
-+BINDIR = $(PREFIX)/bin
-+LIBDIR = $(PREFIX)/share/lout
-+DOCDIR = $(PREFIX)/share/doc/lout
-+MANDIR = $(PREFIX)/man/man1
+ COLLATE = 1
+
+-BINDIR = /usr/staff/jeff/bin
+-LIBDIR = /usr/staff/jeff/lout.lib
+-DOCDIR = /usr/staff/jeff/lout.doc
+-MANDIR = /usr/staff/jeff/lout.man
++BINDIR = ${PREFIX}/bin
++LIBDIR = ${PREFIX}/share/lout
++DOCDIR = ${PREFIX}/share/doc/lout
++MANDIR = ${PREFIX}/man/man1
LIBFONT = font
LIBMAPS = maps
-@@ -231,7 +232,7 @@
+@@ -256,7 +256,7 @@
CHARIN = 1
CHAROUT = 0
@@ -25,7 +24,7 @@
LOC_FR = fr
LOC_DE = de
-@@ -281,40 +282,42 @@
+@@ -310,40 +310,42 @@
@echo "(a) Installing lout and c2lout binaries into BINDIR $(BINDIR)"
cp lout $(BINDIR)/lout
chmod 755 $(BINDIR)/lout
@@ -75,7 +74,7 @@
chmod 755 $(LIBDIR)/$(LIBLOCA)
@echo ""
@echo "(c) Initializing run (should be silent, no errors expected)"
-@@ -323,6 +326,7 @@
+@@ -352,6 +354,7 @@
@echo "(d) Changing mode of files just created by initializing run"
chmod 644 $(LIBDIR)/$(LIBDATA)/*
chmod 644 $(LIBDIR)/$(LIBHYPH)/*
@@ -83,7 +82,7 @@
installman:
@echo ""
-@@ -331,23 +335,27 @@
+@@ -360,23 +363,27 @@
-e "s@<DOCDIR>@$(DOCDIR)@" -e "s@<MANDIR>@$(MANDIR)@" \
man/lout.1 > $(MANDIR)/lout.1
chmod 644 $(MANDIR)/lout.1
@@ -95,9 +94,9 @@
installdoc:
@echo ""
@echo "Creating DOCDIR $(DOCDIR) and copying documentation into it"
-- cp -r doc $(DOCDIR)
-+ -mkdir $(DOCDIR)
-+ cp -r doc/* $(DOCDIR)
+- $(RCOPY) doc $(DOCDIR)
++ -mkdir -p $(DOCDIR)
++ $(RCOPY) doc/* $(DOCDIR)
chmod 755 $(DOCDIR)
chmod 755 $(DOCDIR)/*
chmod 644 $(DOCDIR)/*/*
@@ -114,7 +113,7 @@
chmod 755 $(LIBDIR)/$(LIBLOCA)/$(LOC_FR)/LC_MESSAGES
cp locale/msgs.fr $(LIBDIR)/$(LIBLOCA)/$(LOC_FR)/LC_MESSAGES/msgs.$(LOC_FR)
gencat $(LIBDIR)/$(LIBLOCA)/$(LOC_FR)/LC_MESSAGES/errors.$(LOC_FR) \
-@@ -357,9 +365,9 @@
+@@ -386,9 +393,9 @@
installde:
@echo ""
@echo "Putting German error messages into $(LIBDIR)/$(LIBLOCA)/$(LOC_DE)"
diff --git a/print/lout/pkg-plist b/print/lout/pkg-plist
index fd9910def71f..d416004e99a1 100644
--- a/print/lout/pkg-plist
+++ b/print/lout/pkg-plist
@@ -179,6 +179,7 @@ share/doc/lout/user/gra_over
share/doc/lout/user/gra_plac
share/doc/lout/user/gra_summ
share/doc/lout/user/gra_tick
+share/doc/lout/user/mydcbook
share/doc/lout/user/mydefs
share/doc/lout/user/pascal
share/doc/lout/user/preface
@@ -326,6 +327,8 @@ share/lout/hyph/french.lh
share/lout/hyph/french.lp
share/lout/hyph/german.lh
share/lout/hyph/german.lp
+share/lout/hyph/italian.lh
+share/lout/hyph/italian.lp
share/lout/hyph/norweg.lh
share/lout/hyph/norweg.lp
share/lout/hyph/polish.lh
@@ -337,6 +340,9 @@ share/lout/hyph/swedish.lh
share/lout/hyph/swedish.lp
share/lout/include/README
share/lout/include/README2
+share/lout/include/bddoc
+share/lout/include/bdoc
+share/lout/include/bdslides
share/lout/include/book
share/lout/include/bookf
share/lout/include/cbook
@@ -360,9 +366,11 @@ share/lout/include/docf
share/lout/include/dpicture
share/lout/include/dreport
share/lout/include/dslides
+share/lout/include/ebdslides
share/lout/include/ebook
share/lout/include/edoc
share/lout/include/epicture
+share/lout/include/eprint
share/lout/include/eq
share/lout/include/ereport
share/lout/include/eslides
@@ -381,6 +389,7 @@ share/lout/include/mydefs
share/lout/include/pas
share/lout/include/picture
share/lout/include/picturef
+share/lout/include/queries
share/lout/include/report
share/lout/include/reportf
share/lout/include/russian.fd