aboutsummaryrefslogtreecommitdiff
path: root/print/lyx16
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-03-05 21:27:17 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-03-05 21:27:17 +0000
commit57427523d48fde606fb9cff5d1c4ac61a9cd749b (patch)
tree8f1b8fc32e5a8c9bba844d231b7565b10a73fbca /print/lyx16
parente1330a835fcdab6fc98f323e61280920785db4ed (diff)
downloadports-57427523d48fde606fb9cff5d1c4ac61a9cd749b.tar.gz
ports-57427523d48fde606fb9cff5d1c4ac61a9cd749b.zip
Notes
Diffstat (limited to 'print/lyx16')
-rw-r--r--print/lyx16/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/print/lyx16/Makefile b/print/lyx16/Makefile
index af7d30da3290..232a13d8de43 100644
--- a/print/lyx16/Makefile
+++ b/print/lyx16/Makefile
@@ -24,6 +24,7 @@ RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
USE_PERL5= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
--with-extra-inc="${LOCALBASE}/include"
@@ -53,14 +54,16 @@ RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500035
-USE_GCC= 3.1
+CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS} -Wno-non-template-friend -ftemplate-depth-30"
.if defined(WITH_QT)
-BROKEN= Does not build
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}" \
+ CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS} -Wno-non-template-friend -ftemplate-depth-30"
.endif
.endif
pre-everything::
-.if ( ${OSVERSION} >= 500035 ) && !defined(WITH_QT)
+.if !defined(WITH_QT)
@${ECHO_MSG}
@${ECHO_MSG} "If you want to build with the Qt3 frontend,"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_QT=yes\""
@@ -81,4 +84,9 @@ pre-everything::
@${ECHO_MSG}
.endif
+post-patch:
+ @${REINPLACE_CMD} -E -e \
+ 's|CFLAGS=$$|#CFLAGS=|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
.include <bsd.port.post.mk>