aboutsummaryrefslogtreecommitdiff
path: root/print/lyx
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:16:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:16:49 +0000
commit9d79e7b1469f6887d302e13ce7c67c54408a2453 (patch)
tree263754af5ddd95f1ad55b06c101378a0cf71009b /print/lyx
parenta0e384abe8236d5d12c69354d90c0de5342f7efb (diff)
downloadports-9d79e7b1469f6887d302e13ce7c67c54408a2453.tar.gz
ports-9d79e7b1469f6887d302e13ce7c67c54408a2453.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=430947
Diffstat (limited to 'print/lyx')
-rw-r--r--print/lyx/Makefile8
-rw-r--r--print/lyx/files/extrapatch-src_frontends_qt4_GuiWorkArea.cpp28
2 files changed, 1 insertions, 35 deletions
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index 75ae2074fbea..7dffe808aa5f 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -50,10 +50,4 @@ HUNSPELL_LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
NLS_CONFIGURE_OFF= --disable-nls
NLS_USES= gettext
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1000000 && ${OSVERSION} < 1002000)
-EXTRA_PATCHES= ${FILESDIR}/extrapatch-src_frontends_qt4_GuiWorkArea.cpp
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/lyx/files/extrapatch-src_frontends_qt4_GuiWorkArea.cpp b/print/lyx/files/extrapatch-src_frontends_qt4_GuiWorkArea.cpp
deleted file mode 100644
index fa35a656373a..000000000000
--- a/print/lyx/files/extrapatch-src_frontends_qt4_GuiWorkArea.cpp
+++ /dev/null
@@ -1,28 +0,0 @@
-This patch is necessary for FreeBSD 10.0 and 10.1, whose libc++ does not work
-with boost and std::bind() and leads to the following failure:
-
-frontends/qt4/liblyxqt4.a(GuiWorkArea.o): In function `_ZN5boost6detail8function26void_function_obj_invoker0INSt3__16__bindIMN3lyx8frontend11GuiWorkAreaEFvvEJPS7_EEEvE6invokeERNS1_15function_bufferE':
-GuiWorkArea.cpp:(.text._ZN5boost6detail8function26void_function_obj_invoker0INSt3__16__bindIMN3lyx8frontend11GuiWorkAreaEFvvEJPS7_EEEvE6invokeERNS1_15function_bufferE[_ZN5boost6detail8function26void_function_obj_invoker0INSt3__16__bindIMN3lyx8frontend11GuiWorkAreaEFvvEJPS7_EEEvE6invokeERNS1_15function_bufferE]+0xa): undefined reference to `_ZNSt3__18__invokeIRMN3lyx8frontend11GuiWorkAreaEFvvERPS3_JEvEEDTcldsdeclsr3std3__1E7forwardIT0_Efp0_Efp_spclsr3std3__1E7forwardIT1_Efp1_EEEOT_OS9_DpOSA_'
-/usr/bin/ld: lyx: hidden symbol `_ZNSt3__18__invokeIRMN3lyx8frontend11GuiWorkAreaEFvvERPS3_JEvEEDTcldsdeclsr3std3__1E7forwardIT0_Efp0_Efp_spclsr3std3__1E7forwardIT1_Efp1_EEEOT_OS9_DpOSA_' isn't defined
-/usr/bin/ld: final link failed: Nonrepresentable section on output
-
---- src/frontends/qt4/GuiWorkArea.cpp.orig 2016-05-23 23:47:31 UTC
-+++ src/frontends/qt4/GuiWorkArea.cpp
-@@ -55,6 +55,8 @@
- #include "frontends/FontMetrics.h"
- #include "frontends/WorkAreaManager.h"
-
-+#include <boost/bind.hpp>
-+
- #include <QContextMenuEvent>
- #if (QT_VERSION < 0x050000)
- #include <QInputContext>
-@@ -320,7 +322,7 @@ void GuiWorkArea::init()
- d->setCursorShape(Qt::IBeamCursor);
-
- d->synthetic_mouse_event_.timeout.timeout.connect(
-- bind(&GuiWorkArea::generateSyntheticMouseEvent,
-+ boost::bind(&GuiWorkArea::generateSyntheticMouseEvent,
- this));
-
- // Initialize the vertical Scroll Bar