aboutsummaryrefslogtreecommitdiff
path: root/print/makeindex
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-08-26 04:20:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-08-26 04:20:37 +0000
commitd5c75d77b2532bdd1bc6c135f26460dc5e4d0895 (patch)
tree7cf2aacfc83dcc44bb68457e62e88dab9bd213fb /print/makeindex
parent846ba4a247cff1acb50d0b35ec2aa732480c8851 (diff)
downloadports-d5c75d77b2532bdd1bc6c135f26460dc5e4d0895.tar.gz
ports-d5c75d77b2532bdd1bc6c135f26460dc5e4d0895.zip
- Fix MASTER_SITES
- Support CFLAGS properly PR: 160138 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=280471
Diffstat (limited to 'print/makeindex')
-rw-r--r--print/makeindex/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/print/makeindex/Makefile b/print/makeindex/Makefile
index 5f2a11aa721f..bb746c86e026 100644
--- a/print/makeindex/Makefile
+++ b/print/makeindex/Makefile
@@ -7,31 +7,34 @@
PORTNAME= makeindex
PORTVERSION= 3.0.8
+PORTREVISION= 1
CATEGORIES= print
-MASTER_SITES= http://freebsd.unixfreunde.de/sources/ \
- http://mirror2.unixfreunde.de/
+MASTER_SITES= http://ftp.linux.cz/pub/tex/local/indexing/makeindex3/ \
+ http://ftp.cstug.cz/pub/tex/local/indexing/makeindex3/
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= A general purpose, formatter-independent index processor
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
+CONFLICTS= teTeX-base-[0-9]*
WRKSRC= ${WRKDIR}/makeindex
MAN1= makeindex.1
+post-patch:
+ @(cd ${WRKSRC}/doc; \
+ ${SED} -e s:/usr/local/lib/tex/macros/:${PREFIX}/share/texmf/makeindx/: \
+ <makeindex.l >makeindex.1)
+
do-build:
- @(cd ${WRKSRC}/src-3.0/regexp; make)
- @(cd ${WRKSRC}/src-3.0; make)
+ @(cd ${WRKSRC}/src-3.0/regexp; ${MAKE} OPT="${CFLAGS}")
+ @(cd ${WRKSRC}/src-3.0; ${MAKE} OPT="${CFLAGS}")
do-install:
@${MKDIR} ${PREFIX}/share/texmf/makeindx
- @(cd ${WRKSRC}/src-3.0/regexp; make)
- @(cd ${WRKSRC}/src-3.0; make install)
+ @(cd ${WRKSRC}/src-3.0/regexp; ${MAKE})
+ @(cd ${WRKSRC}/src-3.0; ${MAKE} install)
@(cd ${WRKSRC}/doc; \
- ${SED} -e s:/usr/local/lib/tex/macros/:${PREFIX}/share/texmf/makeindx/: \
- <makeindex.l >makeindex.1; \
- ${INSTALL_DATA} makeindex.1 ${PREFIX}/man/man1/)
+ ${INSTALL_DATA} makeindex.1 ${MANPREFIX}/man/man1)
.include <bsd.port.mk>