aboutsummaryrefslogtreecommitdiff
path: root/print/makeindex
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-10-12 02:58:10 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-10-12 02:58:10 +0000
commiteb0eafb6b167610ba925cb3a99ba4fdfa56d5b7c (patch)
tree6f834d933ba9eb516a4d78f3a64775342e1aa48a /print/makeindex
parent7914f6c0712d1eac7a4f228fbffb89230d8f6822 (diff)
downloadports-eb0eafb6b167610ba925cb3a99ba4fdfa56d5b7c.tar.gz
ports-eb0eafb6b167610ba925cb3a99ba4fdfa56d5b7c.zip
This is Jean-Marc Zucconi's makeindex port.
Submitted by: jmz
Notes
Notes: svn path=/head/; revision=214
Diffstat (limited to 'print/makeindex')
-rw-r--r--print/makeindex/Makefile23
-rw-r--r--print/makeindex/pkg-comment1
-rw-r--r--print/makeindex/pkg-descr12
-rw-r--r--print/makeindex/pkg-plist20
-rw-r--r--print/makeindex/scripts/configure13
5 files changed, 69 insertions, 0 deletions
diff --git a/print/makeindex/Makefile b/print/makeindex/Makefile
new file mode 100644
index 000000000000..6d649c24b414
--- /dev/null
+++ b/print/makeindex/Makefile
@@ -0,0 +1,23 @@
+DISTFILES= makeindex-3.0.8.tar.Z
+DISTNAME= makeindex
+
+MASTER_SITES= ftp://achilles.doc.ic.ac.uk/tex/contrib/Schrod/
+
+build: configure pre-build
+ @echo "===> Building for ${DISTNAME}"
+ @(cd ${WRKSRC}/src-3.0/regexp; make)
+ @(cd ${WRKSRC}/src-3.0; make)
+
+install:
+ @echo "===> Installing for ${DISTNAME}"
+ @mkdir -p ${PREFIX}/lib/texmf/makeindx
+ @mkdir -p ${PREFIX}/bin
+ @mkdir -p ${PREFIX}/man/man1
+ @(cd ${WRKSRC}/src-3.0/regexp; make)
+ @(cd ${WRKSRC}/src-3.0; make install)
+ @(cd ${WRKSRC}/doc; \
+ sed -e s:/usr/local/lib/tex/macros/:${PREFIX}/lib/texmf/makeindx/: \
+ <makeindex.l >makeindex.1; \
+ install -c -m 644 makeindex.1 ${PREFIX}/man/man1/)
+
+.include <bsd.port.mk>
diff --git a/print/makeindex/pkg-comment b/print/makeindex/pkg-comment
new file mode 100644
index 000000000000..c9b8d1eea5d4
--- /dev/null
+++ b/print/makeindex/pkg-comment
@@ -0,0 +1 @@
+makeindex - a general purpose, formatter-independent index processor.
diff --git a/print/makeindex/pkg-descr b/print/makeindex/pkg-descr
new file mode 100644
index 000000000000..c13b1e202f61
--- /dev/null
+++ b/print/makeindex/pkg-descr
@@ -0,0 +1,12 @@
+The program makeindex is a general purpose hierarchical index
+generator; it accepts one or more input files (often produced by a
+text formatter such as TeX or troff, sorts the entries, and produces
+an output file which can be formatted. The index can have up to three
+levels (0, 1, and 2) of subitem nesting. The way in which words are
+flagged for indexing within the main document is specific to the
+formatter used; makeindex does not automate the process of selecting
+these words. As the output index is hierarchical, makeindex can be
+considered complimentary to the awk(1)-based make.index(1L) system of
+Bentley and Kernighan, which is specific to troff(1), generates
+non-hierarchical indices, and employs a much simpler syntax for
+indicating index entries.
diff --git a/print/makeindex/pkg-plist b/print/makeindex/pkg-plist
new file mode 100644
index 000000000000..e01593f3b089
--- /dev/null
+++ b/print/makeindex/pkg-plist
@@ -0,0 +1,20 @@
+@cd /usr/local
+@owner bin
+@mode 755
+bin/makeindex
+@mode 644
+lib/texmf/makeindx/din.ist
+lib/texmf/makeindx/icase.ist
+lib/texmf/makeindx/latex.ist
+lib/texmf/makeindx/math.ist
+lib/texmf/makeindx/mkind.ist
+lib/texmf/makeindx/puncts.ist
+lib/texmf/makeindx/tex.ist
+lib/texmf/makeindx/english/digit.ist
+lib/texmf/makeindx/english/letter.ist
+lib/texmf/makeindx/english/special.ist
+lib/texmf/makeindx/german/digit.ist
+lib/texmf/makeindx/german/special.ist
+lib/texmf/makeindx/german/umlaut.ist
+lib/texmf/makeindx/german/wb.ist
+man/man1/makeindex.1
diff --git a/print/makeindex/scripts/configure b/print/makeindex/scripts/configure
new file mode 100644
index 000000000000..e1634b5711cc
--- /dev/null
+++ b/print/makeindex/scripts/configure
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+cd $WRKSRC/src-3.0 || exit 1;
+cp Makefile.gen Makefile || exit 1;
+echo "STYDIR=$PREFIX/lib/texmf/makeindx" >> Makefile || exit 1;
+echo "BINDIR=$PREFIX/bin" >> Makefile || exit 1;
+
+mv mkind.h mkind.h.orig || exit 1;
+sed -e s:/usr/local:$PREFIX: < mkind.h.orig > mkind.h
+
+cd regexp || exit 1;
+cp Makefile.psx Makefile || exit 1;
+exit 0