aboutsummaryrefslogtreecommitdiff
path: root/print/mpage
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-05 13:22:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-05 13:22:00 +0000
commit52535f7cf0b607b0a4e645395d912df23b05cba0 (patch)
tree0bf117fe7dc6473c4f4827b3569d0fdaf213194b /print/mpage
parent97bb25b35b1fcc284677c8a45b98ecb595c0ec0e (diff)
downloadports-52535f7cf0b607b0a4e645395d912df23b05cba0.tar.gz
ports-52535f7cf0b607b0a4e645395d912df23b05cba0.zip
- Update to 2.5.4
PR: ports/73470 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=120864
Diffstat (limited to 'print/mpage')
-rw-r--r--print/mpage/Makefile10
-rw-r--r--print/mpage/distinfo4
-rw-r--r--print/mpage/files/patch-file_c52
-rw-r--r--print/mpage/pkg-plist8
4 files changed, 34 insertions, 40 deletions
diff --git a/print/mpage/Makefile b/print/mpage/Makefile
index 3cf8b2ff7768..229979319189 100644
--- a/print/mpage/Makefile
+++ b/print/mpage/Makefile
@@ -10,8 +10,7 @@
# "Legal" (8.5" x 14").
PORTNAME= mpage
-PORTVERSION= 2.5.3
-PORTREVISION= 1
+PORTVERSION= 2.5.4
CATEGORIES= print
MASTER_SITES= ftp://ftp.mesa.nl/pub/mpage/
EXTRACT_SUFX= .tgz
@@ -19,7 +18,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Print multiple pages per sheet of paper
-MAN1= mpage.1
ALL_TARGET= default
+MAN1= mpage.1
+PLIST_FILES= bin/mpage %%DATADIR%%/CP850.PC %%DATADIR%%/ISO+STD+OTH \
+ %%DATADIR%%/ISO-8859.1 %%DATADIR%%/ISO-8859.15 \
+ %%DATADIR%%/ISO-Latin.1 %%DATADIR%%/ISO-Latin.2
+PLIST_DIRS= %%DATADIR%%
+
.include <bsd.port.mk>
diff --git a/print/mpage/distinfo b/print/mpage/distinfo
index 5c361bd08654..55ec3df9d6e3 100644
--- a/print/mpage/distinfo
+++ b/print/mpage/distinfo
@@ -1,2 +1,2 @@
-MD5 (mpage-2.5.3.tgz) = 4724dcba203100384b4611be8adc900c
-SIZE (mpage-2.5.3.tgz) = 82101
+MD5 (mpage-2.5.4.tgz) = c14d58e24e7fdebe0c9eeb57ef1895f4
+SIZE (mpage-2.5.4.tgz) = 93992
diff --git a/print/mpage/files/patch-file_c b/print/mpage/files/patch-file_c
index d1838f88d6c2..725f8b09a8db 100644
--- a/print/mpage/files/patch-file_c
+++ b/print/mpage/files/patch-file_c
@@ -1,6 +1,5 @@
-$OpenBSD: patch-file_c,v 1.2 2002/11/13 17:15:49 naddy Exp $
---- file.c.orig Sun Jun 16 02:56:44 2002
-+++ file.c Mon Nov 11 06:54:23 2002
+--- file.c.orig Mon May 31 04:34:15 2004
++++ file.c Mon Nov 1 20:58:16 2004
@@ -18,6 +18,7 @@
*/
@@ -9,41 +8,40 @@ $OpenBSD: patch-file_c,v 1.2 2002/11/13 17:15:49 naddy Exp $
#include "mpage.h"
-@@ -101,10 +102,10 @@ do_pr_file(fname, asheet, outfd)
- * header or not
+@@ -119,11 +120,11 @@
*/
+ #define DASHES "-- "
if (opt_header != NULL)
-- (void)sprintf(command, "%s -l%d -w%d -h \"%s\" %s", prprog,
-+ (void)snprintf(command, sizeof(command), "%s -l%d -w%d -h \"%s\" %s", prprog,
- asheet->sh_plength, asheet->sh_cwidth, opt_header, fname);
+- (void)sprintf(command, "%s -l%d -w%d -h \"%s\" %s%s", prprog,
++ (void)snprintf(command, sizeof(command), "%s -l%d -w%d -h \"%s\" %s%s", prprog,
+ asheet->sh_plength, asheet->sh_cwidth, opt_header,
+ fname[0] == '-' ? DASHES : "", fname);
else
-- (void)sprintf(command, "%s -l%d -w%d %s", prprog,
-+ (void)snprintf(command, sizeof(command), "%s -l%d -w%d %s", prprog,
- asheet->sh_plength, asheet->sh_cwidth, fname);
+- (void)sprintf(command, "%s -l%d -w%d %s%s", prprog,
++ (void)snprintf(command, sizeof(command), "%s -l%d -w%d %s%s", prprog,
+ asheet->sh_plength, asheet->sh_cwidth,
+ fname[0] == '-' ? DASHES : "", fname);
/*
- * open a pipe to the proper pr(1) command, and pr provides
-@@ -148,7 +149,7 @@ do_stdin(asheet, outfd)
- * a temporary file; this temporary file will then
- * be used as input to the do_doc routine
- */
-- (void)strcpy(tmpfile, "/usr/tmp/mpageXXXXXX");
-+ (void)strlcpy(tmpfile, "/tmp/mpageXXXXXX", sizeof(tmpfile));
- if ( (tmpfd = mkstemp(tmpfile)) == -1) {
- fprintf(stderr, "%s: cannot create temporary file", MPAGE);
- perror(MPAGE);
-@@ -156,11 +157,13 @@ do_stdin(asheet, outfd)
+@@ -168,7 +169,7 @@
+ * but the tmpfilename
+ */
+
+- (void) strcpy(tmpfile, "/usr/tmp/mpage-stdin-XXXXXX");
++ (void) strlcpy(tmpfile, "/tmp/mpage-stdin-XXXXXX", sizeof(tmpfile));
+ if ( (tmpfd = mkstemp(tmpfile)) == -1) {
+ fprintf(stderr, "%s: cannot create temporary file", MPAGE);
+ perror(MPAGE);
+@@ -217,11 +218,11 @@
}
close(tmpfd);
if (opt_header != NULL)
-- (void)sprintf(command, "%s -l%d -w%d -h \"%s\"> %s", prprog,
-+ (void)snprintf(command, sizeof(command),
-+ "%s -l%d -w%d -h \"%s\"> %s", prprog,
+- (void)sprintf(command, "%s -l%d -w%d -h \"%s\" > %s", prprog,
++ (void)snprintf(command, sizeof(command), "%s -l%d -w%d -h \"%s\" > %s", prprog,
asheet->sh_plength, asheet->sh_cwidth,
opt_header, tmpfile);
else
- (void)sprintf(command, "%s -l%d -w%d > %s", prprog,
-+ (void)snprintf(command, sizeof(command),
-+ "%s -l%d -w%d > %s", prprog,
++ (void)snprintf(command, sizeof(command), "%s -l%d -w%d > %s", prprog,
asheet->sh_plength, asheet->sh_cwidth, tmpfile);
/*
* open a pipe to the pr(1) command which will create a
diff --git a/print/mpage/pkg-plist b/print/mpage/pkg-plist
deleted file mode 100644
index 7e9fa655a735..000000000000
--- a/print/mpage/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/mpage
-share/mpage/CP850.PC
-share/mpage/ISO+STD+OTH
-share/mpage/ISO-8859.1
-share/mpage/ISO-8859.15
-share/mpage/ISO-Latin.1
-share/mpage/ISO-Latin.2
-@dirrm share/mpage