aboutsummaryrefslogtreecommitdiff
path: root/print/mpage
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-12-11 19:36:37 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-12-11 19:36:37 +0000
commit79f7eaf006627f84d8e3fb9847c0abd3ca7b2d76 (patch)
treef58aa28b94b3037f4f8590c5bd7d2751f537f796 /print/mpage
parent1f0911181604ad58fa5154c0543c513897b3f5eb (diff)
downloadports-79f7eaf006627f84d8e3fb9847c0abd3ca7b2d76.tar.gz
ports-79f7eaf006627f84d8e3fb9847c0abd3ca7b2d76.zip
Notes
Diffstat (limited to 'print/mpage')
-rw-r--r--print/mpage/Makefile13
-rw-r--r--print/mpage/files/patch-Makefile (renamed from print/mpage/files/patch-aa)23
-rw-r--r--print/mpage/files/patch-args.c (renamed from print/mpage/files/patch-args_c)0
-rw-r--r--print/mpage/files/patch-mpage.1.in (renamed from print/mpage/files/patch-mpage_1_in)0
-rw-r--r--print/mpage/files/patch-mpage.c (renamed from print/mpage/files/patch-mpage_c)0
-rw-r--r--print/mpage/files/patch-post.c (renamed from print/mpage/files/patch-post_c)0
6 files changed, 19 insertions, 17 deletions
diff --git a/print/mpage/Makefile b/print/mpage/Makefile
index fa2bcd460147..724ebc91db17 100644
--- a/print/mpage/Makefile
+++ b/print/mpage/Makefile
@@ -16,21 +16,16 @@ COMMENT= Print multiple pages per sheet of paper
ALL_TARGET= default
-MAN1= mpage.1
PORTDOCS= CHANGES Characters Copyright Encoding.format FAQ NEWS \
README README.OS2 README.amiga SCOPTIONS TODO
PLIST_FILES= bin/mpage %%DATADIR%%/CP850.PC %%DATADIR%%/ISO+STD+OTH \
%%DATADIR%%/ISO-8859.1 %%DATADIR%%/ISO-8859.15 \
- %%DATADIR%%/ISO-Latin.1 %%DATADIR%%/ISO-Latin.2
+ %%DATADIR%%/ISO-Latin.1 %%DATADIR%%/ISO-Latin.2 \
+ man/man1/mpage.1.gz
PLIST_DIRS= %%DATADIR%%
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for FILE in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
-.endfor
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/print/mpage/files/patch-aa b/print/mpage/files/patch-Makefile
index d28aaacb560f..fe696305ed3c 100644
--- a/print/mpage/files/patch-aa
+++ b/print/mpage/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Mon Oct 21 03:46:44 2002
-+++ Makefile Sat Nov 2 16:41:52 2002
+--- Makefile.orig 2004-05-31 00:38:31.000000000 +0500
++++ Makefile 2013-12-11 23:08:46.646822192 +0400
@@ -24,7 +24,6 @@
# Set this to an ANSI compatible C compiler (preferably gcc)
# See also system specific settings below
@@ -8,7 +8,7 @@
############################################################################
#
-@@ -40,7 +39,7 @@
+@@ -40,7 +39,7 @@ CC=gcc
# See glob.c for all possibilities
#
# PAGESIZE=Letter
@@ -17,15 +17,22 @@
#
# Define your spooler type
-@@ -50,7 +49,6 @@
+@@ -50,11 +49,10 @@ PAGESIZE=A4
SPOOL_TYPE=BSD_SPOOLER
# PREFIX=e:/usr # OS/2 type
-PREFIX=/usr/local
#PREFIX=/usr
- BINDIR=$(PREFIX)/bin
- LIBDIR=$(PREFIX)/share
-@@ -106,8 +104,11 @@
+-BINDIR=$(PREFIX)/bin
+-LIBDIR=$(PREFIX)/share
+-MANDIR=$(PREFIX)/man/man1
++BINDIR=${DESTDIR}$(PREFIX)/bin
++LIBDIR=${DESTDIR}$(PREFIX)/share
++MANDIR=${DESTDIR}$(PREFIX)/man/man1
+
+ #
+ # A default encoding is given in encoding.h. Setting ENCODING=1 will
+@@ -106,8 +104,11 @@ O = .o
# Choose one of the following CFLAGS/CC definitions:
# If you are using gcc, you probably don't need to change anything here.
@@ -38,7 +45,7 @@
# AIX (xlC on aix 4):
#CFLAGS = -O2 -s $(DEFS)
-@@ -177,7 +178,6 @@
+@@ -181,7 +182,6 @@ install:
if [ ! -d $(LIBDIR)/mpage ] ; then mkdir -p $(LIBDIR)/mpage ; fi
if [ ! -d $(BINDIR) ] ; then mkdir -p $(BINDIR) ; fi
if [ ! -d $(MANDIR) ] ; then mkdir -p $(MANDIR) ; fi
diff --git a/print/mpage/files/patch-args_c b/print/mpage/files/patch-args.c
index 81695b62a830..81695b62a830 100644
--- a/print/mpage/files/patch-args_c
+++ b/print/mpage/files/patch-args.c
diff --git a/print/mpage/files/patch-mpage_1_in b/print/mpage/files/patch-mpage.1.in
index 05ae2a3c49fa..05ae2a3c49fa 100644
--- a/print/mpage/files/patch-mpage_1_in
+++ b/print/mpage/files/patch-mpage.1.in
diff --git a/print/mpage/files/patch-mpage_c b/print/mpage/files/patch-mpage.c
index e93d618d48ea..e93d618d48ea 100644
--- a/print/mpage/files/patch-mpage_c
+++ b/print/mpage/files/patch-mpage.c
diff --git a/print/mpage/files/patch-post_c b/print/mpage/files/patch-post.c
index 4e54394f4af0..4e54394f4af0 100644
--- a/print/mpage/files/patch-post_c
+++ b/print/mpage/files/patch-post.c