aboutsummaryrefslogtreecommitdiff
path: root/print/mpage
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-08-02 11:25:11 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-08-02 11:25:11 +0000
commita0caaced6f484165d97a0d78df229f9cedf84fb1 (patch)
treee12c247cd4c022ea4f77e03691c454fb25332748 /print/mpage
parent13a7d7db16dd4cc86d382c7132099abf09104772 (diff)
downloadports-a0caaced6f484165d97a0d78df229f9cedf84fb1.tar.gz
ports-a0caaced6f484165d97a0d78df229f9cedf84fb1.zip
Remove spurious strcpy() that clobbers the stack.
Submitted by: Guy Middleton <guy@crtsol.com>
Notes
Notes: svn path=/head/; revision=63867
Diffstat (limited to 'print/mpage')
-rw-r--r--print/mpage/Makefile1
-rw-r--r--print/mpage/files/patch-args.c13
2 files changed, 14 insertions, 0 deletions
diff --git a/print/mpage/Makefile b/print/mpage/Makefile
index 015d7e824cc2..b2712d9ae48e 100644
--- a/print/mpage/Makefile
+++ b/print/mpage/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mpage
PORTVERSION= 2.5.2
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= ftp://ftp.mesa.nl/pub/mpage/
EXTRACT_SUFX= .tgz
diff --git a/print/mpage/files/patch-args.c b/print/mpage/files/patch-args.c
new file mode 100644
index 000000000000..32b1df52ecba
--- /dev/null
+++ b/print/mpage/files/patch-args.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- args.c.orig Fri Aug 2 13:16:25 2002
++++ args.c Fri Aug 2 13:17:06 2002
+@@ -442,7 +442,6 @@
+ libdir = env;
+
+ if ((env = getenv("MPAGE")) != NULL) {
+- strcpy(copy, env);
+ if ((copy = strdup(env)) == NULL) {
+ fprintf(stderr, "%s: Unable to alloc memory for environment args\n",
+ MPAGE);