aboutsummaryrefslogtreecommitdiff
path: root/print/nenscript
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-14 03:50:27 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-14 03:50:27 +0000
commit6571d6147b9794374ba2e54ed5725c790af984d5 (patch)
treed60b91fa1eb8fe607c8f89142862299dd2e85aa3 /print/nenscript
parent023e2deaeb57c01571b367db5628602479dd4f3e (diff)
downloadports-6571d6147b9794374ba2e54ed5725c790af984d5.tar.gz
ports-6571d6147b9794374ba2e54ed5725c790af984d5.zip
Initial import of nenscript version 1.13.3.
A clone of the proprietary enscript program from Adobe Systems. PR: 14815 Submitted by: Christopher J. Michaels <cjm2@altavista.net>
Notes
Notes: svn path=/head/; revision=23117
Diffstat (limited to 'print/nenscript')
-rw-r--r--print/nenscript/Makefile30
-rw-r--r--print/nenscript/distinfo1
-rw-r--r--print/nenscript/files/patch-aa66
-rw-r--r--print/nenscript/pkg-comment1
-rw-r--r--print/nenscript/pkg-descr19
-rw-r--r--print/nenscript/pkg-plist3
6 files changed, 120 insertions, 0 deletions
diff --git a/print/nenscript/Makefile b/print/nenscript/Makefile
new file mode 100644
index 000000000000..3098e9ead79c
--- /dev/null
+++ b/print/nenscript/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: nenscript
+# Version required: 1.13.3
+# Date created: 10 November 1999
+# Whom: cjm2
+#
+# $FreeBSD$
+#
+
+DISTNAME= nenscript-1.13.3
+CATEGORIES= print
+MASTER_SITES= http://www.im.lcs.mit.edu/~magnus/nenscript/
+
+MAINTAINER= cjm2@altavista.net
+
+USE_BZIP2= yes
+
+MAKEFILE= makefile
+MAN1= nenscript.1
+
+pre-fetch:
+ @${ECHO_MSG} "To build the Non-US version type:"
+ @${ECHO_MSG} " make NON_US=yes"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nenscript ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/nenscript.1 ${MANPREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/doc/nenscript
+ ${INSTALL_MAN} ${WRKSRC}/readme ${PREFIX}/share/doc/nenscript
+
+.include <bsd.port.mk>
diff --git a/print/nenscript/distinfo b/print/nenscript/distinfo
new file mode 100644
index 000000000000..af6cde221a78
--- /dev/null
+++ b/print/nenscript/distinfo
@@ -0,0 +1 @@
+MD5 (nenscript-1.13.3.tar.bz2) = 606f0966b893150ce70baed025a192f0
diff --git a/print/nenscript/files/patch-aa b/print/nenscript/files/patch-aa
new file mode 100644
index 000000000000..dd885a086c13
--- /dev/null
+++ b/print/nenscript/files/patch-aa
@@ -0,0 +1,66 @@
+--- makefile.orig Wed Aug 11 21:02:50 1993
++++ makefile Wed Nov 10 23:17:56 1999
+@@ -11,9 +11,9 @@
+ SOURCES = main.c postscri.c print.c fontwidt.c font_lis.c paper.c
+ OBJECTS = $(SOURCES:.c=.o)
+
+-INSTALLDIR = /usr/local
+-BININSTALLDIR = $(INSTALLDIR)/bin
+-MANINSTALLDIR = $(INSTALLDIR)/man/man1
++#INSTALLDIR = /usr/local
++BININSTALLDIR = ${PREFIX}/bin
++MANINSTALLDIR = ${MANPREFIX}/man/man1
+
+ LOCALINSTALLDIR = $(HOME)/bin
+ LOCALMANINSTALLDIR = $(HOME)/man/man1
+@@ -26,14 +26,20 @@
+ #
+ # US_VERSION selects default US paper format as well as selecting US format date
+ #
+-CFLAGS = -O $(DEBUG) -DUS_VERSION
++.if !defined(NON_US)
++CFLAGS += -DUS_VERSION
++.endif
++.if defined(DEBUG)
++CFLAGS += -g
++.endif
++
+ LFLAGS =
+
+-CHMOD = chmod
+-CP = cp
+-RM = rm
++#CHMOD = chmod
++#CP = cp
++#RM = rm
+ #INSTALL = /etc/install
+-INSTALL = /usr/ucb/install -c
++#INSTALL = /usr/ucb/install -c
+
+ all debug: $(PROG)
+
+@@ -43,18 +49,18 @@
+ main.$(OBJ): main.c
+
+ install: $(PROG)
+- $(INSTALL) -s -m 555 $(PROG) $(BININSTALLDIR)
+- $(INSTALL) -m 444 $(MAN) $(MANINSTALLDIR)
++ ${INSTALL_PROGRAM} $(PROG) $(BININSTALLDIR)
++ ${INSTALL_MAN} $(MAN) $(MANINSTALLDIR)
+
+ install.man: $(MAN)
+- $(INSTALL) -f $(MAININSTALLDIR) -m 444 $(MAN)
++ ${INSTALL_MAN} $(MAININSTALLDIR) $(MAN)
+
+ install.local: $(PROG) $(MAN)
+- $(INSTALL) -s -m 555 $(PROG) $(LOCALINSTALLDIR)
+- $(INSTALL) -m 444 $(MAN) $(LOCALMANINSTALLDIR)
++ ${INSTALL_PROGRAM} $(PROG) $(LOCALINSTALLDIR)
++ ${INSTALL_MAN} $(MAN) $(LOCALMANINSTALLDIR)
+
+ clean:
+- rm -f *.o *.obj *.exe *.mdt $(PROG)
++ ${RM} -rf *.o *.obj *.exe *.mdt $(PROG)
+
+ font_lis.c: machdep.h defs.h font_lis.h main.h
+
diff --git a/print/nenscript/pkg-comment b/print/nenscript/pkg-comment
new file mode 100644
index 000000000000..1b7dfb62dd00
--- /dev/null
+++ b/print/nenscript/pkg-comment
@@ -0,0 +1 @@
+A clone of the proprietary enscript program from Adobe Systems
diff --git a/print/nenscript/pkg-descr b/print/nenscript/pkg-descr
new file mode 100644
index 000000000000..eb5bae9cdd9c
--- /dev/null
+++ b/print/nenscript/pkg-descr
@@ -0,0 +1,19 @@
+A clone of the proprietary enscript program from Adobe Systems. For those
+who have never used enscript, it is a good ASCII to Postscript converter.
+
+The main features of nenscript are:
+
+ . produces Postscript output which fully conforms to
+ the Document Structuring Conventions
+ . support for normal and "gaudy" output
+ . support for single or double column output
+ . allows insertion of titles and headers in any font.
+ . multiple copies of a document
+
+Features additional to nenscript are:
+ . automatic wrapping of long lines
+ . availability under MSDOS
+ . executable is self contained - no additional files required
+
+-Chris
+cjm2@altavista.net
diff --git a/print/nenscript/pkg-plist b/print/nenscript/pkg-plist
new file mode 100644
index 000000000000..87d6db89409e
--- /dev/null
+++ b/print/nenscript/pkg-plist
@@ -0,0 +1,3 @@
+bin/nenscript
+share/doc/nenscript/readme
+@dirrm share/doc/nenscript