aboutsummaryrefslogtreecommitdiff
path: root/print/p5-Font-FreeType
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2017-07-17 17:21:05 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2017-07-17 17:21:05 +0000
commitce3d99b886605db7d640290d9b6ba5bb0001c1f2 (patch)
tree8796045e0f48a9697c09175c2d966b5726c82275 /print/p5-Font-FreeType
parent45b2819b0f8ac7688cc73c36dd02b0d205a1a5e4 (diff)
downloadports-ce3d99b886605db7d640290d9b6ba5bb0001c1f2.tar.gz
ports-ce3d99b886605db7d640290d9b6ba5bb0001c1f2.zip
Update print/p5-Font-FreeType to 0.07
- update depends - remove no longer relevant patches - specify LICENSE Changelog: http://search.cpan.org/dist/Font-FreeType/Changes PR: 218293 Submitted by: Anton Yuzhaninov Approved by: kuriyama (maintainer timeout, 3+ months) Approved by: az (mentor), vsevolod (mentor).
Notes
Notes: svn path=/head/; revision=446082
Diffstat (limited to 'print/p5-Font-FreeType')
-rw-r--r--print/p5-Font-FreeType/Makefile13
-rw-r--r--print/p5-Font-FreeType/distinfo5
-rw-r--r--print/p5-Font-FreeType/files/patch-FreeType.xs48
-rw-r--r--print/p5-Font-FreeType/files/patch-Makefile.PL13
-rw-r--r--print/p5-Font-FreeType/pkg-plist6
5 files changed, 19 insertions, 66 deletions
diff --git a/print/p5-Font-FreeType/Makefile b/print/p5-Font-FreeType/Makefile
index a37e2daf078f..e97b5b1cab61 100644
--- a/print/p5-Font-FreeType/Makefile
+++ b/print/p5-Font-FreeType/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= Font-FreeType
-PORTVERSION= 0.03
-PORTREVISION= 2
+PORTVERSION= 0.07
CATEGORIES= print perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -10,9 +9,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to read font files and render glyphs using FreeType2
+LICENSE= ARTPERL10
+
+BUILD_DEPENDS= p5-Devel-CheckLib>=0:devel/p5-Devel-CheckLib \
+ p5-File-Which>=0:sysutils/p5-File-Which
LIB_DEPENDS= libfreetype.so:print/freetype2
+TEST_DEPENDS= p5-Test-Warnings>=0:devel/p5-Test-Warnings
-USES= pkgconfig perl5
+USES= perl5
USE_PERL5= configure
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Font/FreeType/FreeType.so
+
.include <bsd.port.mk>
diff --git a/print/p5-Font-FreeType/distinfo b/print/p5-Font-FreeType/distinfo
index d5387b5c872d..96105e8ce6e6 100644
--- a/print/p5-Font-FreeType/distinfo
+++ b/print/p5-Font-FreeType/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Font-FreeType-0.03.tar.gz) = c07eab16bb4d16ba61fd0a3376a8f76980245aef443d1ea193ec5446d1127d5f
-SIZE (Font-FreeType-0.03.tar.gz) = 95275
+TIMESTAMP = 1491011072
+SHA256 (Font-FreeType-0.07.tar.gz) = 4d2f6426a11b732469fb3d7a198c02a47779157f938116cbb7602826e54efc79
+SIZE (Font-FreeType-0.07.tar.gz) = 234507
diff --git a/print/p5-Font-FreeType/files/patch-FreeType.xs b/print/p5-Font-FreeType/files/patch-FreeType.xs
deleted file mode 100644
index c3a9fee694d2..000000000000
--- a/print/p5-Font-FreeType/files/patch-FreeType.xs
+++ /dev/null
@@ -1,48 +0,0 @@
---- FreeType.xs.orig 2004-09-12 05:50:44.000000000 +0900
-+++ FreeType.xs 2011-08-13 20:42:27.482201061 +0900
-@@ -226,7 +226,7 @@
- #define QEFFT2_CALL_TIDY FREETMPS; LEAVE;
-
- static int
--handle_move_to (FT_Vector *to, void *data)
-+handle_move_to (const FT_Vector *to, void *data)
- {
- struct QefFT2_Outline_Decompose_Extra_ *extra = data;
- double x = QEFFT2_NUM(to->x), y = QEFFT2_NUM(to->y);
-@@ -243,7 +243,7 @@
- }
-
- static int
--handle_line_to (FT_Vector *to, void *data)
-+handle_line_to (const FT_Vector *to, void *data)
- {
- struct QefFT2_Outline_Decompose_Extra_ *extra = data;
- double x = QEFFT2_NUM(to->x), y = QEFFT2_NUM(to->y);
-@@ -260,7 +260,7 @@
- }
-
- static int
--handle_conic_to (FT_Vector *control, FT_Vector *to, void *data)
-+handle_conic_to (const FT_Vector *control, const FT_Vector *to, void *data)
- {
- struct QefFT2_Outline_Decompose_Extra_ *extra = data;
- double x = QEFFT2_NUM(to->x), y = QEFFT2_NUM(to->y);
-@@ -292,7 +292,7 @@
- }
-
- static int
--handle_cubic_to (FT_Vector *control1, FT_Vector *control2, FT_Vector *to,
-+handle_cubic_to (const FT_Vector *control1, const FT_Vector *control2, const FT_Vector *to,
- void *data)
- {
- struct QefFT2_Outline_Decompose_Extra_ *extra = data;
-@@ -805,7 +805,8 @@
- char_code = FT_Get_First_Char(face, &glyph_idx);
- while (glyph_idx) {
- if (glyph_idx == glyph->index) {
-- RETVAL = newSVuv((UV) glyph->char_code = char_code);
-+ glyph->char_code = char_code;
-+ RETVAL = newSVuv((UV) glyph->char_code);
- break;
- }
- char_code = FT_Get_Next_Char(face, char_code, &glyph_idx);
diff --git a/print/p5-Font-FreeType/files/patch-Makefile.PL b/print/p5-Font-FreeType/files/patch-Makefile.PL
deleted file mode 100644
index 39665842b204..000000000000
--- a/print/p5-Font-FreeType/files/patch-Makefile.PL
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.PL.bak 2004-09-10 09:43:29.000000000 +0900
-+++ Makefile.PL 2011-08-13 21:01:55.896033332 +0900
-@@ -5,8 +5,8 @@
- NAME => 'Font::FreeType',
- AUTHOR => 'Geoff Richards <qef@laxan.com>',
- VERSION_FROM => 'lib/Font/FreeType.pm',
-- LIBS => [ '-lfreetype' ],
-- INC => '-I/usr/include/freetype2',
-+ LIBS => `pkg-config --libs freetype2`,
-+ INC => `pkg-config --cflags freetype2`,
- NO_META => 1,
- );
-
diff --git a/print/p5-Font-FreeType/pkg-plist b/print/p5-Font-FreeType/pkg-plist
index 142266074dda..502468a8b5ed 100644
--- a/print/p5-Font-FreeType/pkg-plist
+++ b/print/p5-Font-FreeType/pkg-plist
@@ -1,7 +1,13 @@
%%SITE_ARCH%%/Font/FreeType.pm
+%%SITE_ARCH%%/Font/FreeType/BoundingBox.pm
+%%SITE_ARCH%%/Font/FreeType/CharMap.pm
%%SITE_ARCH%%/Font/FreeType/Face.pm
%%SITE_ARCH%%/Font/FreeType/Glyph.pm
+%%SITE_ARCH%%/Font/FreeType/NamedInfo.pm
%%SITE_ARCH%%/auto/Font/FreeType/FreeType.so
%%PERL5_MAN3%%/Font::FreeType.3.gz
+%%PERL5_MAN3%%/Font::FreeType::BoundingBox.3.gz
+%%PERL5_MAN3%%/Font::FreeType::CharMap.3.gz
%%PERL5_MAN3%%/Font::FreeType::Face.3.gz
%%PERL5_MAN3%%/Font::FreeType::Glyph.3.gz
+%%PERL5_MAN3%%/Font::FreeType::NamedInfo.3.gz