aboutsummaryrefslogtreecommitdiff
path: root/print/p5-Net-CUPS
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-24 13:37:22 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-24 13:37:22 +0000
commit09bb802d34adaf1d3ddc1a9eae28b06964588c96 (patch)
treedb5b3692c6f28ceb48f75e1aa00fe12c4b3471f3 /print/p5-Net-CUPS
parentdd5691331d2bce239f11ddee0685f73d687ee98b (diff)
downloadports-09bb802d34adaf1d3ddc1a9eae28b06964588c96.tar.gz
ports-09bb802d34adaf1d3ddc1a9eae28b06964588c96.zip
Update to 0.64
- Strip shared library - Update pkg-descr Changes: http://search.cpan.org/dist/Net-CUPS/Changes
Notes
Notes: svn path=/head/; revision=462805
Diffstat (limited to 'print/p5-Net-CUPS')
-rw-r--r--print/p5-Net-CUPS/Makefile6
-rw-r--r--print/p5-Net-CUPS/distinfo5
-rw-r--r--print/p5-Net-CUPS/files/patch-CUPS.xs165
-rw-r--r--print/p5-Net-CUPS/files/patch-Makefile.PL18
-rw-r--r--print/p5-Net-CUPS/pkg-descr12
5 files changed, 14 insertions, 192 deletions
diff --git a/print/p5-Net-CUPS/Makefile b/print/p5-Net-CUPS/Makefile
index c03d6fedb577..0594d214a8de 100644
--- a/print/p5-Net-CUPS/Makefile
+++ b/print/p5-Net-CUPS/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= Net-CUPS
-PORTVERSION= 0.61
-PORTREVISION= 5
+PORTVERSION= 0.64
CATEGORIES= print perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -20,4 +19,7 @@ LIB_DEPENDS= libcupsimage.so:print/cups \
USES= perl5
USE_PERL5= configure
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Net/CUPS/CUPS.so
+
.include <bsd.port.mk>
diff --git a/print/p5-Net-CUPS/distinfo b/print/p5-Net-CUPS/distinfo
index 21a8a15667ca..247e0aa37fcc 100644
--- a/print/p5-Net-CUPS/distinfo
+++ b/print/p5-Net-CUPS/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Net-CUPS-0.61.tar.gz) = fd4a5a86038df9dfe57dcfed78b2d045e4b18d507a6fa5a8f82ecb3a732e0e35
-SIZE (Net-CUPS-0.61.tar.gz) = 83893
+TIMESTAMP = 1519418917
+SHA256 (Net-CUPS-0.64.tar.gz) = d7bc77ff0f62bf874c843c590eb12a80bbd44749a2fb74dbed445c35d0e85a85
+SIZE (Net-CUPS-0.64.tar.gz) = 87872
diff --git a/print/p5-Net-CUPS/files/patch-CUPS.xs b/print/p5-Net-CUPS/files/patch-CUPS.xs
deleted file mode 100644
index 9ae3b2c666d8..000000000000
--- a/print/p5-Net-CUPS/files/patch-CUPS.xs
+++ /dev/null
@@ -1,165 +0,0 @@
-Patch obtained from: https://rt.cpan.org/Public/Bug/Display.html?id=78583
-
---- ./CUPS.xs.orig 2009-07-30 13:42:59.000000000 +0000
-+++ ./CUPS.xs 2014-04-20 19:18:15.000000000 +0000
-@@ -5,9 +5,17 @@
- #include "ppport.h"
-
- #include <cups/cups.h>
-+#if (CUPS_VERSION_MAJOR > 1) || (CUPS_VERSION_MINOR > 5)
-+#define HAVE_CUPS_1_6 1
-+#endif
-+
- /*#include <cups/backend.h>*/
- #include <cups/http.h>
--#include <cups/image.h>
-+#ifdef HAVE_CUPS_1_6
-+ #include <cupsfilters/image.h>
-+#else
-+ #include <cups/image.h>
-+#endif
- #include <cups/ipp.h>
- #include <cups/ppd.h>
- #include <cups/file.h>
-@@ -19,6 +27,17 @@
- #include "const-c.inc"
- #include "packer.c"
-
-+#ifndef HAVE_CUPS_1_6
-+#define ippGetGroupTag(attr) attr->group_tag
-+#define ippGetName(attr) attr->name
-+#define ippGetValueTag(attr) attr->value_tag
-+#define ippGetInteger(attr, element) attr->values[element].integer
-+#define ippGetString(attr, element, language) attr->values[element].string.text
-+#define ippGetStatusCode(ipp) ipp->request.status.status_code
-+#define ippFirstAttribute(ipp) ipp->current = ipp->attrs
-+#define ippNextAttribute(ipp) ipp->current = ipp->current->next
-+#endif
-+
- static SV *password_cb = (SV*) NULL;
-
- const char *
-@@ -200,7 +219,7 @@
- if (response != NULL) {
- attr = ippFindAttribute(response, "ppd-make", IPP_TAG_TEXT);
- rv = sv_newmortal();
-- sv_setpv(rv, attr->values[0].string.text);
-+ sv_setpv(rv, ippGetString(attr, 0, NULL));
- XPUSHs(rv);
- count++;
-
-@@ -211,7 +230,7 @@
- }
-
- rv = sv_newmortal();
-- sv_setpv(rv, attr->values[0].string.text);
-+ sv_setpv(rv, ippGetString(attr, 0, NULL));
- XPUSHs(rv);
- count++;
- }
-@@ -252,7 +271,7 @@
- "ppd-make-and-model",
- IPP_TAG_TEXT);
- rv = sv_newmortal();
-- sv_setpv(rv, attr->values[0].string.text);
-+ sv_setpv(rv, ippGetString(attr, 0, NULL));
- XPUSHs(rv);
- count++;
- while (attr != NULL) {
-@@ -263,7 +282,7 @@
- break;
- }
- rv = sv_newmortal();
-- sv_setpv(rv, attr->values[0].string.text);
-+ sv_setpv(rv, ippGetString(attr, 0, NULL));
- XPUSHs(rv);
- count++;
- }
-@@ -356,14 +375,14 @@
- if (response != NULL) {
- attr = ippFindAttribute(response, "ppd-name", IPP_TAG_NAME );
- while ((attr != NULL) && (i < 1)) {
-- tmpppd = attr->values[0].string.text;
-+ tmpppd = ippGetString(attr, 0, NULL);
- attr = ippFindNextAttribute(response,
- "ppd-make",
- IPP_TAG_TEXT);
- attr = ippFindNextAttribute(response,
- "ppd-make-and-model",
- IPP_TAG_TEXT);
-- if (strcmp(attr->values[0].string.text, ppdfilename) == 0 ) {
-+ if (strcmp(ippGetString(attr, 0, NULL), ppdfilename) == 0 ) {
- /* return tmpppd; */
- strcpy(test, tmpppd);
- break;
-@@ -410,12 +429,12 @@
- attr = ippFindNextAttribute(response, "printer-name", IPP_TAG_NAME);
-
- while (attr != NULL) {
-- if (strcmp(attr->values[0].string.text, device) == 0) {
-+ if (strcmp(ippGetString(attr, 0, NULL), device) == 0) {
- attr = ippFindNextAttribute( response,
- attribute,
- attribute_type);
- rv = sv_newmortal();
-- sv_setpv( rv, attr->values[0].string.text);
-+ sv_setpv( rv, ippGetString(attr, 0, NULL));
- XPUSHs( rv );
- break;
- }
-@@ -858,15 +877,15 @@
- SV* rv = NULL;
- int count = 0;
- ipp_attribute_t* attr = NULL;
-- for (attr = ipp->attrs; attr != NULL; attr = attr->next)
-+ for (attr = ippFirstAttribute(ipp); attr != NULL; attr = ippNextAttribute(ipp))
- {
-- while (attr != NULL && attr->group_tag != IPP_TAG_JOB)
-- attr = attr->next;
-+ while (attr != NULL && ippGetGroupTag(attr) != IPP_TAG_JOB)
-+ attr = ippNextAttribute(ipp);
-
- if (attr == NULL)
- break;
- rv = sv_newmortal();
-- sv_setpv( rv, attr->name );
-+ sv_setpv( rv, ippGetName(attr) );
- XPUSHs( rv );
- count++;
- }
-@@ -880,27 +899,27 @@
- SV* rv = NULL;
- int count = 0;
- ipp_attribute_t* attr = NULL;
-- for (attr = ipp->attrs; attr != NULL; attr = attr->next)
-+ for (attr = ippFirstAttribute(ipp); attr != NULL; attr = ippNextAttribute(ipp))
- {
-- while (attr != NULL && attr->group_tag != IPP_TAG_JOB)
-- attr = attr->next;
-+ while (attr != NULL && ippGetGroupTag(attr) != IPP_TAG_JOB)
-+ attr = ippNextAttribute(ipp);
-
- if (attr == NULL)
- break;
-
-- if( !strcmp( attr->name, name ) )
-+ if( !strcmp( ippGetName(attr), name ) )
- {
- rv = sv_newmortal();
-- if( ( attr->value_tag == IPP_TAG_INTEGER ) ||
-- ( attr->value_tag == IPP_TAG_ENUM ) )
-+ if( ( ippGetValueTag(attr) == IPP_TAG_INTEGER ) ||
-+ ( ippGetValueTag(attr) == IPP_TAG_ENUM ) )
- {
- /* We have a number with any luck ... */
-- sv_setiv( rv, attr->values[0].integer );
-+ sv_setiv( rv, ippGetInteger(attr, 0) );
- }
- else
- {
- /* We have a string ... maybe ... try to set it. */
-- sv_setpv( rv, attr->values[0].string.text );
-+ sv_setpv( rv, ippGetString(attr, 0, NULL) );
- }
-
- XPUSHs( rv );
diff --git a/print/p5-Net-CUPS/files/patch-Makefile.PL b/print/p5-Net-CUPS/files/patch-Makefile.PL
deleted file mode 100644
index 0551f5e28f7f..000000000000
--- a/print/p5-Net-CUPS/files/patch-Makefile.PL
+++ /dev/null
@@ -1,18 +0,0 @@
-Fixes issue with the version check as mentioned upstream:
-https://rt.cpan.org/Public/Bug/Display.html?id=104237
-
---- Makefile.PL.orig 2015-10-27 12:05:43 UTC
-+++ Makefile.PL
-@@ -31,8 +31,10 @@ else
-
- my @version_parts = split( /\./, $version );
-
--if( ( $version_parts[1] < 2 ) ||
-- ( ( $version_parts[1] == 2 ) && ( $version_parts[2] < 2 ) ) )
-+if(
-+ ( $version_parts[0] < 1 ) ||
-+ ( ( $version_parts[0] == 1 ) && ( $version_parts[1] < 2 ) ) ||
-+ ( ( $version_parts[0] == 1 ) && ( $version_parts[1] == 2 ) && ( $version_parts[2] < 2 ) ) )
- {
- print "The version of the Common Unix Printing System installed\n";
- print "on your system is too old for this module to work properly.\n";
diff --git a/print/p5-Net-CUPS/pkg-descr b/print/p5-Net-CUPS/pkg-descr
index 6a2bbea0aebf..d7912b3bb0cf 100644
--- a/print/p5-Net-CUPS/pkg-descr
+++ b/print/p5-Net-CUPS/pkg-descr
@@ -1,8 +1,10 @@
-Previous versions of this module attempted to provide a Perl interface
-layer similar to the C interface of CUPS. This was fine for power users,
-but most people were not looking for this type of interface.
+Net::CUPS is an interface to the Common Unix Printing System API.
-This module has now been converted to use an object oriented paradigm
-to facilitate quicker development and ease of use.
+Previous versions of this module attempted to provide a Perl interface layer
+similar to the C interface of CUPS. This was fine for power users, but most
+people were not looking for this type of interface.
+
+This module has now been converted to use an object oriented paradigm to
+facilitate quicker development and ease of use.
WWW: http://search.cpan.org/dist/Net-CUPS/