aboutsummaryrefslogtreecommitdiff
path: root/print/pcal
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-14 22:42:27 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-14 22:42:27 +0000
commit3d92847487a2973e1944742ffb9d46ca5ee330bf (patch)
treeb00c908d04488087690453ef070a8e2311f26f8d /print/pcal
parentb4ae0851a8f35bfb36429daedb44f13fad7f2472 (diff)
downloadports-3d92847487a2973e1944742ffb9d46ca5ee330bf.tar.gz
ports-3d92847487a2973e1944742ffb9d46ca5ee330bf.zip
- Update to 4.8.0
- Undeprecate - Assign maintainership PR: ports/76220 Submitted by: Matthew West <mwest@uct.ac.za>
Notes
Notes: svn path=/head/; revision=126469
Diffstat (limited to 'print/pcal')
-rw-r--r--print/pcal/Makefile36
-rw-r--r--print/pcal/distinfo4
-rw-r--r--print/pcal/files/patch-aa38
-rw-r--r--print/pcal/files/patch-ab8
-rw-r--r--print/pcal/files/patch-ac15
-rw-r--r--print/pcal/files/patch-ad14
-rw-r--r--print/pcal/files/patch-ae19
-rw-r--r--print/pcal/pkg-plist18
8 files changed, 67 insertions, 85 deletions
diff --git a/print/pcal/Makefile b/print/pcal/Makefile
index ea2d54126b46..6eccf5c34cc7 100644
--- a/print/pcal/Makefile
+++ b/print/pcal/Makefile
@@ -6,24 +6,22 @@
#
PORTNAME= pcal
-PORTVERSION= 4.7.1
+PORTVERSION= 4.8.0
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mwest@uct.ac.za
COMMENT= PostScript calendar program
-DEPRECATED= http://vuxml.FreeBSD.org/58fc2752-5f74-11d9-a9e7-0001020eed82.html
-EXPIRATION_DATE=2005-02-13
-
USE_REINPLACE= yes
-MAKE_ENV= CC="${CC}" HOST_CC="${CC}" PAPERSIZE="${PAPERSIZE}"
-ALL_TARGET= pcal
+MAKE_ENV= CC="${CC}" HOST_CC="${CC}"
+ALL_TARGET=
+USE_GMAKE= yes
MAN1= pcal.1
-PLIST_FILES= bin/pcal libexec/pcal.cgi
-PORTDOCS= ReadMe pcal.html pcalw.html
+PORTDOCS= ReadMe.txt pcal.html pcalw.html
WWWSERVER!= hostname
@@ -31,21 +29,23 @@ WWWSERVER!= hostname
post-patch:
@${REINPLACE_CMD} -e \
- 's|@@PREFIX@@|${PREFIX}|g' ${WRKSRC}/pcal.cgi
+ 's|@@PREFIX@@|${PREFIX}|g' ${WRKSRC}/html/pcal.cgi
@${REINPLACE_CMD} -e \
- 's|@@WWWSERVER@@|${WWWSERVER}|g' ${WRKSRC}/pcal.html
+ 's|@@WWWSERVER@@|${WWWSERVER}|g' ${WRKSRC}/html/pcal.html
@${REINPLACE_CMD} -e \
- 's|@@WWWSERVER@@|${WWWSERVER}|g' ${WRKSRC}/pcalw.html
+ 's|@@WWWSERVER@@|${WWWSERVER}|g' ${WRKSRC}/html/pcalw.html
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pcal ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/pcal.cgi ${PREFIX}/libexec
- ${INSTALL_MAN} ${WRKSRC}/pcal.man ${MANPREFIX}/man/man1/pcal.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/exec/pcal ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/html/pcal.cgi ${PREFIX}/libexec
+ ${INSTALL_MAN} ${WRKSRC}/doc/pcal.man ${MANPREFIX}/man/man1/pcal.1
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/ReadMe ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/pcal.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/pcalw.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/ReadMe.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/html/pcal.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/html/pcalw.html ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/print/pcal/distinfo b/print/pcal/distinfo
index 4910940017eb..b923e9306276 100644
--- a/print/pcal/distinfo
+++ b/print/pcal/distinfo
@@ -1,2 +1,2 @@
-MD5 (pcal-4.7.1.tar.gz) = 07d8e3b92affc4940c4401d9a8274075
-SIZE (pcal-4.7.1.tar.gz) = 291594
+MD5 (pcal-4.8.0.tgz) = 0bd20cec495926c81b5cd03b637d7a62
+SIZE (pcal-4.8.0.tgz) = 266615
diff --git a/print/pcal/files/patch-aa b/print/pcal/files/patch-aa
index 0c8072602ac0..542785257e16 100644
--- a/print/pcal/files/patch-aa
+++ b/print/pcal/files/patch-aa
@@ -1,20 +1,20 @@
---- Makefile.orig Tue Jan 7 10:29:28 2003
-+++ Makefile Sat May 24 15:40:57 2003
-@@ -21,8 +21,8 @@
-
- # Set the configuration variables below to taste.
-
--PCALINIT_CC = /usr/bin/gcc # native compiler
--CC = /usr/bin/gcc # cross-compiler (if target != host)
-+PCALINIT_CC = ${CC} # native compiler
-+CC = ${HOST_CC} # cross-compiler (if target != host)
-
- # Set COMPRESS to your preferred compression utility (compress, gzip, etc.),
- # Z to the file suffix that it generates (.Z, .gz, etc.), and UUC to the file
-@@ -58,9 +58,9 @@
- # PACK = pack
-
- # directories for installing executable and man page(s)
+--- Makefile.orig Thu Dec 16 00:54:16 2004
++++ Makefile Thu Jan 13 17:28:01 2005
+@@ -73,8 +73,8 @@
+ D_BUILD_ENV = -DBUILD_ENV_UNIX
+ PCAL = pcal
+ PCALINIT = pcalinit
+- CC = /usr/bin/gcc
+- PCALINIT_CC = /usr/bin/gcc
++ CC = ${HOST_CC}
++ PCALINIT_CC = ${CC}
+ PACK = compress
+ # PACK = pack
+ # PACK = gzip
+@@ -101,9 +101,9 @@
+ OBJDIR = obj
+ EXECDIR = exec
+ DOCDIR = doc
-BINDIR = /usr/local/bin
-MANDIR = /usr/man/man1
-CATDIR = /usr/man/cat1
@@ -22,5 +22,5 @@
+MANDIR = ${PREFIX}/man/man1
+CATDIR = ${PREFIX}/cat1
- OBJECTS = pcal.o exprpars.o moonphas.o pcalutil.o readfile.o writefil.o
-
+ #
+ # Compiling for DOS/DJGPP requires different directories for the installed
diff --git a/print/pcal/files/patch-ab b/print/pcal/files/patch-ab
index 30f608219a49..0b8e4293be25 100644
--- a/print/pcal/files/patch-ab
+++ b/print/pcal/files/patch-ab
@@ -1,6 +1,6 @@
---- pcal.cgi.orig Wed Dec 20 15:43:36 2000
-+++ pcal.cgi Wed Dec 20 15:45:35 2000
-@@ -27,8 +27,8 @@
+--- html/pcal.cgi.orig Thu Dec 16 01:18:24 2004
++++ html/pcal.cgi Thu Jan 13 17:29:50 2005
+@@ -29,8 +29,8 @@
# common calendar file on your system (note that the user can't use his/her
# own calendar file since most servers will execute pcal.cgi as 'nobody')
@@ -10,4 +10,4 @@
+file=@@PREFIX@@/share/misc/calendar
# set DEBUG=1 to echo debugging output as HTML text
- DEBUG=0
+ # DEBUG=0
diff --git a/print/pcal/files/patch-ac b/print/pcal/files/patch-ac
index 2290dff70a02..3eb99805523d 100644
--- a/print/pcal/files/patch-ac
+++ b/print/pcal/files/patch-ac
@@ -1,15 +1,6 @@
---- pcal.html.orig Wed Feb 9 18:06:23 2000
-+++ pcal.html Sat May 24 15:42:13 2003
-@@ -12,7 +12,7 @@
-
- -->
- <HEAD>
--<TITLE>pcal v4.6</TITLE>
-+<TITLE>pcal v4.7.1</TITLE>
- </HEAD>
-
- <BODY>
-@@ -21,7 +21,7 @@
+--- html/pcal.html.orig Thu Dec 16 01:18:24 2004
++++ html/pcal.html Thu Jan 13 17:31:10 2005
+@@ -20,7 +20,7 @@
<!-- start of form -->
diff --git a/print/pcal/files/patch-ad b/print/pcal/files/patch-ad
index fd9ccb32877e..0432f65d43c5 100644
--- a/print/pcal/files/patch-ad
+++ b/print/pcal/files/patch-ad
@@ -1,14 +1,6 @@
---- pcalw.html.orig Wed Feb 9 18:06:23 2000
-+++ pcalw.html Sat May 24 15:42:43 2003
-@@ -12,14 +12,14 @@
-
- -->
- <HEAD>
--<TITLE>pcal v4.6 (single-year mode)</TITLE>
-+<TITLE>pcal v4.7.1 (single-year mode)</TITLE>
- </HEAD>
- <BODY>
- <H2 ALIGN=CENTER>Generate single-page PostScript calendar for entire year</H2>
+--- html/pcalw.html.orig Thu Dec 16 01:18:24 2004
++++ html/pcalw.html Thu Jan 13 17:31:55 2005
+@@ -20,7 +20,7 @@
<!-- start of form -->
diff --git a/print/pcal/files/patch-ae b/print/pcal/files/patch-ae
deleted file mode 100644
index 031ba3350c8a..000000000000
--- a/print/pcal/files/patch-ae
+++ /dev/null
@@ -1,19 +0,0 @@
---- pcal.man.orig Wed Feb 9 18:06:23 2000
-+++ pcal.man Sat May 24 15:37:18 2003
-@@ -443,14 +443,14 @@
- `&#NNN;' (NNN = any three decimal digits) are also supported. These will
- be propagated intact (be sure to escape the `#' in `&#NNN;') if the output
- is specified as HTML (see the
--.B -\H
-+.B \-H
- flag); otherwise they will be converted to their ASCII equivalents. This
- allows a common date file to be used regardless of whether the desired
- output format is HTML, PostScript, or
- Un*x
- .I "calendar(1)"
- (see the
--.B -\c
-+.B \-c
- flag) input.
- .PP
- Lines in the
diff --git a/print/pcal/pkg-plist b/print/pcal/pkg-plist
new file mode 100644
index 000000000000..ef45ecd76570
--- /dev/null
+++ b/print/pcal/pkg-plist
@@ -0,0 +1,18 @@
+bin/pcal
+libexec/pcal.cgi
+%%EXAMPLESDIR%%/calendar_au.txt
+%%EXAMPLESDIR%%/calendar_de.txt
+%%EXAMPLESDIR%%/calendar_ee.txt
+%%EXAMPLESDIR%%/calendar_fi.txt
+%%EXAMPLESDIR%%/calendar_fr.txt
+%%EXAMPLESDIR%%/calendar_gr.txt
+%%EXAMPLESDIR%%/calendar_no.txt
+%%EXAMPLESDIR%%/calendar_nz.txt
+%%EXAMPLESDIR%%/calendar_uk.txt
+%%EXAMPLESDIR%%/fonttest_e
+%%EXAMPLESDIR%%/fonttest_koi8u
+%%EXAMPLESDIR%%/fonttest_l
+%%EXAMPLESDIR%%/fonttest_r
+%%EXAMPLESDIR%%/moon98
+%%EXAMPLESDIR%%/pcal-cfg.txt
+@dirrm %%EXAMPLESDIR%%