aboutsummaryrefslogtreecommitdiff
path: root/print/pcal
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-06 13:13:44 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-06 13:13:44 +0000
commita6bd184328baae0b61a878d1b24833013b2d6532 (patch)
treebce1fcfa1228223a4e3b1c36296259bcf0ce7e5e /print/pcal
parent199894f6563276e6808887ed84a724e3615a1a85 (diff)
downloadports-a6bd184328baae0b61a878d1b24833013b2d6532.tar.gz
ports-a6bd184328baae0b61a878d1b24833013b2d6532.zip
add pcal
PostScript calendar program PR: 28020 Submitted by: Matthew West <mwest@uct.ac.za>
Notes
Notes: svn path=/head/; revision=45879
Diffstat (limited to 'print/pcal')
-rw-r--r--print/pcal/Makefile57
-rw-r--r--print/pcal/distinfo1
-rw-r--r--print/pcal/files/patch-aa37
-rw-r--r--print/pcal/files/patch-ab13
-rw-r--r--print/pcal/files/patch-ac20
-rw-r--r--print/pcal/files/patch-ad19
-rw-r--r--print/pcal/files/patch-ae19
-rw-r--r--print/pcal/pkg-comment1
-rw-r--r--print/pcal/pkg-descr9
-rw-r--r--print/pcal/pkg-plist6
10 files changed, 182 insertions, 0 deletions
diff --git a/print/pcal/Makefile b/print/pcal/Makefile
new file mode 100644
index 000000000000..5d0ff4baa4b7
--- /dev/null
+++ b/print/pcal/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: pcal
+# Date created: 10 June 2001
+# Whom: mwest@uct.ac.za
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcal
+PORTVERSION= 4.7
+CATEGORIES= print
+MASTER_SITES= http://www.geocities.com/SunsetStrip/Palms/5555/PS/
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/}_tar_Z
+EXTRACT_SUFX= .txt
+
+MAINTAINER= mwest@uct.ac.za
+
+WRKSRC= ${WRKDIR}/pcal.${PORTVERSION}
+PAPERSIZE?= A4
+WWWSERVER!= hostname
+
+MAN1= pcal.1
+
+.include <bsd.port.pre.mk>
+
+MAKE_ENV+= PAPERSIZE="${PAPERSIZE}"
+MAKE_ENV+= CC="${CC}" HOST_CC="${CC}"
+
+ALL_TARGET= pcal
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @(cd ${WRKDIR}; \
+ uudecode -p ${DISTDIR}/${DISTFILES} | ${TAR} xzf -; \
+ )
+
+pre-install:
+ ${MV} ${WRKSRC}/pcal.cgi ${WRKSRC}/pcal.cgi.tmp
+ ${SED} -e 's|@@PREFIX@@|${PREFIX}|' \
+ < ${WRKSRC}/pcal.cgi.tmp > ${WRKSRC}/pcal.cgi
+ ${MV} ${WRKSRC}/pcal.html ${WRKSRC}/pcal.html.tmp
+ ${SED} -e 's|@@WWWSERVER@@|${WWWSERVER}|' \
+ < ${WRKSRC}/pcal.html.tmp > ${WRKSRC}/pcal.html
+ ${MV} ${WRKSRC}/pcalw.html ${WRKSRC}/pcalw.html.tmp
+ ${SED} -e 's|@@WWWSERVER@@|${WWWSERVER}|' \
+ < ${WRKSRC}/pcalw.html.tmp > ${WRKSRC}/pcalw.html
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pcal ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/pcal.cgi ${PREFIX}/libexec
+ ${INSTALL_MAN} ${WRKSRC}/pcal.man ${PREFIX}/man/man1/pcal.1
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ReadMe ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/pcal.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/pcalw.html ${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/print/pcal/distinfo b/print/pcal/distinfo
new file mode 100644
index 000000000000..4cb769eb12ee
--- /dev/null
+++ b/print/pcal/distinfo
@@ -0,0 +1 @@
+MD5 (pcal_4_7_tar_Z.txt) = cef12878d3f6862d0cd1ad4358dcce38
diff --git a/print/pcal/files/patch-aa b/print/pcal/files/patch-aa
new file mode 100644
index 000000000000..08d025ea3e64
--- /dev/null
+++ b/print/pcal/files/patch-aa
@@ -0,0 +1,37 @@
+--- Makefile.orig Thu Feb 10 01:06:23 2000
++++ Makefile Thu Dec 21 09:40:35 2000
+@@ -21,8 +21,8 @@
+
+ # Set the configuration variables below to taste.
+
+-PCALINIT_CC = /bin/cc # native compiler
+-CC = /bin/cc # cross-compiler (if target != host)
++PCALINIT_CC = ${CC} # native compiler
++CC = ${HOST_CC} # cross-compiler (if target != host)
+
+ # Set COMPRESS to your preferred compression utility (compress, gzip, etc.),
+ # Z to the file suffix that it generates (.Z, .gz, etc.), and UUC to the file
+@@ -58,9 +58,9 @@
+ # PACK = pack
+
+ # directories for installing executable and man page(s)
+-BINDIR = /usr/local/bin
+-MANDIR = /usr/man/man1
+-CATDIR = /usr/man/cat1
++BINDIR = ${PREFIX}/bin
++MANDIR = ${PREFIX}/man/man1
++CATDIR = ${PREFIX}/cat1
+
+ OBJECTS = pcal.o exprpars.o moonphas.o pcalutil.o readfile.o writefil.o
+
+@@ -112,6 +112,10 @@
+ $(D_TEXT) $(D_LINK) $(D_ALINK) $(D_VLINK) \
+ $(D_HOLIDAY_PRE) $(D_HOLIDAY_POST) $(D_BLANK_STYLE) \
+ $(D_SEARCH_PCAL_DIR)
++
++.if defined(PAPERSIZE) && $(PAPERSIZE) == A4 # default Letter (OK?)
++COPTS += -DA4PAPER
++.endif
+
+ $(PCAL): $(OBJECTS)
+ $(CC) $(LDFLAGS) -o $(PCAL) $(OBJECTS) -lm
diff --git a/print/pcal/files/patch-ab b/print/pcal/files/patch-ab
new file mode 100644
index 000000000000..30f608219a49
--- /dev/null
+++ b/print/pcal/files/patch-ab
@@ -0,0 +1,13 @@
+--- pcal.cgi.orig Wed Dec 20 15:43:36 2000
++++ pcal.cgi Wed Dec 20 15:45:35 2000
+@@ -27,8 +27,8 @@
+ # common calendar file on your system (note that the user can't use his/her
+ # own calendar file since most servers will execute pcal.cgi as 'nobody')
+
+-pcal=/yourpath/pcal
+-file=/yourpath/calendar
++pcal=@@PREFIX@@/bin/pcal
++file=@@PREFIX@@/share/misc/calendar
+
+ # set DEBUG=1 to echo debugging output as HTML text
+ DEBUG=0
diff --git a/print/pcal/files/patch-ac b/print/pcal/files/patch-ac
new file mode 100644
index 000000000000..e14405b198cb
--- /dev/null
+++ b/print/pcal/files/patch-ac
@@ -0,0 +1,20 @@
+--- pcal.html.orig Thu Feb 10 01:06:23 2000
++++ pcal.html Wed Dec 20 17:38:53 2000
+@@ -12,7 +12,7 @@
+
+ -->
+ <HEAD>
+-<TITLE>pcal v4.6</TITLE>
++<TITLE>pcal v4.7</TITLE>
+ </HEAD>
+
+ <BODY>
+@@ -21,7 +21,7 @@
+
+ <!-- start of form -->
+
+-<FORM ACTION="http://yourpath/cgi-bin/pcal.cgi" METHOD=GET>
++<FORM ACTION="http://@@WWWSERVER@@/cgi-bin/pcal.cgi" METHOD=GET>
+
+ <!-- menu for starting month -->
+
diff --git a/print/pcal/files/patch-ad b/print/pcal/files/patch-ad
new file mode 100644
index 000000000000..9e3f2942d0bf
--- /dev/null
+++ b/print/pcal/files/patch-ad
@@ -0,0 +1,19 @@
+--- pcalw.html.orig Thu Feb 10 01:06:23 2000
++++ pcalw.html Wed Dec 20 17:38:56 2000
+@@ -12,14 +12,14 @@
+
+ -->
+ <HEAD>
+-<TITLE>pcal v4.6 (single-year mode)</TITLE>
++<TITLE>pcal v4.7 (single-year mode)</TITLE>
+ </HEAD>
+ <BODY>
+ <H2 ALIGN=CENTER>Generate single-page PostScript calendar for entire year</H2>
+
+ <!-- start of form -->
+
+-<FORM ACTION="http://yourpath/pcal.cgi" METHOD=GET>
++<FORM ACTION="http://@@WWWSERVER@@/cgi-bin/pcal.cgi" METHOD=GET>
+
+ <INPUT TYPE=HIDDEN NAME=wflag VALUE="-w"> <!-- silently set -w flag -->
+
diff --git a/print/pcal/files/patch-ae b/print/pcal/files/patch-ae
new file mode 100644
index 000000000000..82bd6e20dac5
--- /dev/null
+++ b/print/pcal/files/patch-ae
@@ -0,0 +1,19 @@
+--- pcal.man.orig Thu Dec 21 10:10:45 2000
++++ pcal.man Thu Dec 21 10:11:15 2000
+@@ -443,14 +443,14 @@
+ `&#NNN;' (NNN = any three decimal digits) are also supported. These will
+ be propagated intact (be sure to escape the `#' in `&#NNN;') if the output
+ is specified as HTML (see the
+-.B -\H
++.B \-H
+ flag); otherwise they will be converted to their ASCII equivalents. This
+ allows a common date file to be used regardless of whether the desired
+ output format is HTML, PostScript, or
+ Un*x
+ .I "calendar(1)"
+ (see the
+-.B -\c
++.B \-c
+ flag) input.
+ .PP
+ Lines in the
diff --git a/print/pcal/pkg-comment b/print/pcal/pkg-comment
new file mode 100644
index 000000000000..05899ae556e8
--- /dev/null
+++ b/print/pcal/pkg-comment
@@ -0,0 +1 @@
+PostScript calendar program
diff --git a/print/pcal/pkg-descr b/print/pcal/pkg-descr
new file mode 100644
index 000000000000..f470809c8835
--- /dev/null
+++ b/print/pcal/pkg-descr
@@ -0,0 +1,9 @@
+"Pcal" is a program to print PostScript calendars for any month and
+year. By default, it looks for a file in the home directory named
+"calendar" for entries with leading dates matching dates on the
+calendar, and prints any following text under the appropriate day.
+
+WWW: http://www.geocities.com/SunsetStrip/Palms/5555/PS/
+
+--
+mwest@uct.ac.za
diff --git a/print/pcal/pkg-plist b/print/pcal/pkg-plist
new file mode 100644
index 000000000000..488e30d58346
--- /dev/null
+++ b/print/pcal/pkg-plist
@@ -0,0 +1,6 @@
+bin/pcal
+libexec/pcal.cgi
+share/doc/pcal/ReadMe
+share/doc/pcal/pcal.html
+share/doc/pcal/pcalw.html
+@dirrm share/doc/pcal