aboutsummaryrefslogtreecommitdiff
path: root/print/pdfbox
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-02-06 13:51:15 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-02-06 13:51:15 +0000
commite27dbec5225f023c00c7d2ad60d96cd5a1573612 (patch)
treee417cd1fe677a57fc18177f91417d96db433134b /print/pdfbox
parent13efbf88f0a9bc7fe5da696c339c608dd8d849d6 (diff)
downloadports-e27dbec5225f023c00c7d2ad60d96cd5a1573612.tar.gz
ports-e27dbec5225f023c00c7d2ad60d96cd5a1573612.zip
- Update to 1.8.4 release
- Overhaul port - Stagify - Take maintainership
Notes
Notes: svn path=/head/; revision=343078
Diffstat (limited to 'print/pdfbox')
-rw-r--r--print/pdfbox/Makefile27
-rw-r--r--print/pdfbox/distinfo16
-rw-r--r--print/pdfbox/pkg-descr25
3 files changed, 33 insertions, 35 deletions
diff --git a/print/pdfbox/Makefile b/print/pdfbox/Makefile
index 4f7f71176cdf..2a11413f299d 100644
--- a/print/pdfbox/Makefile
+++ b/print/pdfbox/Makefile
@@ -2,38 +2,35 @@
# $FreeBSD$
PORTNAME= pdfbox
-PORTVERSION= 1.8.1
+PORTVERSION= 1.8.4
CATEGORIES= print textproc java
MASTER_SITES= ${MASTER_SITE_APACHE:S,%SUBDIR%,pdfbox/${PORTVERSION},}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTFILES= ${PORTNAME}-app-${PORTVERSION}.jar \
- fontbox-${PORTVERSION}.jar jempbox-${PORTVERSION}.jar
+DISTFILES= ${JAR_NAMES:S/$/-${PORTVERSION}.jar/}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Java PDF Library
+MAINTAINER= ale@FreeBSD.org
+COMMENT= Java tool for working with PDF documents
LICENSE= APACHE20
RUN_DEPENDS= ${JAVAJARDIR}/bcmail.jar:${PORTSDIR}/java/bouncycastle \
${JAVALIBDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging
-USE_JAVA= yes
-JAVA_VERSION= 1.6+
+JAR_NAMES= pdfbox fontbox jempbox preflight xmpbox
-DIST_SUBDIR= ${PORTNAME}
+USE_JAVA= yes
NO_EXTRACT= yes
NO_BUILD= yes
-PLIST_FILES= %%JAVAJARDIR%%/fontbox-${PORTVERSION}.jar \
- %%JAVAJARDIR%%/jempbox-${PORTVERSION}.jar \
- %%JAVAJARDIR%%/${PORTNAME}-app-${PORTVERSION}.jar
+PLIST_FILES= ${JAR_NAMES:S/^/%%JAVAJARDIR%%\//:S/$/.jar/}
-NO_STAGE= yes
do-install:
@${ECHO_MSG} -n ">> Installing JAR files in ${JAVAJARDIR}..."
- @${MKDIR} ${JAVAJARDIR}
- @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*-${PORTVERSION}.jar \
- ${JAVAJARDIR}
+ @${MKDIR} ${STAGEDIR}${JAVAJARDIR}
+.for f in ${JAR_NAMES}
+ ${INSTALL_DATA} ${DISTDIR}/${f}-${PORTVERSION}.jar \
+ ${STAGEDIR}${JAVAJARDIR}/${f}.jar
+.endfor
@${ECHO_MSG} " [ DONE ]"
.include <bsd.port.mk>
diff --git a/print/pdfbox/distinfo b/print/pdfbox/distinfo
index 754460548ca6..f2f91979ff18 100644
--- a/print/pdfbox/distinfo
+++ b/print/pdfbox/distinfo
@@ -1,6 +1,10 @@
-SHA256 (pdfbox/pdfbox-app-1.8.1.jar) = af8ca208421ebc1db685cc47d04b3da488d019f5598c518882e53bca1f5fdd18
-SIZE (pdfbox/pdfbox-app-1.8.1.jar) = 10468862
-SHA256 (pdfbox/fontbox-1.8.1.jar) = 999c4481d265163ca67a5c5d5a4e10c0d3fc3a49813f5c6f59d76139f04e6888
-SIZE (pdfbox/fontbox-1.8.1.jar) = 205153
-SHA256 (pdfbox/jempbox-1.8.1.jar) = efd6895a66f7bd36db3e563d87e833d392608abac4af311125d64ca99b7f5491
-SIZE (pdfbox/jempbox-1.8.1.jar) = 50972
+SHA256 (pdfbox-1.8.4.jar) = 097d89d010625d4dab99d1d384624ae97707b9a990cb2539a1576f5a5ec29f5f
+SIZE (pdfbox-1.8.4.jar) = 3997494
+SHA256 (fontbox-1.8.4.jar) = fff0788fd5962af0e096efa36ffe0cd49133b326a49f4365c2d587dd9ff663d3
+SIZE (fontbox-1.8.4.jar) = 205430
+SHA256 (jempbox-1.8.4.jar) = 4daa7fe823c5c2c55dd450a5b5111a0c198b86982f1087736138884c0a34a214
+SIZE (jempbox-1.8.4.jar) = 50980
+SHA256 (preflight-1.8.4.jar) = 22bc4b2c672d8fbe5d5c79eaa1c577c52c45f2ab2baf83f61a5d4b68ec67bb28
+SIZE (preflight-1.8.4.jar) = 297410
+SHA256 (xmpbox-1.8.4.jar) = 6aa0be8cfa3ad54345d32f837353c646f382febc0bdfb8875f457aa837a90c08
+SIZE (xmpbox-1.8.4.jar) = 114621
diff --git a/print/pdfbox/pkg-descr b/print/pdfbox/pkg-descr
index b83a7df8df85..3d82c6635079 100644
--- a/print/pdfbox/pkg-descr
+++ b/print/pdfbox/pkg-descr
@@ -1,19 +1,16 @@
-Apache PDFBox - Java PDF Library
-
-Apache PDFBox is an open source Java PDF library for working with PDF
+The Apache PDFBox library is an open source Java tool for working with PDF
documents. This project allows creation of new PDF documents, manipulation of
existing documents and the ability to extract content from documents. Apache
-PDFBox also includes a command line utility.
-
-Features
+PDFBox also includes several command line utilities.
- * PDF to text extraction
- * Merge PDF Documents
- * PDF Document Encryption/Decryption
- * Lucene Search Engine Integration
- * Fill in form data FDF and XFDF
- * Create a PDF from a text file
- * Create images from PDF pages
- * Print a PDF
+Features:
+ - Text extraction
+ - Merging & Splitting
+ - Forms Filling
+ - PDF/A Validation
+ - PDF Printing
+ - PDF to Image Conversion
+ - PDF Creation
+ - PDF Signing
WWW: http://pdfbox.apache.org/